Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libproxy1-0.5.3-150600.2.2 RPM for aarch64

From OpenSuSE Leap 15.6 for aarch64

Name: libproxy1 Distribution: SUSE Linux Enterprise 15
Version: 0.5.3 Vendor: SUSE LLC <https://www.suse.com/>
Release: 150600.2.2 Build date: Thu May 9 14:30:18 2024
Group: System/Libraries Build host: h04-armsrv1
Size: 67496 Source RPM: libproxy-client-0.5.3-150600.2.2.src.rpm
Packager: https://www.suse.com/
Url: http://libproxy.github.io/libproxy/
Summary: Automatic proxy configuration management for applications
libproxy is a library that provides automatic proxy configuration
management.

Proxy autoconfiguration (PAC) requires JavaScript (which most
applications do not have), and determing the PAC script location
requires a WPAD protocol implementation, which complicates proxy
support. libproxy exists to abstract this issue and provides
an answer how to reach a certain network resource.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Tue Mar 19 2024 yfjiang@suse.com
  - Do not use %elif by now since SLE, Leap does not have an rpm
    supporting the tag.
* Wed Feb 28 2024 dimstar@opensuse.org
  - Drop pkgconfig(libsoup-3.0) BuildRequires: no longer needed.
* Wed Sep 13 2023 dimstar@opensuse.org
  - Add libpxbackend-1_0 to baselibs.conf: required by libproxy.so.1.
* Wed Aug 16 2023 dimstar@opensuse.org
  - Generate libpxbackend-1_0-mini to be used inside OBS: the backend
    is built without additional dependencies like cURL. So there is
    no wpad/pac support in this variant. Helps break a build cycle.
* Thu Jul 13 2023 dimstar@opensuse.org
  - Update to version 0.5.3:
    + Fix crash querying URLs without a host.
    + Web: Update application page.
    + Add appplication info about apt and python requests.
* Fri Jun 16 2023 dimstar@opensuse.org
  - Update to version 0.5.2:
    + Link with libsocket where needed.
    + Remove libsoup from doc and CI.
    + Fix coverity findings.
    + Add a comment that docs option needs introspection.
    + Set pac data after download only.
    + Fix race condition in px_manager_get_proxies_sync.
    + Update gobject dependency in pkgconfig file.
    + Reread env variables in each get_config call.
* Fri Jun 02 2023 dimstar@opensuse.org
  - Update to version 0.5.1:
    + Guard PxManager test with pacrunner-duktape option.
    + Install libpxbackend into pkglibdir.
    + Move glib2 inclusion out of c++ protection.
    + Replace libsoup with glib socket service functions.
    + Use glib-object header instead of gio.
    + Fix libproxy rpath.
    + Draft: Improve ignore checks.
  - Drop pkgconfig(libpeas-1.0) BuildRequires: libpeas is no longer
    needed.
  - Add pkgconfig(gobject-introspection-1.0) BuildRequires: this was
    used before, but pulled in by libpeas.
* Fri Jun 02 2023 dimstar@opensuse.org
  - Update to version 0.5.0:
    + Complete rewrite, now actively maintained by Volkswagen.
  - Drop libproxy-perl-cflags.patch: no longer applicable as the
    bindings were ported to gobject-introspection.
  - Adjusted build dependencies:
    + Dropped cmake, gcc-c++, netcfg, pkgconfig, zlib-devel,
      NetworkManager-devel, dbus-1-devel, perl, python-rpm-macros,
      python3-devel, python-devel, pkgconfig(gio-2.0) >= 2.26,
      pkgconfig(gobject-2.0), pkgconfig(javascriptcoregtk-4.0),
      libKF5ConfigCore5, pkgconfig(mozjs-38), mono-devel.
    + Added meson, sysuser-tools, vala, pkgconfig(glib-2.0),
      pkgconfig(libpeas-1.0), pkgconfig(gi-docgen),
      pkgconfig(gsettings-desktop-schemas), pkgconfig(libcurl),
      pkgconfig(libsoup-3.0).
  - Change multibuild flavors to build a client library
    (libproxy.so.1 plus consumer include files) and a backend flavor
    (pxbackend, linked against cURL, duktape; the lib doing the
    actual work. The split is needed to break up build cycles with
    curl).
  - Drop no longer existing subpackages libproxy1-config-kde,
    libproxy1-config-gnome3, libproxy1-config-pacrunner,
    libproxy1-networkmanager, libproxy1-pacrunner-duktape,
    libproxy1-pacrunner-webkit, libproxy1-pacrunner-mozjs,
    python-libproxy, python3-libproxy, perl-Net-Libproxy,
    libproxy-sharp. All the language bindings are now handled by
    gobject-introspection.
  - Introduce the new sub packages typelib-1_0-Libproxy-1_0,
    libpxbackend-1_0, and libproxy-devel-doc.
* Thu Jun 01 2023 fcrozat@suse.com
  - Only build mono support on openSUSE, not SLE nor SUSE ALP.
* Tue Jun 21 2022 dimstar@opensuse.org
  - Add libproxy-perl-cflags.patch: perl: Use ccflags from %Config
    for libproxy module compilation; fixes perl test suite on i586.
* Mon Jun 20 2022 dimstar@opensuse.org
  - Update to version 0.4.18:
    + build: Allow configuration of sysconfig module.
    + config_envvar: Add environment variable for pacrunner
      debugging.
    + build: disable mozjs by default.
    + python: Support Python 3.10 and above.
    + Add Duktape pacrunner module.
    + config_kde: Compute list of config file locations ourselves.
    + cpmfog_gnome3: Add gnome-wayland to permitted DESKTOP_SESSION.
  - Drop libproxy-python-310.patch: fixed upstream.
  - Build duktape pacrunner module:
    + Add pkgconfig(duktape): new dependency.
    + Split new subpackage libproxy1-pacrunner-duktape.
    + Suggest duktape pacrunner for config modules recommending a
      pacrunner.
* Mon May 16 2022 dimstar@opensuse.org
  - Add libproxy-python-310.patch: Detect python 3.10.
* Thu Feb 10 2022 bjorn.lie@gmail.com
  - Drop gconf2-devel BuildRequires: libproxy was ported to gsettings
    quite some time ago.
  - Update our Supplements to current standard.
* Tue Jul 13 2021 dimstar@opensuse.org
  - Do no longer BuildRequire libmodman-devel: libproxy 0.4.17 was
    changed upstream to only support to internal version (no other
    consumer of libmodman exists).
  - No longer pass -DFORCE_SYSTEM_LIBMODMAN=ON to cmake: not
    understood anymore (boo#1188265).
* Tue Dec 29 2020 dimstar@opensuse.org
  - Update to version 0.4.17:
    + python bindings: fix "TypeError: argtypes must be a sequence of
      types".
  - Drop 147.patch: fixed upstream.
* Mon Dec 14 2020 dimstar@opensuse.org
  - Add 147.patch: python bindings: fix "TypeError: _argtypes_ must
    be a sequence of types".
* Fri Dec 04 2020 dimstar@opensuse.org
  - Update to version 0.4.16:
    + Port to, and require, SpiderMonkey 6.
    + Use closesocket() instead of close() on Windows.
    + Add symbol versions - be ready to introduce new APIs as needed.
    + Add public px_proxy_factory_free_proxies function.
    + Add PacRunner config backend (largely untested; feedback
      welcome!).
    + Small performance improvements.
    + pxgsettings: use the correct syntax to connect to the changed
      signal (silences annoying output on console).
    + Support python3 up to version 3.9.
    + Fix buffer overflow when PAC is enabled (CVE-2020-26154).
    + Rewrite url::recvline to be nonrecursive (CVE-2020-25219).
    + Remove nonfunctional and crashy pacrunner caching.
    + Never use system libmodman (no other consumers, not
      maintained).
  - Drop upstream merged patches:
    + libproxy-python3.7.patch
    + libproxy-pxgsettings.patch
    + libproxy-CVE-2020-25219.patch
    libproxy-fix-pac-buffer-overflow.patch
  - Create new sub-package libproxy1-config-pacrunner.
* Wed Sep 30 2020 mgorse@suse.com
  - Add libproxy-CVE-2020-25219.patch: Rewrite url::recvline to be
    nonrecursive (boo#1176410 CVE-2020-25219).
  - Add libproxy-fix-pac-buffer-overflow.patch: fix buffer overflow
    when PAC is enabled (boo#1177143 CVE-2020-26154).
* Mon Sep 14 2020 yfjiang@suse.com
  - Build with KDE on Tumbleweed, Leap and SLE releases greater than
    SLE-15-SP2 (jsc#SLE-12256).
* Mon Apr 27 2020 dimstar@opensuse.org
  - Add libproxy-pxgsettings.patch: pxgsettings: use the correct
    syntax to connect to the changed signal.
* Thu Mar 12 2020 tchvatal@suse.com
  - Remove few SLE11 conditions
  - Fix build without python2 available
* Wed Dec 12 2018 dimstar@opensuse.org
  - Convert package from multispec to multibuild.
* Fri Oct 05 2018 dimstar@opensuse.org
  - Update Url tag to point to http://libproxy.github.io/libproxy/
  - Add libproxy-python3.7.patch: Support python 3.7 and 3.8.
  - Drop py_requires: no longer needed.
* Sat Jul 07 2018 bjorn.lie@gmail.com
  - Drop favor_gtk2 conditional.
* Thu Feb 22 2018 fvogt@suse.com
  - Use %license (boo#1082318)
* Thu Sep 07 2017 jengelh@inai.de
  - Update descriptions and RPM categories.
* Thu May 11 2017 dimstar@opensuse.org
  - Update to version 0.4.15:
    + Port to, and require, SpiderMonkey 38.
    + Fix "NetworkManager plugin not being built"
      (gh#libproxy/libproxy#53).
    + Fix "networkmanager plugin not working
      (gh#libproxy/libproxy#58).
    + Fix "Invalid read after free" (gh#libproxy/libproxy#59).
    + Fix intermittent unit test failures.
  - Replace pkgconfig(mozjs185) buildRequires with
    pkgconfig(mozjs-38), following upstream.
* Mon Feb 06 2017 dimstar@opensuse.org
  - Have libproxy1-config-kde require libqt5-qtpaths instead of
    libqt5-qttools on openSUSE > 13.2 / openSUSE > Leap 42.x
    (boo#988808).
* Mon Jan 09 2017 dimstar@opensuse.org
  - Update to version 0.4.14:
    + Parallel build support for python2 and python3.
    - DWITH_PYTHON has been replaced with -DWITH_PYTHON2 and
    - DWITH_PYTHON3 to have full control over this. Default is
      ON for both (gh#libproxy/libproxy#22).
    + Minor fixes to the PAC retriever code
      (gh#libproxy/libproxy#40).
    + Fallback to mcs instead of gmcs for the mono bindings
      (gh#libproxy/libproxy#37).
    + Fix build using cmake 3.7.
    + Fix deprecation warnings of pxgsettings with glib 2.46.
    + Improve the get-pac test suite (gh#libproxy/libproxy#47).
  - Drop update-from-svn.sh: The script has not been usable for
    years, since libproxy is no longer hosted in this svn repo.
  - Drop upstream merged patches:
    + libproxy-cmake-3.7.patch
    + libproxy-FindMono-4.6.patch
    + libproxy-gnome-waitpid.patch
    + libproxy-python3-support.patch
  - Re-enable the test suite: with the upstream changes this should
    now be more reliable.
* Tue Nov 22 2016 dimstar@opensuse.org
  - Add libproxy-cmake-3.7.patch: Fix build with cmake 3.7.
* Thu Sep 29 2016 dimstar@opensuse.org
  - Add libproxy-FindMono-4.6.patch: Fall back to mcs if gmcs cannot
    be found. Fixes issues with mono 4.6, which no longer ships the
    wrapper by default.
* Mon Aug 08 2016 dimstar@opensuse.org
  - Add libproxy-python3-support.patch: Allow to build PYTHON2 and
    PYTHON3 bindings during the same build phase.
  - Create new subpackage python3-libproxy.
  - Add python3-devel BuildRequires when not building core.
* Fri Jul 22 2016 dimstar@opensuse.org
  - Add libproxy-gnome-waitpid.patch: GNOME3: Wait for pxgsettings to
    vanish while destroying the plugin (boo#967601).
* Fri May 20 2016 alarrosa@suse.com
  - Update to GNOME 3.20.2 (Fate#318572, bnc#980527)
* Tue May 10 2016 dimstar@opensuse.org
  - Require libqt5-qttools by libproxy1-config-kde: the plugin spawns
    qtpaths to find the right config files (boo#979232).
  - Trigger libproxy1-config-kde for installation when
    plasma5-session and libproxy1 are installed.
* Mon May 09 2016 dimstar@opensuse.org
  - Fix condition to not build KDE plugin for SLE.
* Thu Apr 28 2016 dimstar@opensuse.org
  - Update to version 0.4.13:
    + Allow linking webkit pacrunner against javascriptcore-4.0
      (webkit2).
    + Allow to disable building of the KDE module
      (-DWITH_KDE=ON/OFF).
    + Fix compilation errors with CLang on MacOSX.
    + bindings: perl: Add an option to explicitly link against
      libperl.so. Some distributions want to do it, other prefer not
      to, the library is anyway in context of perl.
    + config_kde: Add a basic cache and invalidation: performance
      improvement for the KDE module.
  - Pass -DWITH_KDE=OFF to cmake when building core.
  - Replace pkgconfig(webkitgtk-3.0) BuildRequires with
    pkgconfig(javascriptcoregtk-4.0): make use of the WebKit2 port.
* Fri Apr 15 2016 mgorse@suse.com
  - Update to GNOME 3.20  Fate#318572
* Thu Jan 14 2016 fcrozat@suse.com
  - Disable building libproxy-config-kde on SLE.
* Tue Jan 12 2016 dimstar@opensuse.org
  - Update to version 0.4.12:
    + Move development to github.com/libproxy/libproxy.
    + Fix fd leak in get_pac (Bug #185).
    + Detect running MATE session (Bug #186, Part1).
    + Fix linking of perl bindings to pthread (Bug #182).
    + Correctly detect spidermonky (mozjs185) (Bug #188).
    + Stop pxgsettings from segfaulting on exit (Bug #192).
    + Fix test #10 (Bug #189).
    + Fix build on Mac OS X (Bug #183).
    + Add a generic KDE Config module (fix crashes of Qt5 based
      apps) (issue#4).
  - Drop upstream fixed patches:
    + libproxy-pxgsettings-crash.patch
    + libproxy-no-libperl.patch
    + libproxy-pxgsettings-signals.patch
  - Rename libproxy1-config-kde4 subpackage to libproxy-config-kde,
    following upstreams introduction of the generic config loader.
  - Require libKF5ConfigCore5 from libproxy1-config-kde (we don't
    really need the library, but kreadconfig5 in this package).
  - Replace libkde4-devel and libqt4-devel BuildRequires with
    libKF5ConfigCore5: the new KDE config parser interacts directly
    with kreadconfig5 and does not link to Qt.
* Fri May 15 2015 dimstar@opensuse.org
  - Add libproxy-pxgsettings-signals.patch: Fix for pxgsettins not
    actively monitoring gsetting changes. Due to recent changes in
    GLib, only values are being monitored, that are read AFTER the
    signal handler is attached.
  - Adjust baselibs.conf to match what is currenly being built.

Files

/usr/lib64/libproxy.so.1


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jul 9 20:14:19 2024