Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

hamcrest-core-1.3-lp152.6.37 RPM for noarch

From OpenSuSE Leap 15.2 for noarch

Name: hamcrest-core Distribution: openSUSE Leap 15.2
Version: 1.3 Vendor: openSUSE
Release: lp152.6.37 Build date: Tue Jun 9 13:32:40 2020
Group: Development/Libraries/Java Build host: cloud121
Size: 50054 Source RPM: hamcrest-1.3-lp152.6.37.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/hamcrest/JavaHamcrest
Summary: Core API of hamcrest matcher framework.
The core API of hamcrest matcher framework to be used by third-party framework providers.
This includes the a foundation set of matcher implementations for common operations.

Provides

Requires

License

BSD-3-Clause

Changelog

* Wed Oct 02 2019 Fridrich Strba <fstrba@suse.com>
  - Remove references to the hamcrest-parent pom and do not
    distribute it
    * useless since we don't build with maven
    * creates problems with gradle connector
* Tue Jan 15 2019 Fridrich Strba <fstrba@suse.com>
  - Make jmock and easymock integration opt-in (bsc#1121956)
* Fri Jan 04 2019 Fridrich Strba <fstrba@suse.com>
  - Use sources from github, which are accessible
  - Do not build the hamcrest-text empty jar
  - Split a core package off the main package
  - Added patch:
    * hamcrest-1.3-qdox-2.0.patch
      + Fix build against QDox 2.0
  - Removed patch:
    * hamcrest-1.3-no-integration.patch
      + Not needed any more since integration is buildable
  - Modified patches:
    * hamcrest-1.3-build.patch
    * hamcrest-1.3-fork-javac.patch
    * hamcrest-1.3-javadoc.patch
    * hamcrest-1.3-javadoc10.patch
    * hamcrest-1.3-javadoc9.patch
    * hamcrest-1.3-no-jarjar.patch
    * hamcrest-1.3-random-build-crash.patch
* Mon Dec 18 2017 fstrba@suse.com
  - Added patch:
    * hamcrest-1.3-javadoc10.patch
      + Fix build with jdk10's javadoc that ends in error when a
      link cannot be downloaded
* Fri Sep 08 2017 fstrba@suse.com
  - Modified patch:
    * hamcrest-1.3-fork-javac.patch
      + Specify java target level 1.6 in order to allow building
      with jdk9
  - Specify java source level 1.6 in order to allow building with
    jdk9
  - Added patch:
    * hamcrest-1.3-javadoc9.patch
      + fix javadoc errors that are fatal in jdk9
* Mon May 29 2017 tchvatal@suse.com
  - Apply patch from fedora:
    * hamcrest-1.3-fork-javac.patch
* Fri May 19 2017 tchvatal@suse.com
  - Fix homepage
  - Update to build with new javapacakges-tools
* Wed Mar 18 2015 tchvatal@suse.com
  - Fix build with new javapackages-tools
* Mon Jul 07 2014 tchvatal@suse.com
  - Use junit not junit4
* Mon Jun 16 2014 tchvatal@suse.com
  - Add patch to fix random build errors by enforcing single thread.
    * hamcrest-1.3-random-build-crash.patch

Files

/usr/share/java/hamcrest
/usr/share/java/hamcrest/core.jar
/usr/share/licenses/hamcrest-core
/usr/share/licenses/hamcrest-core/LICENSE.txt
/usr/share/maven-metadata/hamcrest-core.xml
/usr/share/maven-poms/hamcrest
/usr/share/maven-poms/hamcrest/core.pom


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Feb 9 11:43:03 2024