Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

geany-plugins-vimode-1.37-2.mga8 RPM for aarch64

From Mageia 8 for aarch64 / media / core / release

Name: geany-plugins-vimode Distribution: Mageia
Version: 1.37 Vendor: Mageia.Org
Release: 2.mga8 Build date: Wed Dec 30 22:26:41 2020
Group: Development/Tools Build host: localhost
Size: 159772 Source RPM: geany-plugins-1.37-2.mga8.src.rpm
Packager: luigiwalser <luigiwalser>
Url: https://plugins.geany.org
Summary: Vim-mode plugin for Geany
Vimode is a Vim-mode plugin for Geany written by a guy who does not use Vim.

Despite the limited Vim knowledge of the author, the plugin tries to be a
reasonably complete Vim mode implementation featuring:

* normal mode, insert/replace mode, visual mode, line visual mode
* repeated commands (e.g. 10dd - delete 10 lines)
* "motion" commands (e.g. d10l - delete 10 characters to the right)
* "text object" commands (e.g. di( - delete inner contents of parentheses)
* visual mode commands (e.g. ~ to swap case of the selected text)
* basic ex mode commands like :s, including range specifications (e.g.
  :5,8s/foo/bar/g - replace foo with bar on lines 5 through 8)
* most basic navigation, selection and text manipulation commands
  - see the end of this file for the full list
* command repetition using "." and repeated insert

Provides

Requires

License

GPLv2+ and GPLv3+

Changelog

* Wed Dec 30 2020 luigiwalser <luigiwalser> 1.37-2.mga8
  + Revision: 1666239
  - rebuild for libgit2
* Tue Nov 03 2020 akien <akien> 1.37-1.mga8
  + Revision: 1642211
  - Version 1.37
* Fri Jul 24 2020 daviddavid <daviddavid> 1.36-3.mga8
  + Revision: 1608636
  - rebuild for new libgit2 1.0.1
  - add upstream patch to make libgit2 version preprocessor conditionals
    compatible with libgit2-0.99
* Sun Feb 16 2020 umeabot <umeabot> 1.36-2.mga8
  + Revision: 1534813
  - Mageia 8 Mass Rebuild
  + wally <wally>
  - replace deprecated %configure2_5x
* Sun Oct 06 2019 daviddavid <daviddavid> 1.36-1.mga8
  + Revision: 1450014
  - new version: 1.36
  - switch to python3-docutils
  - re-enable plugin debugger, now ported to Gtk+3
* Wed May 01 2019 akien <akien> 1.35-1.mga7
  + Revision: 1396007
  - Version 1.35
* Sat Apr 20 2019 wally <wally> 1.34-4.mga7
  + Revision: 1393751
  - rebuild for libgit2 0.28.1
* Sun Feb 24 2019 wally <wally> 1.34-3.mga7
  + Revision: 1369880
  - drop unneeded enchant requires
* Sat Feb 23 2019 wally <wally> 1.34-2.mga7
  + Revision: 1369551
  - switch to gtk3
  - disable webkit1 plugin webhelper
  - disable gtk2 only plugins devhelp and multiterm
  - disable gtk2 only plugins debugger and geanypy

Files

/usr/lib/.build-id
/usr/lib/.build-id/41
/usr/lib/.build-id/41/74c06b6dc674172e0b9db5591f25b3a277e047
/usr/lib64/geany/vimode.so
/usr/share/doc/geany-plugins/vimode
/usr/share/doc/geany-plugins/vimode/AUTHORS
/usr/share/doc/geany-plugins/vimode/COPYING
/usr/share/doc/geany-plugins/vimode/README


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Dec 6 01:56:05 2021