Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libOpenCL1-2.3.1-1.7 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: libOpenCL1 Distribution: openSUSE Tumbleweed
Version: 2.3.1 Vendor: openSUSE
Release: 1.7 Build date: Wed Jun 15 05:27:40 2022
Group: Unspecified Build host: sheep86
Size: 193635 Source RPM: ocl-icd-2.3.1-1.7.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/OCL-dev/ocl-icd
Summary: OpenCL ICD Bindings
OpenCL is a royalty-free standard for cross-platform, parallel programming
of modern processors found in personal computers, servers and
handheld/embedded devices.

This package provides an Installable Client Driver Bindings (ICD Bindings).
The provided libOpenCL library is able to load any free or non-free installed
ICD (driver backend).

Provides

Requires

License

BSD-2-Clause

Changelog

* Fri Aug 20 2021 Martin Hauke <mardnh@gmx.de>
  - Update to version 2.3.1
    * Khronos Header Compatibility
  - Remove patch (included upstream):
    * 0001-Updated-to-support-latest-Khronos-headers.patch
* Tue Aug 17 2021 Marcus Meissner <meissner@suse.com>
  - overwrite the libopenCL.so.1 link in %post of baselibs. (bsc#1189433)
* Tue Jun 15 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Add upstream change to fix build:
    * 0001-Updated-to-support-latest-Khronos-headers.patch
* Wed Mar 31 2021 Martin Hauke <mardnh@gmx.de>
  - Update to version 2.3.0
    * Change OCL_ICD_LAYERS to OPENCL_LAYERS to conform to
      upecification
    * Updated layer support around official CL/cl_layer.h
    * Updated OpenCL Headers
    * Fixed typo in manpage
* Sat Dec 12 2020 Martin Hauke <mardnh@gmx.de>
  - Update to version 2.2.14
    * Added experimental support for layers
* Sat Oct 24 2020 Martin Hauke <mardnh@gmx.de>
  - Update to version 2.2.13
    * Removed warnings and use uniform warning suppression
    * Switched Khornos Headers to OpenCL3.0
    * Added OpenCL 3.0 support
    * Fix warning in gcc10
    * Updated loader and headers to support
      clSetContextDestructorCallback.
    * Call clGetDeviceIDs directly through the dispatch table
  - Drop patch:
    * ocl-icd-gcc10.patch (fixed upstream)
* Mon Aug 31 2020 Stefan Dirsch <sndirsch@suse.com>
  - added patch markups to specfile for better documentation
* Sat Aug 22 2020 Stefan Dirsch <sndirsch@suse.com>
  - n_UsrShare.patch
    * first try /etc/OpenCL/vendors, then /usr/share/OpenCL/vendors
    (boo#1173005, comment#8)
  - supersedes configure option --enable-custom-vendordir
* Tue Jun 23 2020 Stefan Dirsch <sndirsch@suse.com>
  - switch from /usr/etc/OpenCL/vendors to /usr/share/OpenCL/vendors
    for vendor specific .icd files (boo#1173005)
* Thu Jun 18 2020 Stefan Dirsch <sndirsch@suse.com>
  - switch to /usr/etc/OpenCL/vendors for vendor specific .icd files
    (boo#1173005); currently I'm only aware of Mesa using it (taking
    care about adjusting this myself); NVIDIA is using its own
    libOpenCL ...
* Wed Jun 03 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Add ocl-icd-gcc10.patch: Fix build with gcc10 (boo#1172436).
* Sat May 30 2020 Marcus Meissner <meissner@suse.com>
  - add baselibs.conf to build 32bit binaries for Wine (bsc#1172303)
* Wed Feb 26 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Remove condition for SLE11 build as it is unresolvable anyway
  - Require update-alternatives only where really needed
  - Require opencl-headers in the develpackage as otherwise all
    those that pull the devel would need to do it on their own.
* Mon Aug 05 2019 Antoine Belvire <antoine.belvire@opensuse.org>
  - Update to version 2.2.12:
    * Switched khronos headers to OpenCL 2.2.
    * Added OpenCL 2.2 support.
  - Update URL to GitHub repository since previous URL is not
    accessible anymore.
  - Only suggest pocl instead of recommending it.
  - Add check section.
* Sat Jan 19 2019 mardnh@gmx.de
  - Add missing Requires(post): update-alternatives
* Mon Jan 14 2019 sndirsch@suse.com
  - limit usage of update-alernatives to sle15-sp1/Leap 15.1 and newer
* Sun Jan 13 2019 sndirsch@suse.com
  - sle15/Leap15 and newer: switch to usage of update-alternatives,
    so the package no longer conflicts with nvidia packages
    (boo#1108304)

Files

/etc/alternatives/libOpenCL.so.1
/usr/lib64/libOpenCL.so.1
/usr/lib64/ocl-icd
/usr/lib64/ocl-icd/libOpenCL.so.1
/usr/lib64/ocl-icd/libOpenCL.so.1.0.0
/usr/share/doc/packages/libOpenCL1
/usr/share/doc/packages/libOpenCL1/README


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Aug 7 23:27:41 2022