Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python312-qt5-5.15.10-1.5 RPM for s390x

From OpenSuSE Ports Tumbleweed for s390x

Name: python312-qt5 Distribution: openSUSE:Factory:zSystems
Version: 5.15.10 Vendor: openSUSE
Release: 1.5 Build date: Sun Oct 15 15:57:31 2023
Group: Development/Libraries/Python Build host: reproducible
Size: 26609995 Source RPM: python-qt5-5.15.10-1.5.src.rpm
Packager: https://bugs.opensuse.org
Url: https://www.riverbankcomputing.com/software/pyqt
Summary: Python bindings for Qt 5
PyQt is a set of Python bindings for the Qt framework.

Provides

Requires

License

SUSE-GPL-2.0-with-FLOSS-exception OR GPL-3.0-only OR NonFree

Changelog

* Sun Oct 15 2023 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.10
    * Added the missing QEvent.Type.NativeGesture member (Qt v5.2 and
      later).
    * Added the missing QEvent.Type.EnterEditFocus and
      QEvent.Type.LeaveEditFocus members.
    * PyQt5-sip v12.13 is now required for Python v3.12 support.
    * Bug fixes.
* Mon Jun 26 2023 Hans-Peter Jansen <hpj@urpla.net>
  - Fix shell stubs of pyuic5 pylupdate5 pyrcc5 in order to run the
    correct interpreter
* Sat Jun 10 2023 ecsos <ecsos@opensuse.org>
  - Add %{?sle15_python_module_pythons}
* Thu Feb 09 2023 Ben Greiner <code@bnavigator.de>
  - Update to v5.15.9
    * Fix the order in which modules are built so that the composite
      Qt module is built after everything it depends on.
* Sun Jan 29 2023 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.8
    * Added the missing QLocale.Language.NigerianPidgin member (Qt
      v5.15.2 and later).
    * Added the missing QOperatingSystemVersion.MacOSBigSure
      attribute (Qt v5.15.1 and later).
    * Added the missing QThreadPool.contains() method (Qt v5.15.1 and
      later).
    * Added the missing
      QBluetoothDeviceDiscoveryAgent.DiscoveryMethod members.
    * Bug fixes.
* Tue Jun 21 2022 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.7
    * Refactored the draw methods of QPainter to accept sip.array
      objects of appropriate types.  Such arrays, once initialised,
      can be used very efficiently as they do not require repeated
      conversion from the usual Python collection types.
    * Added the missing QBluetoothUuid constructors.
    * PyQt5-sip v12.11 is now required to enable support for
      sip.array.
    * Bug fixes.
  - PyQt5-sip 12.11 does not support Python 3.6: No build for SLE or
    Leap 15.x anymore!
* Thu Dec 23 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Fix dependencies of python-qt5-remoteobjects: do not require all
    python flavors (i.e. avoid requires python_module).
* Thu Nov 04 2021 Ben Greiner <code@bnavigator.de>
  - Remove py_ssize_t_clean argument from QtCoremod.sip in order to
    make downstream packages buildable with sip < 6.4 -- boo#1192300
* Wed Nov 03 2021 Ben Greiner <code@bnavigator.de>
  - Don't require python-sip-devel for python-qt5-devel. The project
    building against PyQt should explicitly know about the proper
    requirement. -- boo#1192300
* Fri Oct 29 2021 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.6
    * Bug fixes
    * affecting source builds for Python 3.10
    * minor improvements to the QObject type hints
* Tue Oct 19 2021 Ben Greiner <code@bnavigator.de>
  - Update to v5.15.5
    * Added the missing QPdfWriter.setPageSize() overload.
    * pylupdate5 now assumes that the default codec is UTF-8 and
      specified v2.1
      as the .ts file format.
    * Bug fixes.
  - Silence some rpmlint errors
* Tue Jul 06 2021 Ben Greiner <code@bnavigator.de>
  - remove the noop %requires_ge libqt5-x11
* Wed Apr 14 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Remove the QtWebKit dependency everywhere.
    The QtWebKit module was abandoned upstream years ago and the
    community fork didn't get far. The only package that had a
    dependency on qtwebkit bindings (spyder) was fixed.
* Thu Mar 11 2021 Ben Greiner <code@bnavigator.de>
  - Update to version 5.15.4
    * Packaging bug fixes.
  - Fixes problems with packages checking the package metadata like
    boo#1183144
* Thu Feb 25 2021 Ben Greiner <code@bnavigator.de>
  - Update to version 5.15.3
    * Added the missing QImage.setAlphaChannel().
    * Support for the QtNetworkAuth library has been moved to a
      separate PyQtNetworkAuth package.
    * Bug fixes.
  - Disable the build for SIPv4 and Python2. It does not build
    anymore. According to upstream, the change was not intentional,
    albeit SIP v4 is not officially supported anymore. We use this
    opportunity to ditch the old cruft. Moves the SLE/Leap builds
    to SIP v5.
  - Remove unused QtWebEngine libraries from build system. Those are
    handled in the python-qtwebengine-qt5 package.
* Tue Feb 23 2021 Benjamin Greiner <code@bnavigator.de>
  - Remove the unnecessary strict binary compatibility requirement
    for PyQt5.sip: python-sip[56]-devel will not runtime require any
    PyQt[56].sip module anymore and the %requires_eq would do nothing
    because the package is not installed.
* Mon Feb 22 2021 Benjamin Greiner <code@bnavigator.de>
  - Some rpmlint runs were complaining that the PyQt5 dir was not
    also owned by the nonring extra packages

Files

/usr/lib/python3.12/site-packages/dbus
/usr/lib/python3.12/site-packages/dbus/mainloop
/usr/lib/python3.12/site-packages/dbus/mainloop/pyqt5.py
/usr/lib64/python3.12/site-packages/PyQt5
/usr/lib64/python3.12/site-packages/PyQt5-5.15.10.dist-info
/usr/lib64/python3.12/site-packages/PyQt5-5.15.10.dist-info/INSTALLER
/usr/lib64/python3.12/site-packages/PyQt5-5.15.10.dist-info/METADATA
/usr/lib64/python3.12/site-packages/PyQt5-5.15.10.dist-info/RECORD
/usr/lib64/python3.12/site-packages/PyQt5/Qt.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtBluetooth.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtBluetooth.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtCore.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtCore.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtDBus.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtDBus.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtDesigner.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtDesigner.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtGui.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtGui.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtHelp.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtHelp.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtLocation.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtLocation.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtMultimedia.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtMultimedia.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtMultimediaWidgets.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtMultimediaWidgets.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtNetwork.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtNetwork.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtNfc.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtNfc.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtOpenGL.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtOpenGL.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtPositioning.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtPositioning.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtPrintSupport.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtPrintSupport.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtQml.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtQml.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtQuick.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtQuick.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtQuickWidgets.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtQuickWidgets.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtSerialPort.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtSerialPort.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtSql.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtSql.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtSvg.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtSvg.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtTest.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtTest.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtTextToSpeech.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtTextToSpeech.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtWebChannel.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtWebChannel.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtWebSockets.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtWebSockets.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtWidgets.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtWidgets.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtX11Extras.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtX11Extras.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtXml.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtXml.pyi
/usr/lib64/python3.12/site-packages/PyQt5/QtXmlPatterns.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/QtXmlPatterns.pyi
/usr/lib64/python3.12/site-packages/PyQt5/_QOpenGLFunctions_2_0.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/_QOpenGLFunctions_2_1.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/_QOpenGLFunctions_4_1_Core.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/dbus_mainloop.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/py.typed
/usr/lib64/python3.12/site-packages/PyQt5/pylupdate.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/pylupdate_main.py
/usr/lib64/python3.12/site-packages/PyQt5/pyrcc.abi3.so
/usr/lib64/python3.12/site-packages/PyQt5/pyrcc_main.py
/usr/lib64/python3.12/site-packages/PyQt5/sip.pyi
/usr/lib64/python3.12/site-packages/PyQt5/uic
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/compiler.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/indenter.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/misc.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/proxy_metaclass.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/qobjectcreator.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Compiler/qtproxies.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Loader
/usr/lib64/python3.12/site-packages/PyQt5/uic/Loader/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Loader/loader.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/Loader/qobjectcreator.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/driver.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/exceptions.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/icon_cache.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/objcreator.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2/as_string.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2/ascii_upper.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2/proxy_base.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v2/string_io.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3/__init__.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3/as_string.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3/ascii_upper.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3/proxy_base.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/port_v3/string_io.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/properties.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/pyuic.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/uiparser.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qaxcontainer.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qscintilla.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qtcharts.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qtprintsupport.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qtquickwidgets.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qtwebenginewidgets.py
/usr/lib64/python3.12/site-packages/PyQt5/uic/widget-plugins/qtwebkit.py
/usr/lib64/qt5/plugins/PyQt5
/usr/lib64/qt5/plugins/PyQt5/libpy3.12qt5qmlplugin.so
/usr/share/doc/packages/python312-qt5
/usr/share/doc/packages/python312-qt5/ChangeLog
/usr/share/doc/packages/python312-qt5/NEWS
/usr/share/doc/packages/python312-qt5/README
/usr/share/licenses/python312-qt5
/usr/share/licenses/python312-qt5/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jul 9 12:37:36 2024