Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libbrlapi0_8-6.5-1.2 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: libbrlapi0_8 Distribution: openSUSE Tumbleweed
Version: 6.5 Vendor: openSUSE
Release: 1.2 Build date: Thu Sep 1 12:17:50 2022
Group: System/Daemons Build host: obs-arm-11
Size: 67106 Source RPM: brltty-6.5-1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: https://brltty.app/
Summary: Library to use BRLTTY from applications
BrlAPI is a service provided by the brltty daemon.

Its purpose is to allow programmers to write applications that take
advantage of a braille terminal in order to deliver a blind user
suitable information for his/her specific needs.

While an application communicates with the braille terminal, everything
brltty sends to the braille terminal in the application's console is
ignored, whereas each piece of data coming from the braille terminal is
sent to the application, rather than to brltty.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Mon Jun 13 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 6.5
  - Update api_version.
  - Add brltty-udev-dir.patch: install udev rules into /usr/lib.
  - Remove the custom disabling of rules for generic USB serial
    devices, since upstream now has these separated out. Instead,
    provide these rules in a udev-generic package.
* Thu Feb 10 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Pass --with-tables-directory=%{_datadir}/%{name} to configure: do
    not install the tables to /etc, as they are not supposed to be
    modified by local admins.
* Tue Dec 14 2021 ohering@suse.de
  - Add python-rpm-macros (bsc#1180125)
* Tue Nov 23 2021 Callum Farmer <gmbr3@opensuse.org>
  - Add all sysusers.d Requires
* Sat Oct 02 2021 Callum Farmer <gmbr3@opensuse.org>
  - Move sysusers.d to separate package
  - Remove old SUSE RPM constructs
* Fri Oct 01 2021 Callum Farmer <gmbr3@opensuse.org>
  - Use sysuser-tools to process included sysusers.d file correctly
    (bsc#1191465)
* Sat Sep 25 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 6.4:
    + See ChangeLog for changes.
  - API version is now 0.8.3.
  - Add at-spi2 to BuildRequires. Now needed for at-spi driver.
* Tue Feb 02 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 6.3:
    + See ChangeLog for changes.
  - API version is now 0.8.2.
  - Drop brltty-fix-install-dirs.patch: no longer needed.
* Sun Jan 17 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Starting with the TCL 8.6.11 package, the default install path
    for the TCL library is corrected to /usr/lib64/tcl: adjust the
    move command for our tcl module basedon this change.
* Fri Jan 01 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 6.2:
    + See ChangeLog for changes.
  - Update api_version: now 0.8.1.
  - Replace brltty-5.5-systemd-install.patch with
    brltty-fix-install-dirs.patch: also adjust udev directory.
  - Drop brltty-gcc10.patch: fixed upstream.
  - Move udev rules patching to %build.
  - Use the Makefile to install udev and polkit rules and docs.
  - Brltty-config has been renamed to brltty-config.sh.
  - Remove polkit conditional: we always have it enabled.
  - Remove old espeak support: Leap prior to 15.0 is no longer
    supported.
  - Add python3-setuptools to BuildRequires: required by rpm during
    checks.
  - Add doxygen to BuildRequires: needed to build manual.
  - Create a brltty user on install: now expected by service.
* Wed Oct 14 2020 Michael Gorse <mgorse@suse.com>
  - Add coreutils and util-linux to post requires (boo#1177656).
* Tue Jul 07 2020 Callum Farmer <callumjfarmer13@gmail.com>
  - Fixes for %_libexecdir changing to /usr/libexec
* Thu Apr 09 2020 Michael Gorse <mgorse@suse.com>
  - Update to version 6.1:
    + See ChangeLog for changes.
  - Rebased brltty-5.5-systemd-install.patch
  - api_version is now 0.8.0, and sover is now 0_8
  - Add brltty-gcc10.patch: fix build with -fno-common.
  - Adjust line to remove xsession file.
  - Remove brltty-alsa.patch
* Wed Oct 09 2019 ro@suse.de
  - change udev rule again to also not automatically use the braille
    driver for USB IDs 10c4:ea60 and 10c4:ea80 as these are generic
    IDs of generic UART bridges and should not be used for higher
    level devices (bsc#1093378, bsc#1093455, bsc#1007652)
* Wed Jun 19 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
    allow OBS to shortcut by using systemd-devel-mini.
* Tue Mar 26 2019 olaf@aepfle.de
  - Use alsa API properly. Consumers are expected to use
    <alsa/asoundlib.h> instead of <asoundlib.h>.
    This is in preparation of an change to pkgconfig(alsa) to
    not pollute CFLAGS with -I/usr/include/alsa anymore (bsc#1130333)
    brltty-alsa.patch
* Thu Feb 28 2019 mgorse@suse.com
  - Update to version 6.0:
    + Too many changes; please read ChangeLog :
    - Rebased brltty-5.5-systemd-install.patch
  - api_version is now 0.7.0, and sover is now 0_7
  - brltty-systemd-wrapper now installs into /usr/libexec
  - Pass libexecdir in configure
  - LICENSE-GPL no longer exists
  - Package binaries new in 6.0

Files

/etc/brlapi.key
/usr/lib/libbrlapi.so.0.8
/usr/lib/libbrlapi.so.0.8.4
/usr/share/doc/packages/libbrlapi0_8
/usr/share/doc/packages/libbrlapi0_8/Manual-BrlAPI
/usr/share/doc/packages/libbrlapi0_8/Manual-BrlAPI/English


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 14 23:50:02 2022