Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gstreamer-plugins-rs-0.8.2-1.1 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: gstreamer-plugins-rs Distribution: openSUSE Tumbleweed
Version: 0.8.2 Vendor: openSUSE
Release: 1.1 Build date: Fri Mar 18 21:04:13 2022
Group: Productivity/Multimedia/Other Build host: obs-arm-5
Size: 36242230 Source RPM: gstreamer-plugins-rs-0.8.2-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://gstreamer.freedesktop.org/
Summary: GStreamer Streaming-Media Framework Plug-Ins
GStreamer is a streaming media framework based on graphs of filters
that operate on media data. Applications using this library can do
anything media-related, from real-time sound processing to playing
videos. Its plug-in-based architecture means that new data types or
processing capabilities can be added simply by installing new
plug-ins.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Mon Feb 28 2022 bjorn.lie@gmail.com
  - Update to version 0.8.2:
    * Update Cargo.lock
    * ci: Use correct gstreamer-rs images template
    * deny: Remove num-rational override
    * dav1ddec:
    - Use `AtomicRefCell` instead of `Mutex` for the state
    - Fix compilation after some API changes
    - Release input frames that immediately caused a decoding error
* Fri Feb 04 2022 bjorn.lie@gmail.com
  - Update to version 0.8.1:
    * Update Cargo.lock
    * Update versions to 0.8.1
    * cdg: update image and cdg_renderer
    * gtk4: Attach main context receiver from the main context's
      thread
    * dav1ddec: Add 8/16 bit grayscale support
    * rav1enc: Support 8 bit grayscale input
    * dav1ddec: Require correct alignment and stream format when
      running with GStreamer 1.20
    * rav1enc: Include stream-format and alignment in the caps
    * dav1ddec: Clean up state tracking a bit
  - Add automatic .changes generation to service, as upstream seems
    to not want to make release notes or changelogs.
* Wed Jan 19 2022 Antonio Larrosa <alarrosa@suse.com>
  - Add a BuildRequires: pkgconfig(libwebp) to fix loading
    libgstrswebp.so which was failing with an `undefined symbol:
    WebPAnimDecoderDelete` error.
* Tue Jan 18 2022 Antonio Larrosa <alarrosa@suse.com>
  - Increase the disk constraint since i586 builds take ~15.6 GB,
    s390x over 22 GB and other archs ~18.8 GB.
* Mon Jan 17 2022 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 0.8.0:
    * No changelog provided by upstream
* Wed Nov 10 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Disable csound plugin for now, mask all macros, BuildRequires and
    set option passed to meson to disabled (was auto), wait for
    upstream to fix the issues identified.
* Tue Nov 02 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Filter out pkgconfig(csound) Requires, add manual csound-devel
    BuildRequires to devel package. csound-devel does not provide a
    .pc file so the autogenerated Requires on pkconfig(csound) is
    wrong.
* Tue Nov 02 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Drop baselibs.conf, this is a new package, lets not build 32bit
    unless we have to.
* Sat Oct 16 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - No longer disabled LTO, drop macro.
* Sat Sep 04 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 0.7.2:
  - Switch service to using an explicit released tag.
  - Drop 0001-Fix-cast-to-f64-so-it-builds-in-i586.patch: Fixed
    upstream.
* Mon Apr 19 2021 Antonio Larrosa <alarrosa@suse.com>
  - Update to 0.6.0+git20210412.c3fb55f
  - Add patch to fix build in the i586 architecture
    (Submitted in glfo#gstreamer/gst-plugins-rs#502):
    * 0001-Fix-cast-to-f64-so-it-builds-in-i586.patch
* Thu Dec 24 2020 Bjørn Lie <bjorn.lie@gmail.com>
  - Enable build of dav1d plugin, do this via:
    + Disable LTO via macro.
    + Add clang and pkgconfig(dav1d) BuildRequires.
    + No longer pass dav1d=disabled to meson, nor remove dav1d from
      cargo.toml via sed call.
  - Add pkgconfig(libsodium) BuildRequires and pass sodium=system to
    meson, do not use package internal version of sodium.
  - Drop pkgconfig(gtk+-3.0) BuildRequires, not needed.
  - Add pkgconfig(pango) BuildRequires: Mandatory, previously pulled
    in by pkgconfig(gtk+-3.0), and add optional nasm BuildRequires.
  - Drop gcc-c++ BuildRequires, no longer needed, nor used.
  - Replace llvm-devel with llvm BuildRequires, this is sufficent.
  - Do general cleanup of spec, make package ready for submit to TW.
    Use normal meson macros.
  - Add _constraints, ensure the build have enough harddisk space.
* Tue Dec 01 2020 Antonio Larrosa <alarrosa@suse.com>
  - Update to git version 0.6.0+git20201201.58786fa
  - Use obs-service-cargo_vendor in the _service file and replace
    vendor-cargo-config with cargo_config
  - Enable the build of sodium and threadshare plugins
  - Remove special Cargo.lock source file which is not needed anymore
* Wed Oct 28 2020 Antonio Larrosa <alarrosa@suse.com>
  - Fix version, since the initial release wasn't 1.18.0 but 0.6.0
  - Update to git version 0.6.0+git20201026.d16e7d1
* Sat Oct 24 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Use %_vpath_builddir instead of hardcoded 'build' directory name:
    meson allows for the path to be changed.
* Wed Sep 16 2020 Antonio Larrosa <alarrosa@suse.com>
  - Initial release of gstreamer-plugins-rs 1.18.0

Files

/usr/lib/gstreamer-1.0
/usr/lib/gstreamer-1.0/libgstcdg.so
/usr/lib/gstreamer-1.0/libgstclaxon.so
/usr/lib/gstreamer-1.0/libgstfallbackswitch.so
/usr/lib/gstreamer-1.0/libgstffv1.so
/usr/lib/gstreamer-1.0/libgstfmp4.so
/usr/lib/gstreamer-1.0/libgstgif.so
/usr/lib/gstreamer-1.0/libgstgtk4.so
/usr/lib/gstreamer-1.0/libgsthlssink3.so
/usr/lib/gstreamer-1.0/libgsthsv.so
/usr/lib/gstreamer-1.0/libgstlewton.so
/usr/lib/gstreamer-1.0/libgstrav1e.so
/usr/lib/gstreamer-1.0/libgstreqwest.so
/usr/lib/gstreamer-1.0/libgstrsaudiofx.so
/usr/lib/gstreamer-1.0/libgstrsclosedcaption.so
/usr/lib/gstreamer-1.0/libgstrsdav1d.so
/usr/lib/gstreamer-1.0/libgstrsfile.so
/usr/lib/gstreamer-1.0/libgstrsflv.so
/usr/lib/gstreamer-1.0/libgstrsjson.so
/usr/lib/gstreamer-1.0/libgstrspng.so
/usr/lib/gstreamer-1.0/libgstrsregex.so
/usr/lib/gstreamer-1.0/libgstrstextwrap.so
/usr/lib/gstreamer-1.0/libgstrswebp.so
/usr/lib/gstreamer-1.0/libgstrusoto.so
/usr/lib/gstreamer-1.0/libgstsodium.so
/usr/lib/gstreamer-1.0/libgstspotify.so
/usr/lib/gstreamer-1.0/libgsttextahead.so
/usr/lib/gstreamer-1.0/libgstthreadshare.so
/usr/lib/gstreamer-1.0/libgsttogglerecord.so
/usr/lib/gstreamer-1.0/libgsturiplaylistbin.so
/usr/lib/gstreamer-1.0/libgstvideofx.so
/usr/share/appdata
/usr/share/appdata/gstreamer-plugins-rs.appdata.xml
/usr/share/doc/packages/gstreamer-plugins-rs
/usr/share/doc/packages/gstreamer-plugins-rs/README.md
/usr/share/licenses/gstreamer-plugins-rs
/usr/share/licenses/gstreamer-plugins-rs/LICENSE-APACHE
/usr/share/licenses/gstreamer-plugins-rs/LICENSE-LGPLv2
/usr/share/licenses/gstreamer-plugins-rs/LICENSE-MIT


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 10:59:15 2022