Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

liblxqt0-0.12.0-lp151.2.3 RPM for armv7hl

From OpenSuSE Ports Leap 15.1 for armv7hl

Name: liblxqt0 Distribution: openSUSE Leap 15.1
Version: 0.12.0 Vendor: openSUSE
Release: lp151.2.3 Build date: Fri Apr 26 07:53:42 2019
Group: System/Libraries Build host: armbuild15
Size: 292540 Source RPM: liblxqt-0.12.0-lp151.2.3.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.lxqt.org
Summary: LXQt core library
liblxqt represents the core library of LXQt providing essential
functionality needed by nearly all of its components.

Provides

Requires

License

LGPL-2.1+

Changelog

* Mon Oct 23 2017 mvetter@suse.com
  - Update to 0.12.0:
    * Bump minimum qtxdg version to 3.1.0
    * Don't export github templates
    * Bump version and needed versions to the final values
    * lxqtpower: Allow disabling of lxqt-session provider
    * Drops Qt5Core_VERSION_STRING
    * HtmlDelegate: Fix sizeHint() computation
    * Add some comments about the meaning of versions
    * Move LXQt version back to liblxqt
    * Fixes (#118)
    * lxqtapplication: Avoid wrong signal handling
    * Removes unneeded semicolon in namespace definition
    * Fix format conversions [-Wformat-pedantic] warnings
    * Suppress compiler warnings about unused function parameters
    * Removes extra semicolons in Qt's Q macros
    * Translator: Prefer XDG_DATA_DIRS over compiled in path
    * Help the compiler optimizing loops
    * Use const variables where possible
    * Update AUTHORS
  - Remove liblxqt-0.11.1-allow-disabl-lxqt-session.patch:
    contained in upstream
* Wed Sep 13 2017 mvetter@suse.com
  - boo#1044483:
    * Add liblxqt-0.11.1-allow-disabl-lxqt-session.patch
      to allow disabling of lxqt-session
* Thu Feb 23 2017 sfalken@opensuse.org
  - Update to 0.11.1:
    * Bump needed build tools version (#113)
    * build: Enable/disable WITH_XDG_DIRS_FALLBACK based on Qt version (#111)
    * Updates lxqt-build-tools required version
    * Adds a CMake minimum version requirement to the -config.cmake
    * Refactors superbuild support
    * Adds PROJECT_NAME to the build with Qt version message
    * Pack target_compile_definitions() and target_include_directories()
    * Adds PROJECT_NAME to the build with Qt version message
    * Pack target_compile_definitions() and target_include_directories()
    * Use the LXQtConfigVars module
    * Make liblxqt depend on lxqt-build-tools
    * Use the lxqt-build-tools LXQtCreatePortableHeaders
    * Use the new LXQt Build Tools package
    * Sets a minimum Qt5Xdg required version
    * Adds minimum Qt version requirement (5.4.2)
    * Remove cpack (#107)
* Fri Sep 30 2016 jengelh@inai.de
  - Update descriptions. Drop seemingly unneeded Provides: liblxqt.
    Own all directories.
* Sat Sep 24 2016 mvetter@suse.com
  - Update to 0.11.0:
    * Bump version ot 0.11.0 (#105)
    * Settings: Make use of reverse_iterator conditional
    * Application: Add <cerrno> include
    * Settings: Add "homemade" XDG_CONFIG_DIRS support
    * Settings: unify duplicated code
    * Add README.md
    * translations: Change default translations repository
    * Update DBus Notify method annotation name
    * Fix lupdate warning missing Q_OBJECT macro
    * Replaces deprecated QStyleOptionViewItemV4
    * Don't lock the screen when it's already locked.
    * lxqtscreensaver: Makes it a opaque pointer class
    * GridLayout: Store current animation flag
    * lxqtgridlayout: Move private class definition
    * HtmlDelegate: Take layoutDirection into account
    * GridLayout: Take layoutDirection into account
    * application: Correct signal handling & clean-up (#72)
    * lxqtpower: Removes unused stuff
    * SingleApplication: Only create an DBus adaptor when needed
    * NotificationPrivate: Fixes programming typo
    * Don't set icon theme name
    * configdialog: Update icons in ThemeChanged event
    * lxqtpower: Add suspend and hibernate to ConsoleKit2 provider
    * LXQtTranslateTs.cmake: Enable PULL_TRANSLATIONS by default
    * LXQtTranslateTs.cmake: Use/update template in remote repo
    * .gitignore: Cleanup
    * build: Use external translations
    * ts-files removal (#90)
    * GridLayout: Fix memory leak
    * translations: Fix external translations logic
    * translations: Add external translations support
    * configdialog: Fix icon bar sizing
    * configdialog: fix size of PageSelectWidget (#83)
    * Use const references with the foreach iterator
    * SettingsCache: Improve performance
    * Print warning messages when using the fallback Icon Theme
    * Use LXQT_DATA_DIR for fallback icon theme search path
    * Sets Oxygen as the only fallback icon theme
    * Adds CMAKE_INSTALL_PREFIX to the LXQt Theme search paths
    * LXQtCompilerSettings: Add QT_USE_QSTRINGBUILDER to the compile definitions
    * SingleApplication: Use QCoreApplication::exit() instead of ::exit()
    * bump year
    * TranslateDesktopTs: Adds UPDATE_OPTIONS options
    * TranslateDesktop: Remove lupdate absolute option
    * TranslateDesktop: Use -a switch in grep commands
    * LXQtTheme: Remove (outdated) "singleclick" qss assembly
    * settings: Upgrade emitting of "changed" signals
    * SingleApplication: Call also QWidget::show on activate
    * Updated Russian translation Removed ru_RU file
    * Use QString() instead of ""
    * Use CMAKE_INSTALL_FULL_DATAROOTDIR
    * Add LXQT_GRAPHICS_DIR directory definition
    * lxqt-config: Correct escaping while setting variables
    * CMake: Removes artifact
    * Adds FindXdgUserDirs CMake find_package module
    * Italian translation update
* Tue Nov 10 2015 mvetter@suse.com
  - Remove patch 0001-fix-build-with-qt-5.5.patch
    Contained in upstream version
* Thu Nov 05 2015 mvetter@suse.com
  - Upstream release 0.10.0
* Thu Oct 08 2015 mvetter@suse.com
  - Factory moved fom libqt5.4 to 5.5
    0001-fix-build-with-qt-5.5.patch: include QObject header explicitly
* Thu Jul 09 2015 mvetter@suse.com
  - Use correct name "lxqt" instead of "lxde-qt"
* Fri Feb 20 2015 sfalken@opensuse.org
  - Changed to %cmake and %cmake_install macros in %build and
    %install
* Mon Feb 09 2015 sfalken@opensuse.org
  - New upstream version 0.9.0
  - Added -lang subpackage
  - Dropped -qt5 package naming, as none of the internal library
    names use -qt5 in 0.9.0.  Added Obsoletes and Conflicts, in the
    odd chance that liblxqt-0.7.0 and liblxqt >=0.8.0 are installed
    on the same system.  Which should never happen.  lxqt-0.9.0 is not
    likely to be pushed to 13.2, and liblxqt can no longer be built
    against Qt4.
* Sun Jan 25 2015 sfalken@opensuse.org
  - Added conditionals to build for Fedora
* Fri Oct 24 2014 andrea@opensuse.org
  - new upstream version 0.8.0

Files

/usr/lib/liblxqt.so.0
/usr/lib/liblxqt.so.0.12.0
/usr/share/doc/packages/liblxqt0
/usr/share/doc/packages/liblxqt0/AUTHORS
/usr/share/doc/packages/liblxqt0/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 12:04:41 2022