Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libKPimGAPIDrive5-18.12.3-lp151.1.2 RPM for armv7hl

From OpenSuSE Ports Leap 15.1 for armv7hl

Name: libKPimGAPIDrive5 Distribution: openSUSE Leap 15.1
Version: 18.12.3 Vendor: openSUSE
Release: lp151.1.2 Build date: Fri Apr 26 13:29:46 2019
Group: System/GUI/KDE Build host: armbuild01
Size: 528982 Source RPM: libkgapi-18.12.3-lp151.1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.kde.org
Summary: Extension for accessing Google data
An extension for accessing some Google services, such as Google Calendar, Google Contacts and Google tasks.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Sat Mar 09 2019 lbeltrame@kde.org
  - Update to 18.12.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12.3.php
  - Changes since 18.12.2:
    * Fix googletalk protocol.
    * Contacts: fix email type deserialization (kde#398847)
  - Dropped patches, now upstream:
    * Contacts-fix-email-type-deserialization.patch
* Mon Feb 25 2019 wbauer@tmo.at
  - Add Contacts-fix-email-type-deserialization.patch to fix broken
    email fields in google contacts (boo#1126614, kde#398847)
  - Use < %{version} again for obsoleting sasl2-kdexoauth2-3
* Sat Feb 09 2019 lbeltrame@kde.org
  - Update to 18.12.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12.2.php
  - Changes since 18.12.1:
    * No code changes since 18.12.1
* Fri Jan 11 2019 lbeltrame@kde.org
  - Update to 18.12.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12.1.php
  - Changes since 18.12.0:
    * No code changes since 18.12.0
* Sat Dec 15 2018 Jan Engelhardt <jengelh@inai.de>
  - Generalize summaries.
* Fri Dec 14 2018 lbeltrame@kde.org
  - Update to 18.12.0
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12.0.php
  - Changes since 18.11.90:
    * No code changes since 18.11.90
* Mon Dec 03 2018 lbeltrame@kde.org
  - Update to 18.11.90
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12-rc.php
  - Changes since 18.11.80:
    * No code changes since 18.11.80
* Tue Nov 20 2018 Luca Beltrame <lbeltrame@kde.org>
  - Run spec-cleaner
* Tue Nov 20 2018 lbeltrame@kde.org
  - Update to 18.11.80
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.12-beta.php
  - Changes since 18.08.3:
    * QT_NO_NARROWING_CONVERSIONS_IN_CONNECT is defined in kf5.51
    * Fix minor EBN issues
    * Relicense the XOAuth SASL plugin under LGPLv2.1+
    * Make sure that it doesn't build with deprecated method
    * Add more flags
    * Fix warning
* Thu Nov 08 2018 lbeltrame@kde.org
  - Update to 18.08.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.08.3.php
  - Changes since 18.08.2:
    * No code changes since 18.08.2
* Thu Oct 11 2018 lbeltrame@kde.org
  - Update to 18.08.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.08.2.php
  - Changes since 18.08.1:
    * Fix compilation with Qt 5.12
* Thu Oct 04 2018 fabian@ritter-vogt.de
  - We actually need <= as the version did not get bumped
* Wed Sep 19 2018 Luca Beltrame <lbeltrame@kde.org>
  - Use < instead of <= when obsoleting sasl2-kdexoauth2-3 to prevent
    self-obsoletion
* Mon Sep 17 2018 Wolfgang Bauer <wbauer@tmo.at>
  - Rename sasl2-kdexoauth2-3 to sasl2-kdexoauth2, it is not a shared
    library but a plugin for sasl2, and it makes no sense to have
    several versions installed at the same time
  - Provide sasl2-kdexoauth2-3 for now to avoid dependency problems
    and to replace the old package
  - Move libkdexoauth2.so from libkgapi-devel to sasl2-kdexoauth2,
    apparently it's required on runtime for gmail/xoauth
    authentification to work (boo#1108577, kde#375410)
* Thu Sep 06 2018 lbeltrame@kde.org
  - Update to 18.08.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.08.1.php
  - Changes since 18.08.0:
    * gmail auth: return proper HTTP response to avoid qwebengine error
    * Fix typos
* Sat Sep 01 2018 fabian@ritter-vogt.de
  - Remove unnecessary WebKitWidgets dependency
* Thu Aug 16 2018 christophe@krop.fr
  - Update to 18.08.0
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.08.0.php
  - Changes since 18.07.80:
    * Fix build against Qt < 5.10
    * Replace KGAPIRaw logging category with file logging
* Thu Jul 26 2018 lbeltrame@kde.org
  - Update to 18.07.80
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.08-beta.php
  - Changes since 18.04.3:
    * Too many changes to list here
* Fri Jul 13 2018 lbeltrame@kde.org
  - Update to 18.04.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.04.3.php
  - Changes since 18.04.2:
    * None
* Fri Jun 08 2018 lbeltrame@kde.org
  - Update to 18.04.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.04.2.php
  - Changes since 18.04.1:
    * None
* Fri May 11 2018 lbeltrame@kde.org
  - Update to 18.04.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.04.1.php
  - Changes since 18.04.0:
    * None
* Wed Apr 18 2018 lbeltrame@kde.org
  - Update to 18.04.0
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.04.0.php
  - Changes since 18.03.90:
    * None
* Fri Apr 06 2018 lbeltrame@kde.org
  - Update to 18.03.90
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-18.04-rc.php
  - Changes since 17.12.3:
    * Remove extra ';'
    * Use override directly
    * USe QLatin1String
    * Set error if oauth dialog is aborted
    * Fix minor typos
    * Make new user-visible messages translatable
    * Fix token page URL (kde#388483)
* Thu Mar 08 2018 lbeltrame@kde.org
  - Update to 17.12.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12.3.php
  - Changes since 17.12.2:
    * None
* Wed Feb 07 2018 lbeltrame@kde.org
  - Update to 17.12.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12.2.php
  - Changes since 17.12.1:
    * Fix oauth focus (kde#389263)
    * Reenable setting the authentication URL
    * Retrieve OAuth2 token with HTTP socket
    * Check for the correct "kind" strings
    * Fix token page URL (kde#388483)
  - Dropped patches, now upstream:
    * Fix-token-page-URL.patch
* Sat Jan 13 2018 wbauer@tmo.at
  - Add Fix-token-page-URL.patch to make authentification with
    Google services work again after a change by Google (kde#388483)
* Thu Jan 11 2018 lbeltrame@kde.org
  - Update to 17.12.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12.1.php
  - Changes since 17.12.0:
    * None
* Sat Dec 09 2017 lbeltrame@kde.org
  - Update to 17.12.0
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12.0.php
  - Changes since 17.11.90:
    * Contacts: fix sync of alternative URL types (kde#387344)
* Sat Dec 02 2017 lbeltrame@kde.org
  - Update to 17.11.90
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12-rc.php
  - Changes since 17.11.80:
    * None
* Mon Nov 20 2017 lbeltrame@kde.org
  - Update to 17.11.80
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.12-beta.php
  - Changes since 17.08.3:
    * Port to new connect api
    * Port to new connect api
    * Port to new connect api
    * Remove project here
    * not necessary to have project here
    * Fix merge conflict
    * Add parent
    * Fix includes
    * Adapt to KCalCore API changes
    * Port Period and Duration to QDateTime
    * Adapt to KCalCore lastModified/created API changes
    * We can remove this compatibility now
    * Make run without install them
    * Remove unused line
* Thu Nov 09 2017 lbeltrame@kde.org
  - Update to 17.08.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.08.3.php
  - Changes since 17.08.2:
    * None
* Mon Oct 16 2017 lbeltrame@kde.org
  - Update to 17.08.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.08.2.php
  - Changes since 17.08.1:
    * lintcmake https://build.neon.kde.org/job/xenial_stable_applications_libkgapi_lintcmake/21/console Unknown CMake command "find_dependency".
    * Fix version
* Thu Sep 07 2017 lbeltrame@kde.org
  - Update to 17.08.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.08.1.php
  - Changes since 17.08.0:
    * None
* Fri Aug 11 2017 christophe@krop.fr
  - Update to KDE Applications 17.08.0
    * New feature release
    * https://www.kde.org/announcements/announce-applications-17.08.0.php
  - Changes since 17.04.3 :
    * Update version
    * Revert "Try to fix build on windows"
    * Try to fix build on windows
    * Fix compile on windows
    * Use isEmpty() here
    * Add more definitions QT_NO_URL_CAST_FROM_STRING
    * Remove Qt module from include
    * Remove module name
    * Use nullptr
    * use nullptr
    * Pedantic
    * Use qCDebug
    * Fix indent
    * Port to for(...:...)
    * Port some others Q_FOREACH
    * Remove more q_foreach
    * Convert some Q_FOREACH
    * not necessary
    * Port to for(...:...)
    * We depend against qt5.7
    * Increase version
    * Fix dependancies
* Sat Aug 05 2017 christophe@krop.fr
  - Update to KDE Applications 17.07.90
    * KDE Applications 17.07.90
    * https://www.kde.org/announcements/announce-applications-17.08-rc.php
* Sun Jul 16 2017 lbeltrame@kde.org
  - Update to 17.04.3
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04.3.php
  - Changes since 17.04.2:
    * None
* Wed Jun 07 2017 lbeltrame@kde.org
  - Update to 17.04.2
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04.2.php
  - Changes since 17.04.1:
    * None
* Wed May 17 2017 lbeltrame@kde.org
  - Update to 17.04.1
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04.1.php
  - Changes since 17.04.0:
    * Prepare 5.5.1
    * Auth: add URL bar and SSL indicator to the authentication page
    * Auth: don't store cookies
    * Auth: Adapt to changes in Google OAuth token retrieval process
    * Use same variable as other lib. It's more easy to upgrade version
    * Fix some clazy warning
  - Drop upstreamed patches:
    * adapt-to-changes-in-google-oauth.patch
* Thu Apr 27 2017 lbeltrame@kde.org
  - Add upstream patch adapt-to-changes-in-google-oauth.patch:
    * Fix for changes in Google OAuth process
* Fri Apr 21 2017 lbeltrame@kde.org
  - Remove all Recommends on non-core packages, since they will
    require the core one
* Fri Apr 21 2017 lbeltrame@kde.org
  - Make libKPimGAPICore5 provide libkgapi, so that instaling
    languages (which use a single file) will work
* Sun Apr 16 2017 lbeltrame@kde.org
  - Update to 17.04.0
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04.0.php
  - Changes since 17.03.90:
    * Fix some clazy warning
* Wed Apr 12 2017 lbeltrame@kde.org
  - Update to 17.03.90
    * New bugfix release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04-rc.php
  - Changes since 17.03.80:
    * None
* Fri Mar 31 2017 fabian@ritter-vogt.de
  - Build only for architectures compatible with Qt WebEngine
* Sat Mar 25 2017 lbeltrame@kde.org
  - Update to 17.03.80
    * New feature release
    * For more details please see:
    * https://www.kde.org/announcements/announce-applications-17.04-beta.php
  - Changes since 5.3.1:
    * increase dependancies
    * Use KDE_INSTALL_TARGETS_DEFAULT_ARGS when installing targets
    * It's in official release + we don't use i18n
    * Fixup .reviewboardrc
    * src/latitude/latitudeservice.cpp - Q_UNUSED
    * Make Qt l10 tools happier
    * Fix version
    * AuthJob: emit finished() when dialog is rejected
    * Rename CMake target prefix from KF5 to KPim
    * Fix typo in quotaBytesUserAggregate() method
    * Fix compile with Qt 5.8: add missing QImage includes
    * Fix compile with Qt 5.8: add missing QImage includes
    * USe nullptr
    * Add missing Q_DECL_OVERRIDE
    * Clean up. Increase qt dependancy
    * use Q_NULLPTR
    * Increase version
    * increase version
    * drive: deprecate hidden() and setHidden() in File
    * Relicense to LGPLv2.1 or v3 or later versions approved by KDE e.V.
    * Remove stray WebKitWidgets reference.
    * Remove unused KF5CoreAddons dependency.
    * Switch to QtWebEngine
    * Move tests to autotests
    * Update AUTHORS
    * Increase version
    * Fix ts2Str() UTC conversion
* Fri Sep 30 2016 fabian@ritter-vogt.de
  - Update to 5.3.1
    * No changelog provided
* Sun Aug 21 2016 hrvoje.senjan@gmail.com
  - Update to 5.3.0
    * No changelog provided
* Sun Jan 17 2016 tittiatcoke@gmail.com
  - Update to 5.1.0
    * KDE Frameworks 5 based version. (boo#953617)

Files

/usr/lib/libKPimGAPIDrive.so.5
/usr/lib/libKPimGAPIDrive.so.5.10.3
/usr/share/licenses/libKPimGAPIDrive5
/usr/share/licenses/libKPimGAPIDrive5/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 12:04:41 2022