Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgcin-im-client1-2.9.0-bp153.1.115 RPM for aarch64

From OpenSuSE Leap 15.3 for aarch64

Name: libgcin-im-client1 Distribution: SUSE Linux Enterprise 15 SP3
Version: 2.9.0 Vendor: openSUSE
Release: bp153.1.115 Build date: Tue May 18 12:22:22 2021
Group: System/Libraries Build host: obs-arm-8
Size: 304040 Source RPM: gcin-2.9.0-bp153.1.115.src.rpm
Packager: https://bugs.opensuse.org
Url: http://hyperrate.com/dir.php?eid=67
Summary: Share libraries of gcin
This package provides runtime libraries for gcin.

Provides

Requires

License

LGPL-2.1-only

Changelog

* Fri Dec 04 2020 Antonio Larrosa <alarrosa@suse.com>
  - Do not build the qt4 subpackage for Leap 15.3 or newer
    (boo#1179613).
* Thu Nov 26 2020 tiwai@suse.de
  - Move the startup snippet to /usr/etc/X11/xim.d for TW
* Mon Jun 08 2020 Gary Ching-Pang Lin <glin@suse.com>
  - Update to 2.9.0
    + Fix gtab word choosing area mismatching
    + Fix an issue with hsu keyboard
    + gcc 10 compatibility
* Wed Apr 17 2019 tiwai@suse.de
  - Drop build of gcin-qt4 subpackage on TW due to EOL of Qt4.
* Mon Apr 01 2019 Gary Ching-Pang Lin <glin@suse.com>
  - Update to 2.8.9
    + Fix issues with gtk3 and switch to gtk3 by default
    + Fix an issue with 41 keys bopomofo
  - Add gcin-remove-dead-code.patch to remove the dead code which
    causes the useless warning
* Thu Dec 27 2018 Gary Ching-Pang Lin <glin@suse.com>
  - Update to 2.8.8
    + Fix a cursor issue in 26 keys bopomofo
    + Fix a issue with Hsu's keyboard layout and enabling
      "more UTF-8 characters"
  - Refresh gcin-fix-qt5-iid.patch
  - Use %license for COPYING
* Fri May 25 2018 glin@suse.com
  - Update to 2.8.6
    + Fixed a selection key problem with ctrl-alt-,
    + Use libcurl to upload/download phrases
    + Improved pinyin pre-select phrases
  - Add libcurl-devel and libXtst-devel to BuildRequires
  - Drop upstreamed patch: gcin-reproducible.patch
  - Refresh patches
    + gcin-dont-copy-gcin-qt5-header.patch
    + gcin-improve-build-with-pkgconfig.patch
    + gcin-parallel-compiling.patch
  - Remove the version check since openSUSE 13.1 is not supported
    long ago
  - Only build gcin-qt4 for openSUSE
* Mon Sep 04 2017 bwiedemann@suse.com
  - Add gcin-reproducible.patch to initialize memory
* Wed Jun 21 2017 glin@suse.com
  - Amend gcin-improve-build-with-pkgconfig.patch for Qt 5.9.0
* Thu Mar 02 2017 glin@suse.com
  - Add gcin-dont-copy-gcin-qt5-header.patch to avoid overwriting
    the patched gcin-qt5.h
* Thu Feb 09 2017 glin@suse.com
  - Update to 2.8.5
    + Fix a typing bug with Hsu layout
    + Fix the missing pre-select phrases when using Array input
      method
  - Refresh patches:
    + gcin-improve-build-with-pkgconfig.patch
    + gcin-parallel-compiling.patch
* Wed Oct 12 2016 glin@suse.com
  - Amend baselibs.conf to avoid the immodules to require gcin-32bit
    (boo#1002566)
* Fri Sep 09 2016 glin@suse.com
  - Remove libappindicator since KDE already brought system tray icon
    back.
* Wed Jun 08 2016 i@marguerite.su
  - fix tumbleweed build
  - refresh patch: gcin-improve-build-with-pkgconfig.patch
    * Qt5PlatformSupport has gone from Qt 5.6.0
    * fix include for qinputmethod.h
  - add gcin-qt5 to baselibs.conf
  - rename the sub-packages in openSUSE style
  - split libgcin-im-client1 library
* Mon Oct 26 2015 mlin@suse.com
  - Add gcin-improve-build-with-pkgconfig.patch
    + Improve build with pkgconfig
    + Add Qt5Gui private headers at moc period
  - Update gcin-fix-qt5-iid.patch
    + Use macro instead of string literal, better backward compatibility
      for Qt5 < 5.5
* Sat Oct 24 2015 glin@suse.com
  - Add gcin-fix-qt5-iid.patch to fix the qt5 iid so that the qt5
    applications can load the gcin immodule (boo#951750)
* Fri Oct 23 2015 glin@suse.com
  - Update to 2.8.4
    + Switch to appindicator by default
    + Changes: http://hyperrate.com/gcin-source/Changelog.html
  - Drop upstreamed fixes
    + qt5gui-header-path-fix.patch
    + plasma5-dirty-fix.patch
* Tue Sep 29 2015 ramaxlo@gmail.com
  - Add gcin-qt5-immodule, libappindicator3-1 as runtime dependencies
    for Plasma 5 (the program does own binding with dlsym())
* Mon Sep 07 2015 glin@suse.com
  - Add libappindicator3-devel to BuildRequires to enable appindicator
    support for Plasma 5
* Wed May 27 2015 ramaxlo@gmail.com
  - Add qt5 immodule support.
  - Add qt5gui-header-path-fix.patch to fix build failure.
  - Add plasma5-dirty-fix.patch to fix plasma 5 black screen issue
    during starting. The reason is unknown so far.
    Refer to http://hyperrate.com/thread.php?tid=31194 for more
    information.
* Sun Mar 08 2015 i@marguerite.su
  - add baselibs.conf as source
* Sat Mar 07 2015 i@marguerite.su
  - update version 2.8.3
    * read http://hyperrate.com/gcin-source/Changelog.html

Files

/usr/lib64/gcin
/usr/lib64/gcin/gcin1.so
/usr/lib64/gcin/gcin2.so
/usr/lib64/gcin/intcode-module.so
/usr/lib64/gcin/libgcin-im-client.so
/usr/lib64/gcin/libgcin-im-client.so.1
/usr/lib64/gcin/libgcin-im-client.so.1.2.5


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 9 15:57:23 2022