Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

perl-image-magick-6.3.5.10-1tr RPM for i586

From Trustix 3.0 for i586

Name: perl-image-magick Distribution: Trustix Secure Linux
Version: 6.3.5.10 Vendor: Comodo Trustix
Release: 1tr Build date: Wed Sep 26 09:43:34 2007
Group: Trustix Official Build host: ttrmgtnived.comodo.net
Size: 288704 Source RPM: imagemagick-6.3.5.10-1tr.src.rpm
Packager: Comodo Trustix <http://www.trustix.com>
Url: http://www.imagemagick.org/
Summary: Perl Image::Magick module
Perl module for using Image::Magick from perl scripts

Provides

Requires

License

GPL

Changelog

* Wed Sep 26 2007 Nived Gopalan <nived at trustix dot org> 6.3.5.10-1tr
  - New Upstream.
  - SECURITY Fix: Some vulnerabilities have been reported in ImageMagick,
    which can be exploited by malicious people to conduct DoS attacks or
    compromise a user's system.
  - Includes fix for CVE-2007-4986, CVE-2007-4987 and CVE-2007-4988.
* Thu Apr 05 2007 Nived Gopalan <nived at trustix dot org> 6.3.3.5-1tr
  - New Upstream.
  - SECURITY Fix: Some vulnerabilities have been reported in ImageMagick,
    which can be exploited by malicious people to compromise a vulnerable
    system.
  - A integer overflow error within the "ReadDCMImage()" function can be
    exploited to cause a heap-based buffer overflow when processing
    specially crafted DCM images.
  - Two integer overflows within the "ReadXWDImage()" function when
    calculating the amount of memory to be allocated for the 'colors' or
    'comment' fields can be exploited to cause heap-based buffer overflows
     when processing specially crafted XWD images.
  
    The Common Vulnerabilities and Exposures project (cve.mitre.org) has
    assigned the name CVE-2007-1797 to this issue.
* Mon Nov 13 2006 Bipin S <bipin at trustix dot org> 6.3.0.1-2tr
  - Fixed undefined symbols, Bug #2035.
* Wed Nov 01 2006 Bipin S <bipin at trustix dot org> 6.3.0.1-1tr
  - New upstream.
* Fri Aug 25 2006 Nived Gopalan <nived at trustix dot org> 6.2.9.1-1tr
  - New Upstream.
  - SECURITY Fix: Tavis Ormandy has reported some vulnerabilities in
    ImageMagick, which potentially can be exploited by malicious people
    to compromise a vulnerable system.
  - Fix boundary errors within the "DecodeBitmap()" function and the
    "ReadSUNImage()" function in sun.c which can be exploited to cause
    heap-based buffer overflows when processing specially crafted
    Sun Rasterfile images.
  - Fix boundary errors within the XCF image decoder which can be
    exploited to cause a stack-based and a heap-based overflow when
    processing specially crafted XCF image files.
  
    The Common Vulnerabilities and Exposures project (cve.mitre.org) has
    assigned the names CVE-2006-3744 and CVE-2006-3743 to this issue.
* Thu Aug 17 2006 Nived Gopalan <nived at trustix dot org> 6.2.9-1tr
  - New Upstream.
  - SECURITY Fix: Damian Put has discovered a vulnerability in ImageMagick,
    which can be exploited by malicious people to cause a DoS (Denial of
    Service) or potentially compromise a user's system. The vulnerability
    is caused due to an integer overflow in the "ReadSGIImage()" function
    when decoding SGI image files. 
  
    The Common Vulnerabilities and Exposures project (cve.mitre.org) has
    assigned the name CVE-2006-4144 to this issue.
* Fri Jan 27 2006 Bipin S <bipin at trustix dot org> 6.2.6-1tr
  - New Upstream.
  - Removed /usr/lib/libltdl.* from spec.
  - Added with-perl-options in configure
* Wed Jun 29 2005 Ajith Thampi <ajith at comodo dot com> 6.2.3-4tr
  - Multiple Bug Fixes
* Tue Jun 07 2005 Ajith Thampi <ajith at comodo dot com> 6.2.3-3tr
  - Rebuilt to make changes with perl-5.8.7
* Tue May 31 2005 Ajith Thampi <ajith at comodo dot com> 6.2.3-1tr
  - New Upstream
  - Fixed an obscure heap-overflow vulnerability in the PNM reader reported by Damian Put
  - Eliminate seg-fault when pinging images not recognised by ImageMagick.
  - Fixed memory overflow computation.
* Mon May 23 2005 Ajith Thampi <ajith at comodo dot com> 6.2.2-4tr
  - Fix DOS, Tavis Ormandy has reported a weakness in ImageMagick, which can be
    exploited by malicious people to cause a DoS (Denial of Service).The problem 
    is caused due to an infinite loop in the XWD decoder when setting a colour mask 
    and can be exploited to consume a large amount of CPU resources via a specially 
    crafted image. (SA15130)
* Tue Apr 26 2005 Ajith Thampi <ajith at comodo dot com> 6.2.2-2tr
  - Remote exploitation of a heap overflow vulnerability could allow 
    execution of arbitrary code or couse denial of service.A heap overflow 
    exists in ReadPNMImage() function, that is used to decode a PNM image files.
* Tue Apr 26 2005 Ajith Thampi <ajith at comodo dot com> 6.2.2-1tr
  - New Upstream
  - Fixes Heap Overflow Vulnerability
* Fri Apr 01 2005 Bipin S <bipin at comodo dot com> 6.2.1-1tr
  - Imported from tsl-2.2 contribs. 
  - minor cleanup, fixed unpackaged file list
* Tue Feb 08 2005 Raghu <raghu at comodo dot com>6.1.8-1ra
  - New Upstream
* Tue Nov 16 2004 Chr. Toldnes <christht at trustix dot org> 6.1.4-2ct
  - Cleanup for official contrib
* Sun Nov 14 2004 Morten Nilsen <morten@nilsen.com>
  - Upgrade and clean up package
* Mon Oct 20 2003 Morten Nilsen <morten@nilsen.com>
  - made initial cut

Files

/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/Image/Magick.pm
/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/auto/Image/Magick
/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/auto/Image/Magick/.packlist
/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/auto/Image/Magick/Magick.bs
/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/auto/Image/Magick/Magick.so
/usr/lib/perl5/site_perl/5.8.7/i586-linux-thread-multi/auto/Image/Magick/autosplit.ix


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jul 10 16:46:32 2014