Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libvmtools0-10.1.0-6.1 RPM for x86_64

From OpenSuSE leap updates for 42.1 / oss / x86_64

Name: libvmtools0 Distribution: openSUSE Leap 42.1
Version: 10.1.0 Vendor: openSUSE
Release: 6.1 Build date: Thu Feb 9 16:32:36 2017
Group: System/Libraries Build host: cloud117
Size: 961768 Source RPM: open-vm-tools-10.1.0-6.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/vmware/open-vm-tools
Summary: Open Virtual Machine Tools - shared library
This is a shared library used by several Open VM Tools components,
such as vmware-toolbox-cmd and vmtoolsd (and its plugins).

Provides

Requires

License

BSD-3-Clause and GPL-2.0 and LGPL-2.1

Changelog

* Tue Feb 07 2017 ken@suse.com
  - Sumbitting update for SLE11SP4, SLE12SP1, SLE12SP2
    see fate#322214 & fate#322218
* Wed Dec 14 2016 sparschauer@suse.de
  - Report SLES12-SAP guest OS as SLES12 (bsc#1013496)
    + Report-SLES12-SAP-guest-OS-as-SLES12.patch
* Thu Dec 01 2016 ken@suse.com
  - Remove building KMP modules. No longer needed or wanted for
    current releases. User space tool vmhgfs-fuse has replaced the
    need for vmhgfs kernel module.
* Sat Nov 12 2016 ken@suse.com
  - Updated to 10.1.0 stable release (boo#1011057)
    + vmware-namespace-cmd command line utility.
    + gtk3 support
    + Common Agent Framework (CAF)
    + guest authentication with xmlsec1
    + FreeBSD support
    + sub-command to push updated network information to the host on demand
    + udev rules for configuring SCSI timeouts in the guest
    + fixes for Ubuntu 16.10
    + Fix for quiesced snapshot failure leaving guest file system
      quiesced (bsc#1006796)
    + Fix for CVE-2015-5191 (bsc#1007600)
  - Dropped upstream patches included (or not necessary) in 10.1.0:
    + vmw-bitmask-gcc6.patch
    + no-unused-const.patch
    + enable-gcc46+.patch
* Wed Nov 02 2016 jcejka@suse.de
  - Add udev rule to increase VMware virtual disk timeout values
    (bsc#994598)
    [99-vmware-scsi-udev.rules]
* Wed Jul 13 2016 ken@suse.com
  - Fix vmtoolsd init script to run vmtoolsd in background. (bsc#971031)
    + fix originally done in SLE-11-SP4 code base by tcech@suse.cz
* Thu Jun 16 2016 ken@suse.com
  - Added patches for GCC 6 build failure (boo#985110)
    + vmw-bitmask-gcc6.patch
    + no-unused-const.patch
* Wed Jun 08 2016 ken@suse.com
  - Update to 10.0.7-gtk3 stable branch
    + add support for gtk3, needed by the dndcp and resolutionset
      plugins
    + remove files generated by autoreconf
    + a few minor build fixes
  - Update fixes copy-n-paste and drag-n-drop regressions (bsc#978424)
  - Added new vmblock-fuse.service
  - Drop upstream patches included (or not necessary) in 10.0.7-gtk3:
    + open-vm-tools-posixly.patch
    + open-vm-tools-buildsystem-fixup.patch
* Fri Apr 29 2016 afaerber@suse.de
  - Sanitize the filename handling some more. The official GitHub
    filename is open-vm-tools-stable-10.0.7.tar.gz.
* Thu Apr 28 2016 ken@suse.com
  - Update to 10.0.7 stable branch
    + Added namespace command line utility "vmware-namespace-cmd".
* Fri Apr 22 2016 jslaby@suse.com
  - they renamed open-vm-tools-stable-10.0.5.tar.gz to
    stable-10.0.5.tar.gz -- fix .spec accordingly
* Wed Apr 20 2016 dimstar@opensuse.org
  - Add open-vm-tools-posixly.patch: defined(linux) is not posix
    compliant and modern compilers no longer accept it. Change to
    defined(__linux__)
    https://github.com/vmware/open-vm-tools/pull/81
  - Add open-vm-tools-buildsystem-fixup.patch: since libsigc++ injects
    - std=c++11 into CFLAGS, the various objects in open-vm-tools need
    to be split up a bit in order to not have a mixed C/C++ object
    receiving the same CFLAGS.
* Wed Dec 23 2015 mlatimer@suse.com
  - Compile without gtkmm support for SLES12 based environments
    (which do not provide gtkmm2.4)
* Tue Dec 01 2015 mlatimer@suse.com
  - Update to 10.0.5 stable branch
    + [vgauth] fix timestamp check
    + [libresolutionSet.so] Add an error handler to X11 resolutionSet
    + [vmci.ko] Kill tasklet when unloading vmci module
    + [libvmbackup.so] Quiesced snapshots Skip freezing autofs mounts.
    + [vmhgfs.ko] make vmhgfs compatible with Linux kernel 4.2
* Fri Oct 30 2015 mlatimer@suse.com
  - Enable vgauth for openSUSE Leap 42.1 (bsc#952645)
* Thu Oct 22 2015 mlatimer@suse.com
  - Remove vgauth requirements from vmtoolsd.service file if vgauth
    is not enabled.
  - Remove gcc4.7 requirement for older environments.
* Wed Sep 09 2015 mlatimer@suse.com
  - Enable certificate-based access control via SAML tokens (vgauth) on
    openSUSE Factory.
* Thu Sep 03 2015 mlatimer@suse.com
  - Update to open-vm-tools-10.0.0-3000743  (boo#944615)
    + Common versioning
    + Quiesced snapshots enhancements for Linux guests running IO workload
    + Shared Folders (Linux kernel 4.0.0 and higher only)
    + ESXi Serviceability
    + GuestInfo Enhancements
    + Internationalization, with support for:
      + English
      + French
      + German
      + Spanish
      + Italian
      + Japanese
      + Korean
      + Simplified Chinese
      + Traditional Chinese
    + Compatibility with all supported versions of VMware vSphere, VMware
      Workstation 12.0 and VMware Fusion 8.0
  - Drop upstream patches included (or not necessary) in 10.0.0:
    - 0001-Fix-vmxnet-module-on-kernels-3.16.patch
    - 0002-Fix-d_alias-to-d_u.d_alias-for-kernel-3.18.patch
    - 0003-Fix-f_dentry-msghdr-kernel-3.19.patch
    - 0004-vmhgfs-bdi-kernel-4.0.patch
    - xutils-add-cstring.patch
  - Remove vmhgfs define to ensure vmhgfs is always built
  - Only build kernel modules for versions <= openSUSE 13.2
* Wed Sep 02 2015 mlatimer@suse.com
  - Do not attempt to start vmware-vmblock-fuse if vmware-vmblock-fuse
    (included with the -desktop package) is not installed (bsc#943236)
* Wed Aug 12 2015 dimstar@opensuse.org
  - For SLE11, the KMP is still required; the .spec file logic is
    now only enabled in the linked package, the 2nd spec file must
    not be part of the main package open-vm-tools (as Factory would
    immediately create the linked package, which would fail building
    with Linux 4.x) (boo#941384).
* Mon Aug 10 2015 dimstar@opensuse.org
  - Drop KMP related .spec and .changes file (bsc#938593) (for now
    we keep the logic in the .spec file, in case we want to resurrect
    it).
* Mon Jul 13 2015 mlatimer@suse.com
  - Update to open-vm-tools-9.10.2-2822639
    + Fix various compilation errors
    + Retry sending vmbackup event with elevated privileges
    + Add a -h option to vgauth
    + Workaround NFS open bug by retrying on ESTALE
    + Fix the HGFS protocol opcode to differentiate headers
    + Thaw filesystems when the snapshot commit message to VMX fails
  - Drop upstream patches included in 9.10.2:
    - toolboxcmd-fix-logic.patch
    - asm_x86.patch
* Sun Jun 28 2015 antoine.belvire@laposte.net
  - Fix compilation issues with GCC 5:
    * Add toolboxcmd-fix-logic.patch
    * Add asm_x86.patch
* Thu May 21 2015 mlatimer@suse.com
  - Build using gcc4.7 for SLES11 environments to avoid mul64.h
    dependency problem for i586 architectures
  - Include cstddef to resolve compile problems under gcc4.7
    enable-gcc46+.patch
  - Ensure xutils builds properly under older versions of gcc
    xutils-add-cstring.patch
  - Prevent files on shared folders from being truncated to 0 bytes
    under 4.0 kernel
    0004-vmhgfs-bdi-kernel-4.0.patch
* Mon May 18 2015 mlatimer@suse.com
  - Update to open-vm-tools-9.10.0-2476743:
    + vgauth added
    + deploypkg added
    + guest proxycerttool added
    + hgfs and vmci/vsock fixes
    + asyncsocket enhancements
    + library fixes and improvements
    + locking and logging fixes and improvements
    + foundry fixes
    + vm-support script fixes
  - Replace obsolete patches with rebased versions (from ArchLinux):
    - Drop 0001-Remove-unused-DEPRECATED-macro.patch
    - Drop 0002-Conditionally-define-g_info-macro.patch
    - Drop 0003-Add-kuid_t-kgid_t-compatibility-layer.patch
    - Drop 0004-Use-new-link-helpers.patch
    - Drop 0005-Update-hgfs-file-operations-for-newer-kernels.patch
    - Drop 0006-Fix-vmxnet-module-on-kernels-3.16.patch
    - Drop 0007-Fix-vmhgfs-module-on-kernels-3.16.patch
    - Drop 0008-Fix-segfault-in-vmhgfs.patch
    - Drop open-vm-tools-linux-3.17.7.patch
    - Drop open-vm-tools-linux-3.17.patch
    - Drop open-vm-tools-linux-3.18.0.patch
    - Add 0001-Fix-vmxnet-module-on-kernels-3.16.patch
    - Add 0002-Fix-d_alias-to-d_u.d_alias-for-kernel-3.18.patch
    - Add 0003-Fix-f_dentry-msghdr-kernel-3.19.patch
  - Add libmspack BuildRequires (deploypkg).
  - Add openssl BuildRequires (grabbitmqproxy and vgauth).
  - Compile using --without-xmlsecurity and --without-xerces as
    pkgconfig(xml-security-c) is not yet available in the build service,
    (disables vgauth support).
  - Disable deploypkg for older versions of SLES and openSUSE.
  - Disable ssl for older versions of SLES and openSUSE (disables
    grabbitmqproxy and vgauth).
  - Update spec file to be compatible with SLES and openSUSE.
  - This update also addresses a suspend with systemd issue (bsc#913727)
* Tue May 05 2015 dimstar@opensuse.org
  - Handle kernel 4.0: we can't just compare the 'minor' part of the
    version anymore when applying patches.
* Thu Mar 12 2015 mlatimer@suse.com
  - Prevent autoinstallation of open-vm-tools in SLES11SP4 environments
    due to potential conflict with VMware tools. (bsc#921618)
* Thu Feb 19 2015 dimstar@opensuse.org
  - Add open-vm-tools-linux-3.19.0.patch: Fix building of vmhgfs with
    Kernel 3.19.0+.
* Wed Jan 21 2015 mlatimer@suse.com
  - Remove modprobe of deprecated vmsync module from SysV init script.
* Fri Jan 16 2015 mlatimer@suse.com
  - Update specfile to ensure kernel modules are not built or required
    for SLES11SP4 and SLES12.
* Fri Jan 09 2015 mlatimer@suse.com
  - Use fuse-devel instead of pkgconfig(fuse) in SLES11SP4.
* Mon Jan 05 2015 dimstar@opensuse.org
  - Add open-vm-tools-linux-3.17.7.patch: Fix building of vmhgfs with
    Kernel 3.17.7+.
  - Add open-vm-tools-linux-3.18.0.patch: Fix building of vmhgfs with
    Kernel 3.18.0+.
* Mon Jan 05 2015 dimstar@opensuse.org
  - Split building of KMPs into own spec file: open-vm-tools-KMP:
    the resulting KMP packages keep their existing name, as this is
    handled through the kernel_package macros. This split allows to
    work around boo#905420.
* Sat Nov 29 2014 Led <ledest@gmail.com>
  - fix bashisms in vmware-user-autostart-wrapper script
* Wed Nov 12 2014 dimstar@opensuse.org
  - Add open-vm-tools-linux-3.17.patch: Fix build with Linux 3.17.0.
* Mon Nov 10 2014 dimstar@opensuse.org
  - Sync up patches with ArchLinux:
    + Added 0001-Remove-unused-DEPRECATED-macro.patch
    + Added 0002-Conditionally-define-g_info-macro.patch
    + Added 0003-Add-kuid_t-kgid_t-compatibility-layer.patch
    + Added 0004-Use-new-link-helpers.patch
    + Added 0005-Update-hgfs-file-operations-for-newer-kernels.patch
    + Added 0006-Fix-vmxnet-module-on-kernels-3.16.patch
    + Added 0007-Fix-vmhgfs-module-on-kernels-3.16.patch
    + Added 0008-Fix-segfault-in-vmhgfs.patch
    + Droped g_info_redefine.patch (now named
      0002-Conditionally-define-g_info-macro.patch).
  - Enable building of KMP packages.
* Mon Nov 10 2014 Led <ledest@gmail.com>
  - Fix bashisms in preun script.
* Fri Oct 31 2014 crrodriguez@opensuse.org
  - Do not generate timestamps in the doxygen docs.
* Mon Oct 20 2014 dimstar@opensuse.org
  - Add -Wno-cpp to CFLAGS.
* Mon Oct 06 2014 boris@steki.net
  - Updated to latest release 9.4.6-1770165
    + Release matching the vSphere 5.5p02 release
  - "which" as separate package does not exist on older opensuse versions
    so removed from Requires for older distributions
  - used autoreconf as source package does not provide configure script anymore
  - removed vmsync module from OS12.3 build target as it does not compile
* Fri May 16 2014 mlatimer@suse.com
  - Modify vmware-user-autostart-wrapper to unconditionally start
    vmware-user-suid-wrapper, and no longer delay for vmblock-fuse
    if under systemd. (bnc#876074)
* Wed May 14 2014 meissner@suse.com
  - added forgotten %pre snippet for service addition, this made
    systemd service not auto-start. bnc#870737
* Mon Apr 28 2014 mlatimer@suse.com
  - Move 'vm-support' script from /etc/vmware-tools to /usr/bin (bnc#874931).
  - Update call to "tools.set.version" RPC during uninstall to match upstream
    behavior (bnc#875129).
  - Add missing RPM runtime dependencies (net-tools, tar, which).
* Mon Mar 17 2014 mlatimer@suse.com
  - Update to version 9.4.0:
    + Release of open-vm-tools matching vSphere 5.5.
  - Remove build dependency on liburiparser (no longer necessary).
  - Removed obsolete --disable-unity configure option.
  - Use doxygen to generate devel docs.
  - Require libprocps for openSUSE 12.3 and above.
  - Added CUSTOM_PROCPS_NAME=procps (required for 9.4.0 build).
  - Add g_info_redefine.patch: Fix redefine warnings during build.
  - Add vmtoolsd.service for use with systemd.
  - Drop open-vm-tools.permissions: No longer required.
  - Only build kmp for specified distributions, and only require kernel-source
    when kernel modules are being built.
  - Rename -gui package to -desktop.
* Sat Nov 02 2013 dimstar@opensuse.org
  - Supplement the -gui package on xorg-x11-server instead of
    xorg-x11 as the latter is only a meta-package, that is not
    installed on all machines (bnc#848505).
* Tue Sep 10 2013 dimstar@opensuse.org
  - Really drop open-vm-tools-kernel-3.8.patch (osc rm).
  - Drop open-vm-tools-kernel-3.6.patch: fixed upstream.
  - Inject -Wno-unused-local-typedefs into CFLAGS.
  - Only build vmsync up to openSUSE 12.3.
  - Disable build of vmhgfs (and related tools) on openSUSE > 12.3,
    as the module fails and VMWare is unresponsive in providing a
    fix. Maybe one day, when there is actual commitment, the module
    and the related tools / mount-helpers can be re-enabled (see also
    bnc#834369).
  - Wrap the KMP Package in a condition to only build when there are
    actually modules to be built (vm_modules not empty).
  - Do not require vmware-guest-kmp from the main package if we do
    not built KMP packages (if there are no modules to be built).
* Mon May 13 2013 dimstar@opensuse.org
  - Update to version 9.2.3:
    + Fixes for HGFS driver to compile on newer kernels (3.9).
    + Fix for HGFS performance regression..
    + vmci/vsock drivers are disabled on kernels 3.9 and above.
    + vmblock driver is disabled on kernels 3.0+.
    + Fix and re-enable Copy/Paste on Solaris.
    + Configure script will detect procsps-ng library.
    + Suppress deprecated warnings coming form newer glib.
  - Drop open-vm-tools-kernel-3.8.patch: fixed upstream.
  - No longer build vmci and vsock for openSUSE > 12.3; they have
    been included in the mainline kernel.
* Wed Apr 24 2013 dimstar@opensuse.org
  - Add open-vm-tools-kernel-3.8.patch: Fix build with kernel 3.8.x.
* Wed Apr 03 2013 dimstar@opensuse.org
  - Update to version 9.2.0:
    + Fixes for HGFS driver to compile on newer kernels (3.6).
    + vmsync driver is disabled on kernels 3.0+ as vmbackup plugin
      uses FIFREEZE/FITHAW standard ioctls.
    + Fixes for Copy/Paste (and C&P is temporarily disabled on
      Solaris due to C++ library issues).
  - Rebase open-vm-tools-kernel-3.6.patch: mostly fixed upstream.
  - No longer build vmblock.ko: it's been obsoleted in favor of
    vmblock-fuse.
  - Change vmtoolsd to use vmware-vmblock-fuse instead of vmblock.ko,
    using the new mount point /var/run/vmblock-fuse.
  - Add fuse Requires, as we now use vmblock-fuse.
    * Fixes bnc#803157.
* Sat Mar 02 2013 coolo@suse.com
  - update license to new format
* Fri Oct 12 2012 dimstar@opensuse.org
  - Update to version 9.2.0:
    + Release of open-vm-tools matching Workstation 9.0.
  - Drop kernel-3_4.patch: fixed upstream.
  - Add open-vm-tools-kernel-3.6.patch: Fix build with kernel 3.6.
  - Add pkgconfig(fuse) BuildRequires: Support vmhgfs fuse.
* Sat Aug 04 2012 dimstar@opensuse.org
  - autostart-wrapper: unset SESSION_MANAGER. This helps newer
    gnome-session versions to not try to track this task. Due to the
    double fork() it gets it wrong and delays logout (waiting for a
    timeout to terminate this user task) (bgo#681904).
* Fri Jun 08 2012 jreidinger@suse.com
  - Add kernel-3_4.patch: Fix build for kernel-3.4.
* Fri Apr 06 2012 dimstar@opensuse.org
  - Update to version 8.8.2:
    + Updated code for compatibility with newer Linux kernel
      releases.
    + Minor tweaks in Unity and Resolution set plugins
  - Drop vmhgfs-2011.12.20.patch: fixed upstream.
* Fri Mar 30 2012 dimstar@opensuse.org
  - Build vmci as first module and copy Modules.symvers to source of
    all subsequent modules to be built. Fixes issues where vmhgfs for
    example does not have all symbols available and fails to load
    [bnc#703959].
* Fri Mar 30 2012 dimstar@opensuse.org
  - Add a tools.conf to the package. All settings are left to default
    except [guestinfo] / disable-perf-mon=1, which resolves
    bnc#698181.
* Thu Mar 15 2012 prusnak@opensuse.org
  - added call to vmware-rpctool in %preun to unset the installed
    version [bnc#748517]
* Sun Feb 05 2012 dimstar@opensuse.org
  - Add vmhgfs-2011.12.20.patch: Fix build of vmhgfs module with
    kernel 3.2.
  - Update FSF address part in vmtoolsd header.
* Tue Jan 24 2012 prusnak@opensuse.org
  - Update to version 8.8.1 (Stable series):
    * Updated code for compatibility with newer Linux kernel releases
      and with newer NetworkManager releases.
  - dropped vmxnet+kernel-3.0 (not needed anymore)
  - build with PIE [bnc#743130]
* Wed Sep 21 2011 dimstar@opensuse.org
  - Update to version 8.8.0 (Stable series):
    + This release of open-vm-tools matches the VMware Tools package
      released with Workstation 8.0 and Fusion 4.0.
      It's targeted at desktop users who want the latest features in
      (VMware's) Unity, HGFS and drag & drop support.
  - Add open-vm-tools-vmxnet+kernel-3.0.patch: HAVE_NETDEV_PRIV is
    gone in kernel 3.0 and netdev_priv is in kernel since 2.6.6.
  - use set_permissions instead of run_permissions on 11.4+
* Thu Jul 21 2011 dimstar@opensuse.org
  - Update to version 2011.07.19:
    + Fix an issue in the HGFS driver that could lead to a kernel
      panic.
    + Update some code to support new compiler and kernel versions.
    + Minor bug fixes and code cleanup.
  - Changes from version 2011.06.27:
    + A few enhancements to Unity: XFCE support, better interaction
      with "the other" (Ubuntu's) Unity and compositing window
      managers, better X error handling, and a few bug fixes.
    + few bug fixes in HGFS, and minor bug fixes in other components.
    + Otherwise, mostly code cleanup.
* Thu Jun 02 2011 prusnak@opensuse.org
  - updated to 2011.05.27:
    + Mostly cleanups and a few bug fixes.
  - fixes [bnc#673267] [bnc#690491]
* Tue May 31 2011 prusnak@opensuse.org
  - use -Wno-unused-but-set in optflags so it will not fail build
    while using -Werror
* Wed May 25 2011 prusnak@opensuse.org
  - added check in initscript whether VMTOOLSUSER_BIN exists
* Fri Apr 29 2011 dimstar@opensuse.org
  - Udpate to version 2011.04.25:
    + Mostly cleanups and small bug fixes in this release.
    + Logging is enabled by default in vmtoolsd, writing to syslog.
      The default log level is not chatty, so few messages should
      make it to syslog during normal operation.
    + The GUI version of the toolbox was removed.
* Wed Apr 27 2011 dimstar@opensuse.org
  - Extend the init script to detect the name of the balloon driver,
    which changed several times in the kernel.
* Thu Apr 14 2011 dimstar@opensuse.org
  - Update to 2011.03.28:
    + HGFS mounter and vmusr's suid wrapper were changed to avoid
      issues with symlink attacks. A new mount utility for vmblock on
      Solaris and FreeBSD was added.
    + The VMCI driver was thoroughly reworked so that it can serve as
      both the host and guest VMCI driver. This is mostly targeted at
      supporting nested VMs.
    + vmusr got better integration with X's session manager,
      including proper cleanup during session teardown.
    + Unity has been enhanced to better handle some desktop
      environments.
    + Many small bug fixes in other areas, including updates for
      newer Linux kernels.
  - Changes from 2011.02.23:
    + Some copy & paste issues with KDE were fixed.
    + Mostly cleanups and bug fixes, with a few build enhancements.
  - Changes from 2011.01.24:
    + Mostly cleanups and bug fixes.
    + Install code fixed to handle translation catalogs correctly.
  - No longer care for missing modules on openSUSE 11.2. It is EOL in
    a few weeks. As a consequence, remove the sources (they are in
    current kernels):
    + pvscsi.tar.bz2
    + vmxnet3.tar.bz2
    + vmemctl.tar.bz2
  - Fix some lint warnings: obsolete only <, not <=, Add PreReq:
    permissions to the -gui package.
* Thu Apr 14 2011 dimstar@opensuse.org
  - Fix build with Factory: verify the list of modules that are not
    yet merged into the main kernel.
* Wed Dec 22 2010 dimstar@opensuse.org
  - Update to version 2010.12.19:
    + New version of DnD code lands in open-vm-tools. The host part
      of the new DnD protocol is not available yet in VMware
      products, though.
    + vmtoolsd gets some new functionality to support new features
      being developed internally.
    + vmxnet driver for FreeBSD fixed to allow changing the MAC
      address.
    + lots of bug fixes and other cleanups in various areas.
  - Re-enable building of X dependenices (with_X 1)
  - Disable unity on openSUSE < 11.4. It requires glib >= 2.24.
* Thu Nov 25 2010 dimstar@opensuse.org
  - Re-Inject pvscsi for older kernel builds.
* Mon Nov 22 2010 dimstar@opensuse.org
  - Update to version 2010-11-17:
    + Mostly cleanups and bug fixes.
    + vmxnet3 on Solaris now supports jumbo frames.
  - For all older updates, please see NEWS.
  - Add an easy way to enable/disable X tools. Those currently fail
    to build.
  - Drop open-vm-tools-libpng14.patch: upstream fixed.
* Mon Jun 07 2010 dimstar@opensuse.org
  - Add vmmemctl.tar.bz2, extracted from open-vm-tools 2010.02.23.
* Mon May 31 2010 dimstar@opensuse.org
  - Better logic to easily disable modules that got inlcluded in the
    Linux Kernel, for bnc#605085.
* Thu Apr 22 2010 dimstar@opensuse.org
  - Re-introduce vmxnet3 on openSUSE <= 11.2. Up to then we have
    kernel 2.26.31, which does not bring the vmxnet3 driver yet.
    The driver itself is the last one shipped with open-vm-tools,
    version 2009.12.16.
* Wed Apr 21 2010 dimstar@opensuse.org
  - Send SIGUSR1 to vmware-user process when the services are being
    stopped. This possibly solves bnc#544400.
* Wed Apr 07 2010 dimstar@opensuse.org
  - Add open-vm-tools-libpng14.patch to fix build with libpng 1.4.
* Wed Mar 24 2010 dimstar@opensuse.org
  - Update to 2010.03.20:
    + New i18n support for Tools; it is based on VMware's internal
      tools
    + Logging infrastructure has been enhanced and now supports
      rotation
    + Bug fixes in several areas (DnD, backup support, thread safety)
    + Updates in Linux kernel modules for compatibility with newer
      kernels.
    + New functionality in the Unity support code.
* Tue Mar 23 2010 dimstar@opensuse.org
  - Disabled vmxnet3 building. this only did not give an error anyhow
    as there was a typo, thus having the module already disabled for
    quite some time.
  - bnc#590329: Re-add lost 50-vmnics.conf file.
* Thu Feb 25 2010 dominique.leuenberger@tmf-group.com
  - Update to 2010.02.23:
    + Mostly bug fixes, cleanups and code refactoring.
* Wed Feb 10 2010 dimstar@opensuse.org
  - Update to 2010.01.19:
    + Linux modules have been updated to compile on newer kernels
    + Solaris modules now should compile on OpenSolaris
      (tested on 2009.06).
    + Other than those, mostly bug fixes and minor refactoring.
* Wed Jan 06 2010 dimstar@opensuse.org
  - Update to 2009.12.16:
    + Some improvements to vmtoolsd, base libraries and and the
      plugin interface.
    + Some library refactoring: use new lock library, changes to
      support compilation of some code on ARM.
    + some fixes in configure.ac to try to correctly support newer
      distros.
    + vsock/vmci improvements.
    + bug fixes in the vmxnet / vmxnet3 drivers, and FreeBSD's
      vmblock driver.
    + vmxnet3 for Linux is now upstream (as of Linux 2.6.32), and
      will be removed from later releases of open-vm-tools.
    + pvscsi will be available upstream starting with Linux 2.6.33
      and at that time will be removed from open-vm-tools.
  - Disable building of vmxnet3 if kernel is 2.6.32 or newer.
* Mon Nov 23 2009 dimstar@opensuse.org
  - Update to 2009.11.17
    + Lots of refactoring and cleanup in the code, mainly targeting
      the definition of a set of public APIs.
    + vmblock-fuse can now replace the vmblock kernel module for DnD
      operations.
    + Fix some memory leaks in the guestInfo module.
* Sun Nov 22 2009 dimstar@opensuse.org
  - Update to 2009.10.15
    + The HGFS module got some performance enhancements.
    + Minor enhancements to vmtoolsd and the logging system.
    + Fix for a few issues reported on the sourceforge bug tracker.
    + Lots of code refactoring, and a few bug fixes.
* Sat Nov 21 2009 dimstar@opensuse.org
  - Update to 2009.09.18
    + Mostly bug fixes and minor enhancements.
    + The pvscsi code was re-factored in preparation for upstreaming.
      The driver has been sent to the LKML for inclusion in the main
      Linux tree and might be removed from open-vm-tools once it's
      accepted.
* Mon Aug 10 2009 dimstar@opensuse.org
  - Update to 2009.08.24
    + Remove support for Linux kernels < 2.6.9.
    + The vsock now implements a new notification protocol that has
      better performance than the previous.
    + New infrastructure for sending more network config-related
      information about the virtual machine to the host.
    + Other bug fixes and minor improvements to the code.
* Sat Aug 08 2009 dominique-obs@leuenberger.net
  - move libguestlib.so to the devel pakage, which we have since
    version 2009.07.22 and remove the rpmlint check for it.
  - Remove the autoreconf call. We do not patch any Makefiles anymore.
  - Require libvmtools0 from the -devel package.
  - Drop the rpmlintrc file. Permissions are correctyl set, devel
    package split out.
* Thu Aug 06 2009 meissner@suse.de
  - Adjust specfile permission handling to match SUSE standard, snippet
    moved to permissions package. bnc#474285
* Thu Jul 23 2009 dominique-obs@leuenberger.net
  - Update to 2009.07.22
    * Better support for dkms by means of a script to help create a
      dkms tree.
    * "make install" now also installs header files for public
      libraries, plus a few fixes to incorrect install behavior.
    * Lots of improvements to the new DnD code.
    * This will be the last release with support for Linux
      kernels < 2.6.9.
  - fix compatibiliy update script to redirect stderr to /dev/null
    (in case the script is not found, do not scare the user)
* Tue Jul 21 2009 prusnak@suse.cz
  - added || : to modprobe -r and umount calls in vmtoolsd [bnc#523342]
* Fri Jun 19 2009 dominique-obs@leuenberger.net
  - Updated to 2009.06.18
    * Mostly a bug fix release.
    * vmhgfs now is able to use vsock as a transport (although
      backend support for HGFS over vsock is not yet released in
      VMware products).
  - Removed patch open-vm-tools-wiperPosix.patch. An alternative
    solution was integrated upstream
  - Dropped patch open-vm-tools-rpath.patch: merged upstream
* Sat May 23 2009 dominique-obs@leuenberger.net
  - Updated to 2009.05.22
    * Mostly a cleanup and bug fix release.
    * Fix a build issue where a symlink attack could cause the
      open-vm-tools build to overwrite data (by placing a symlink in
      /tmp).
    * Second (and last?) batch of changes to clean up duplicate files
      in the source tree, including Solaris and FreeBSD kernel
      modules andother module-specific shared files.
    * Plugins now are properly built using plugins_LTLIBRARIES so
      that "-rpath" doesn't need to be used (this would cause an
      RPATH entry to be added to the final binary, which some tools
      didn't like).
    * open-vm-tools now properly detects PAM and enables PAM support
      in the code.
  - Removed -rpath.patch. Variation of it integrated upstream
  - Added patch to consume (-wiperPosix.patch) the result of fgets
  - BuildRequires pam-devel
  - The pam miss-naming on x86_64 has been fixed upstream
  - Add a new -rpath patch. Not everything is solved upstream.
  - Delete arch dependent files from /usr/share (not yet needed)
* Sat Apr 25 2009 dominique.leuenberger@tmf-group.com
  - Upgrade to snapshot 2009.04.23
    * Implemented copy & paste support for RTF data and file contents.
    * guestd has been removed from open-vm-tools; vmtoolsd is now the only
      option for the main tools service.
    * Added vmblock and vmmemctl modules for Solaris (under the CDDL).
    * vmware-user can now work with both vmblock-fuse and vmblock.
    * Linux HGFS now has a stream-based (TCP, vsock) transport, still under
      development.
    * First batch of changes to cleanup duplicated files in the source tree.
      Most duplicated files in the Linux kernel modules have been cleaned up.
  - Extensive rewrite of the spec file:
    * make use of the now upstream provided make install
    * configure --no-root-privileges, to not install mount.vmhgfs as suid
  - Add patch open-vm-tools-2009.04.23-rpath.diff: removes the rpath logic
    which was introduced for the vmusr and vmsvc plugins. libtools is broken
    in this respect. (patch submitted upstream for review)
  - Extend preun section with  service rename (vmware-guest -> vmtoolsd)
    (patch provided by prusnak)
  - forcibly activate vmtoolsd service also on update.
  - fix up the KMP rename: for this to work we need to provide / obsolete
    vmware-kmp and vmware-kmp-<kernelflavor>; otherwise, zypper starts pulling
    in other kernels.
* Fri Mar 20 2009 dominique@leuenberger.net
  - rename vmware-KMP to vmware-guest-KMP for easier identification
    of the use and to avoid confusion (users installing the KMP on the
    vmware hosts) (bnc#481137)
  - create subpackage libvmtools0
* Thu Mar 19 2009 dominique@leuenberger.net
  - Upgrade to snapshot 2009.03.18
    * Mostly a bug fix release.
    * The new DnD V3 protocol is now available in open-vm-tools.
    * vmtoolsd is now preferred instead of vmware-guestd
    - vmware-guestd will most probably be completely removed in the next release.
    - > vmtoolsd is not yet standard enabled in openSUSE packages.
  - Obsolete merged patches vmxnet and vmxnet3.patch.
* Mon Mar 09 2009 mmarek@suse.cz
  - renamed modprobe config to /etc/modprobe.d/50-vmnics.conf
    (required by new module-init-tools).

Files

/usr/lib64/libDeployPkg.so.0
/usr/lib64/libDeployPkg.so.0.0.0
/usr/lib64/libguestlib.so.0
/usr/lib64/libguestlib.so.0.0.0
/usr/lib64/libhgfs.so.0
/usr/lib64/libhgfs.so.0.0.0
/usr/lib64/libvgauth.so.0
/usr/lib64/libvgauth.so.0.0.0
/usr/lib64/libvmtools.so.0
/usr/lib64/libvmtools.so.0.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 10 02:10:09 2018