Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libproxy1-0.4.18-1.2 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: libproxy1 Distribution: openSUSE Tumbleweed
Version: 0.4.18 Vendor: openSUSE
Release: 1.2 Build date: Wed Aug 31 14:32:24 2022
Group: System/Libraries Build host: build76
Size: 152495 Source RPM: libproxy-0.4.18-1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://libproxy.github.io/libproxy/
Summary: Automatic proxy configuration management for applications
libproxy is a library that provides automatic proxy configuration
management.

Proxy autoconfiguration (PAC) requires JavaScript (which most
applications do not have), and determing the PAC script location
requires a WPAD protocol implementation, which complicate proxy
support. libproxy exists to abstract this issue and provides
an answer how to reach a certain network resource.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Tue Jun 21 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Add libproxy-perl-cflags.patch: perl: Use ccflags from %Config
    for libproxy module compilation; fixes perl test suite on i586.
* Mon Jun 20 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 0.4.18:
    + build: Allow configuration of sysconfig module.
    + config_envvar: Add environment variable for pacrunner
      debugging.
    + build: disable mozjs by default.
    + python: Support Python 3.10 and above.
    + Add Duktape pacrunner module.
    + config_kde: Compute list of config file locations ourselves.
    + cpmfog_gnome3: Add gnome-wayland to permitted DESKTOP_SESSION.
  - Drop libproxy-python-310.patch: fixed upstream.
  - Build duktape pacrunner module:
    + Add pkgconfig(duktape): new dependency.
    + Split new subpackage libproxy1-pacrunner-duktape.
    + Suggest duktape pacrunner for config modules recommending a
      pacrunner.
* Mon May 16 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Add libproxy-python-310.patch: Detect python 3.10.
* Thu Feb 10 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Drop gconf2-devel BuildRequires: libproxy was ported to gsettings
    quite some time ago.
  - Update our Supplements to current standard.
* Tue Jul 13 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Do no longer BuildRequire libmodman-devel: libproxy 0.4.17 was
    changed upstream to only support to internal version (no other
    consumer of libmodman exists).
  - No longer pass -DFORCE_SYSTEM_LIBMODMAN=ON to cmake: not
    understood anymore (boo#1188265).
* Tue Dec 29 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 0.4.17:
    + python bindings: fix "TypeError: argtypes must be a sequence of
      types".
  - Drop 147.patch: fixed upstream.
* Mon Dec 14 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Add 147.patch: python bindings: fix "TypeError: _argtypes_ must
    be a sequence of types".
* Fri Dec 04 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 0.4.16:
    + Port to, and require, SpiderMonkey 6.
    + Use closesocket() instead of close() on Windows.
    + Add symbol versions - be ready to introduce new APIs as needed.
    + Add public px_proxy_factory_free_proxies function.
    + Add PacRunner config backend (largely untested; feedback
      welcome!).
    + Small performance improvements.
    + pxgsettings: use the correct syntax to connect to the changed
      signal (silences annoying output on console).
    + Support python3 up to version 3.9.
    + Fix buffer overflow when PAC is enabled (CVE-2020-26154).
    + Rewrite url::recvline to be nonrecursive (CVE-2020-25219).
    + Remove nonfunctional and crashy pacrunner caching.
    + Never use system libmodman (no other consumers, not
      maintained).
  - Drop upstream merged patches:
    + libproxy-python3.7.patch
    + libproxy-pxgsettings.patch
    + libproxy-CVE-2020-25219.patch
    libproxy-fix-pac-buffer-overflow.patch
  - Create new sub-package libproxy1-config-pacrunner.
* Wed Sep 30 2020 Michael Gorse <mgorse@suse.com>
  - Add libproxy-CVE-2020-25219.patch: Rewrite url::recvline to be
    nonrecursive (boo#1176410 CVE-2020-25219).
  - Add libproxy-fix-pac-buffer-overflow.patch: fix buffer overflow
    when PAC is enabled (boo#1177143 CVE-2020-26154).
* Mon Sep 14 2020 Yifan Jiang <yfjiang@suse.com>
  - Build with KDE on Tumbleweed, Leap and SLE releases greater than
    SLE-15-SP2 (jsc#SLE-12256).
* Mon Apr 27 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Add libproxy-pxgsettings.patch: pxgsettings: use the correct
    syntax to connect to the changed signal.
* Thu Mar 12 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Remove few SLE11 conditions
  - Fix build without python2 available

Files

/usr/lib64/libproxy-0.4.18
/usr/lib64/libproxy-0.4.18/modules
/usr/lib64/libproxy.so.1
/usr/lib64/libproxy.so.1.0.0
/usr/libexec/libproxy-0.4.18
/usr/share/doc/packages/libproxy1
/usr/share/doc/packages/libproxy1/AUTHORS
/usr/share/doc/packages/libproxy1/README
/usr/share/licenses/libproxy1
/usr/share/licenses/libproxy1/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Dec 1 23:35:24 2022