Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python312-packaging-24.0-1.2 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: python312-packaging Distribution: openSUSE Tumbleweed
Version: 24.0 Vendor: openSUSE
Release: 1.2 Build date: Sat Mar 16 10:28:29 2024
Group: Unspecified Build host: reproducible
Size: 188145 Source RPM: python-packaging-24.0-1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://packaging.pypa.io/
Summary: Core utilities for Python packages
Reusable core utilities for various Python Packaging interoperability specifications.

This library provides utilities that implement the interoperability specifications
which have clearly one correct behaviour (eg: PEP 440) or benefit greatly from having
a single shared implementation (eg: PEP 425).

Provides

Requires

License

Apache-2.0 AND BSD-2-Clause

Changelog

* Sat Mar 16 2024 Dirk Müller <dmueller@suse.com>
  - update to 24.0:
    * Do specifier matching correctly when the specifier contains
      an epoch number and has more components than the version
      (:issue:`683`)
    * Support the experimental --disable-gil builds in
      packaging.tags (:issue:`727`)
    * BREAKING: Make optional metadata.Metadata attributes default
      to None (:issue:`733`)
    * Fix errors when trying to access the
      description_content_type, keywords, and requires_python
      attributes on metadata.Metadata when those values have not
      been provided (:issue:`733`)
    * Fix a bug preventing the use of the built in ExceptionGroup
      on versions of Python that support it (:issue:`725`)
* Thu Nov 09 2023 ecsos <ecsos@opensuse.org>
  - Update ot 23.2:
    * parse_marker should consume the entire source string in #687
    * Create a Security Policy file in #695
    * Add python 3.12 to CI in #689
    * Remove URL validation from requirement parsing in #684
    * Add types for packaging.version._Version in #665
    * Add PyPy 3.10 to CI in #699
    * Remove unused argument in _manylinux._is_compatible in #700
    * Canonicalize names for requirements comparison in #696
    * Add platform tag support for LoongArch in #693
    * Ability to install armv7l manylinux/musllinux wheels on armv8l in #690
    * Include CHANGELOG.rst in sdist in #704
    * Update pyupgrade to Python 3.7+ in #580
    * Fix version pattern pre-releases in #705
    * Fix typos found by codespell in #706
    * Support enriched metadata in #686
    * Correct rST syntax in CHANGELOG.rst in #709
    * fix: platform tag for GraalPy in #711
    * Document that this library uses a calendar-based versioning scheme in #717
    * fix: Update copyright date for docs in #713
    * Bump pip version to avoid known vulnerabilities in #720
    * Typing annotations fixed in version.py in #723
    * parse_{sdist,wheel}_filename: don't raise InvalidVersion in #721
    * Fix code blocks in CHANGELOG.md in #724
* Fri Apr 21 2023 Dirk Müller <dmueller@suse.com>
  - add sle15_python_module_pythons (jsc#PED-68)
* Sat Apr 15 2023 Dirk Müller <dmueller@suse.com>
  - update to 23.1
    * chore: add typed classifier
    * Improve parser error messaging around mistakes in/around
      version specifiers
    * Upgrade to latest mypy
    * Delete print() from test_tags
    * Update our linters
    * Improve error for local version label with unsupported operators
    * Parse raw metadata
    * Handle prefix match with zeros at end of prefix correctly
    * Relax typing of _key on _BaseVersion
    * Replace spaces in platform names with underscores
    * Import underlying parser function as an underscored variable
* Thu Apr 13 2023 Matej Cepl <mcepl@suse.com>
  - Make calling of %{sle15modernpython} optional.
* Thu Mar 09 2023 Dirk Müller <dmueller@suse.com>
  - Don't use :primary multibuild flavor for non-Tumbleweed
    * accomodates special SLE15 projects defininig extra flavors but
      not building for primary python3
* Fri Jan 13 2023 Ben Greiner <code@bnavigator.de>
  - Update to v23.0
    * Remove unused LPAREN token from tokenizer by @hrnciar in #630
    * Reorganise the project layout and version management by
      @pradyunsg in #626
    * Correctly handle non-normalised specifiers in requirements by
      @pradyunsg in #634
    * Use stable Python 3.11 in tests by @153957 in #641
    * Fix typing for specifiers.BaseSpecifier.filter() by @henryiii
      in #643
    * Correctly handle trailing whitespace on URL requirements by
      @pradyunsg in #642
    * refactor _generic_api to use EXT_SUFFIX by @mattip in #607
    * Allow "extra" to be None in the marker environment by
      @pradyunsg in #650
    * Fix typos by @kianmeng in #648
    * Update changelog for release by @pradyunsg in #656
* Fri Dec 30 2022 Ben Greiner <code@bnavigator.de>
  - Update to v22.0
    * Fix compatible version specifier incorrectly strip trailing '0'
      by @kasium in #493
    * Remove support for Python 3.6 by @abravalheri in #500
    * Use concurrency limit in ci by @blink1073 in #510
    * Fix issue link in changelog. by @bdice in #509
    * chore: test with PyPy 3.8 & 3.9 by @mayeut in #512
    * Accept locally installed prereleases by @q0w in #515
    * Always run GHA workflows when they change by @mayeut in #516
    * Add __hash__/__eq__ to requirements by @abravalheri in #499
    * Upgrade to setup-python v3 and use caching for GHA by
      @brettcannon in #521
    * allow pre-release versions in marker evaluation by @graingert
      in #523
    * Error out from workflow on missing interpreter by @mayeut in
      [#525]
    * chore: update pre-commit config to the latest repos' versions
      by @mayeut in #534
    * chore: remove Windows PyPy 3.9 workaround on GHA by @mayeut in
      [#533]
    * Use pipx to run nox / build in GHA workflows by @mayeut in #517
    * Run tests with all PyPy versions locally by @mayeut in #535
    * Adhere to PEP 685 when evaluating markers with extras by
      @hroncok in #545
    * chore: update mypy and move to toml by @henryiii in #547
    * Normalize extra comparison in markers for output by
      @brettcannon in #549
    * Evaluate markers under environment with empty "extra" by
      @MrMino in #550
    * Do not set extra in default_environment() by @sbidoul in #554
    * Update extlinks strings to use a format string by @mayeut in
      [#555]
    * Update CI test workflow to use setup-python@v4 by @mayeut in
      [#556]
    * CI: Update actions/* to their latest major versions by @mayeut
      in #557
    * Fix a spelling mistake by @venthur in #558
    * fix: macOS platform tags with old macOS SDK by @mayeut in #513
    * Correctly parse ELF for musllinux on Big Endian by @uranusjr in
      [#538]
    * A metadata module with a data class for core metadata by
      @brettcannon in #518
    * Document utils.NormalizedName by @brettcannon in #565
    * Drop LegacySpecifier and LegacyVersion by @pradyunsg in #407
    * Move metadata, versions and specifiers API documentation to
      sphinx.ext.autodoc by @pradyunsg in #572
    * Demonstrate behaviour of SpecifierSet.__iter__ by @hauntsaninja
      in #575
    * Handwritten parser for parsing requirements by @hrnciar in #484
    * Add changelog entry for removal of pyparsing dependency by
      @hroncok in #581
    * Use Iterator instead of Iterable for specifier filter methods
      by @ichard26 in #584
    * Better output on linter failure by @henryiii in #478
    * Add a "cpNNN-none-any" tag by @joonis in #541
    * Document exceptions raised by functions in utils by @MrMino in
      [#544]
    * Refactor ELF parsing logic to standlone class by @uranusjr in
      [#553]
    * Forbid prefix version matching on pre-release/post-release
      segments by @mayeut in #563
    * Update coverage to >=5.0.0 by @mayeut in #586
    * Normalize specifier version for prefix matching by @mayeut in
      [#561]
    * Add python 3.11 by @mayeut in #587
    * Fix prefix version matching by @mayeut in #564
    * Remove duplicate namedtuple by @layday in #589
    * Update changelog by @pradyunsg in #595
    * Change email-related fields in Metadata to str by @brettcannon
      in #596
    * Add versionchanged for 21.3 by @brettcannon in #599
    * refactor: use flit as a backend by @henryiii in #546
    * Remove packaging.metadata by @pradyunsg in #603
    * Refactor nox requirements to use requirements files (#601) by
      @strokirk in #609
    * Improve Requirement/Marker parser with context-sensitive
      tokenisation by @pradyunsg in #624
  - The new usage of the flit-core backend simplifies the bootstrap
  - Remove old-distro shims: This one requires Python 3.7+, thus
    all non-Tumbleweed backports or future distros must provide the
    primary_python macro and similar themselves.
  - Drop fix-big-endian-build.patch upstreamed gh#pypa/packaging#538
* Mon Aug 01 2022 Ben Greiner <code@bnavigator.de>
  - BuildIgnore python3-packaging for primary bootstrap.
* Thu Jul 21 2022 Ben Greiner <code@bnavigator.de>
  - Refine build and runtime requirements for primary and non-primary
    builds
* Thu Jul 21 2022 John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>
  - Update in SLE-15 (bsc#1199282, jsc#PM-3243, jsc#SLE-24629)
* Fri Jul 15 2022 Ben Greiner <code@bnavigator.de>
  - Split primary flavor in multibuild for possible inclusion into
    Ring0
* Thu Jul 14 2022 Ben Greiner <code@bnavigator.de>
  - Setuptools itself does not depend on packaging anymore, only for
    pythondistdeps.py, That dependency will move to
    python-rpm-packaging soon. -- boo#1178257
  - Use "setuptools" for building again.
    * Python 3.12 will drop the distutils fallback
    * Use the python-base vendored pip in a venv
    * Drop no-legacyversion-warning.patch
  - Remove nonsensical python362 flavor check.
* Sun May 29 2022 John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>
  - Add patch to fix testsuite on big-endian targets
    + fix-big-endian-build.patch
* Mon Apr 25 2022 Hui-Zhi Zhao <hui.zhi.zhao@suse.com>
  - Ignore python3.6.2 since the test doesn't support it.
* Wed Nov 24 2021 Matthias Fehring <buschmann23@opensuse.org>
  - update to 21.3:
    * Add a pp3-none-any tag (gh#pypa/packaging#311)
    * Replace the blank pyparsing 3 exclusion with a 3.0.5 exclusion
      (gh#pypa/packaging#481), (gh#pypa/packaging#486)
    * Fix a spelling mistake (gh#pypa/packaging#479)
* Sat Nov 06 2021 Dirk Müller <dmueller@suse.com>
  - update to 21.2:
    * Update documentation entry for 21.1.
    * Update pin to pyparsing to exclude 3.0.0.
    * PEP 656: musllinux support
    * Drop support for Python 2.7, Python 3.4 and Python 3.5.
    * Replace distutils usage with sysconfig
    * Add support for zip files in ``parse_sdist_filename``
    * Use cached ``_hash`` attribute to short-circuit tag equality comparisons
    * Specify the default value for the ``specifier`` argument to ``SpecifierSet``
    * Proper keyword-only "warn" argument in packaging.tags
    * Correctly remove prerelease suffixes from ~= check
    * Fix type hints for ``Version.post`` and ``Version.dev``
    * Use typing alias ``UnparsedVersion``
    * Improve type inference for ``packaging.specifiers.filter()``
    * Tighten the return type of ``canonicalize_version()``
* Thu Jun 17 2021 Ben Greiner <code@bnavigator.de>
  - Add Provides: for python*dist(packaging): work around boo#1186870
  - skip tests failing because of no-legacyversion-warning.patch
* Sat May 01 2021 Dirk Müller <dmueller@suse.com>
  - add no-legacyversion-warning.patch to restore compatibility with 20.4
* Tue Feb 02 2021 Dirk Müller <dmueller@suse.com>
  - update to 20.9:
    * Run [isort](https://pypi.org/project/isort/) over the code base (:issue:`377`)
    * Add support for the ``macosx_10_*_universal2`` platform tags (:issue:`379`)
    * Introduce ``packaging.utils.parse_wheel_filename()`` and ``parse_sdist_filename()``

Files

/usr/lib/python3.12/site-packages/packaging
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/INSTALLER
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/LICENSE
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/LICENSE.APACHE
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/LICENSE.BSD
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/METADATA
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/RECORD
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/REQUESTED
/usr/lib/python3.12/site-packages/packaging-24.0.dist-info/WHEEL
/usr/lib/python3.12/site-packages/packaging/__init__.py
/usr/lib/python3.12/site-packages/packaging/_elffile.py
/usr/lib/python3.12/site-packages/packaging/_manylinux.py
/usr/lib/python3.12/site-packages/packaging/_musllinux.py
/usr/lib/python3.12/site-packages/packaging/_parser.py
/usr/lib/python3.12/site-packages/packaging/_structures.py
/usr/lib/python3.12/site-packages/packaging/_tokenizer.py
/usr/lib/python3.12/site-packages/packaging/markers.py
/usr/lib/python3.12/site-packages/packaging/metadata.py
/usr/lib/python3.12/site-packages/packaging/py.typed
/usr/lib/python3.12/site-packages/packaging/requirements.py
/usr/lib/python3.12/site-packages/packaging/specifiers.py
/usr/lib/python3.12/site-packages/packaging/tags.py
/usr/lib/python3.12/site-packages/packaging/utils.py
/usr/lib/python3.12/site-packages/packaging/version.py
/usr/share/doc/packages/python312-packaging
/usr/share/doc/packages/python312-packaging/README.rst
/usr/share/licenses/python312-packaging
/usr/share/licenses/python312-packaging/LICENSE
/usr/share/licenses/python312-packaging/LICENSE.APACHE
/usr/share/licenses/python312-packaging/LICENSE.BSD


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Jun 22 00:17:53 2024