Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libnotify-devel-32bit-0.7.5-2.2.2 RPM for x86_64

From OpenSuSE 12.2 for x86_64

Name: libnotify-devel-32bit Distribution: openSUSE 12.2
Version: 0.7.5 Vendor: openSUSE
Release: 2.2.2 Build date: Mon Jul 16 06:50:47 2012
Group: Development/Libraries/X11 Build host: build24
Size: 0 Source RPM: libnotify-0.7.5-2.2.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.galago-project.org/
Summary: Notifications Library
D-BUS notifications library.

Provides

Requires

License

LGPL-2.1+

Changelog

* Mon Jul 09 2012 cfarrell@suse.com
  - license update: LGPL-2.1+
    No GPL-2.0+ files found in the package. The Fedora package is also
    licensed under LGPL-2.1+
* Tue Mar 27 2012 vuntz@opensuse.org
  - Update to version 0.7.5:
    + Build fixes
    + Documentation improvements
    + Spec clarifications
* Thu Dec 08 2011 dimstar@opensuse.org
  - Split typelib file into typelib-1_0-Notify-0_7 subpackage.
  - Add typelib-1_0-Notify-0_7 Requires to devel subpackage.
* Fri Sep 16 2011 jengelh@medozas.de
  - Enable libnotify-devel for all baselibs archs
  - Remove redundant tags/sections; use %_smp_mflags
* Tue Aug 30 2011 vuntz@opensuse.org
  - Update to version 0.7.4:
    + Improve documentation of supported image data formats
    + Test notification removal
    + Build system changes
* Tue May 17 2011 dimstar@opensuse.org
  - Update to version 0.7.3:
    + Add a way to change the application name for individual
      notifications.
* Tue Mar 22 2011 fcrozat@novell.com
  - Update to version 0.7.2:
    + Add a way to change the application name
    + Mark image_path as deprecated
    + Allow properties to be set in any order
* Mon Feb 07 2011 fcrozat@novell.com
  - Update to version 0.7.1:
    + Don't export private symbols
    + Introspection support and annotations
    + Documentation cleanups and fixes
    + Ref the pixbuf passed to set_image_from_pixbuf
    + Add tests for new capabilities and hints
    + Update spec to mention "persistence" and "action-icons" server
      capability and "action-icons", "transient" and "resident"
      hints.
    + Bump spec version to 1.2
  - Add gobject-introspection-devel BuildRequires to build
    introspection.
  - Add support for source service checkout, with %BUILD_FROM_VCS:
    + Add gnome-common, gtk-doc BuildRequires.
    + Add call to ./autogen.sh.
    + Enforce gtk-doc html generation by passing --enable-gtk-doc to
      configure.
  - Change devel package group from System/Libraries to
    Development/Libraries/X11, to fix rpmlint warning.
* Fri Dec 17 2010 vuntz@opensuse.org
  - Update to version 0.7.0:
    + Remove the ability to attach notifications to widgets or
      positions
    + Add a test for the persistence server capability
    + Port to use GBus instead of dbus-glib
    + Add a macro to get library version number
    + Remove GTK+ dependency from library
    + Port tests to GTK+ 3
  - Remove pkgconfig(dbus-1), pkgconfig(dbus-glib-1),
    pkgconfig(gtk+-2.0) BuildRequires.
  - Add explicit pkgconfig(gdk-pixbuf-2.0) BuildRequires.
  - Rename libnotify1 to libnotify4, following the soversion change.
* Mon Oct 04 2010 vuntz@opensuse.org
  - Update to version 0.6.0:
    + Fix crashes (bgo#623096, lp#570462).
* Thu Jul 22 2010 vuntz@opensuse.org
  - Create a tools subpackage, and move the notify-send utility
    there. The main libnotify package is not needed anymore, so make
    the tools subpackage provide/obsolete it.
  - Move the notification-daemon Recommends to libnotify1, since it's
    where it really belongs.
  - Remove libnotify Requires in libnotify1: it's not needed.
  - Remove dbus-1-devel, dbus-1-glib-devel, glib2-devel, gtk2-devel
    Requires in devel package: they will automatically get added with
    pkgconfig() Requires.
* Fri Jul 16 2010 dimstar@opensuse.org
  - Update to version 0.5.1:
    + Remove explicit GTK+ 2.x linking, so that libnotify can link
      against both GTK+ 2.x or GTK+ 3.x
  - Changes from version 0.5.0:
    + Support for version 1.1 of notification spec
    - bgo#608089: Applications aborted at finalizing when the dbus
      session is being closed.
    - bgo#608082: Arabic text is misplaced in bubbles (RTL)
    - bgo#608086: wrong return value of notify_init()
    - bgo#612720: Does not compile with -DGSEAL_ENABLE
    - bgo#613999: Use g_strcompress in notify-send to parse \n from
      command line
    - bgo#610880: lazily initialize the daemon.
  - BuildRequire gtk3-devel instead of gtk2-devel.
* Fri Jun 04 2010 vuntz@opensuse.org
  - Make devel package depend on libnotify1, not libnotify.
* Tue Jan 05 2010 jengelh@medozas.de
  - Package baselibs.conf
* Sun Apr 26 2009 vuntz@novell.com
  - Do not Require notification-daemon, but Recommend it: there's no
    reason to hard-require it.

Files

/usr/lib/libnotify.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Oct 10 12:25:15 2014