Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gnome-keyring-pam-3.4.1-2.1.2 RPM for x86_64

From OpenSuSE 12.2 for x86_64

Name: gnome-keyring-pam Distribution: openSUSE 12.2
Version: 3.4.1 Vendor: openSUSE
Release: 2.1.2 Build date: Tue Jul 17 02:59:07 2012
Group: System/GUI/GNOME Build host: build21
Size: 43680 Source RPM: gnome-keyring-3.4.1-2.1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.gnome.org/
Summary: GNOME Keyring - PAM module
The GNOME Keyring is a daemon in the session, similar to ssh-agent,
and other applications can use it to store passwords and other
sensitive information.

The program can manage several keyrings, each with its own master
password, and there is also a session keyring which is never stored to
disk, but forgotten when the session ends.

The PAM module can be used to unlock the keyring on login.

Provides

Requires

License

GPL-2.0+ ; LGPL-2.1+

Changelog

* Tue Apr 17 2012 vuntz@opensuse.org
  - Update to version 3.4.1:
    + Set 'text/plain' content type on secrets returned from daemon
    + Use correct XDG_RUNTIME_DIR when started from PAM
    + License fix
    + More tests
    + Build fixes
    + Updated translations.
* Mon Mar 26 2012 vuntz@opensuse.org
  - Update to version 3.4.0:
    + Updated translations.
* Tue Mar 20 2012 vuntz@opensuse.org
  - Update to version 3.3.92:
    + Use runtime dir instead of /tmp for sockets.
    + Fix copyright headers.
    + Build fixes.
    + Updated translations.
* Mon Mar 12 2012 vuntz@opensuse.org
  - Pass --with-ca-certificates=%{_sysconfdir}/ssl/ca-bundle.pem
    instead of --with-root-certs=%{_sysconfdir}/ssl/certs to
    configure: it's better to use the single ca certificates file
    than the directory with all certificates, as it's what upstream
    prefers.
* Fri Mar 09 2012 dimstar@opensuse.org
  - Update to version 3.3.91:
    + Fix regression in changing a keyring master password
    + Set better button labels for the prompts
    + Fix assertion when cancelling a unlock prompt
    + Use a single CA certificates file by default
    + Updated translations.
* Sun Feb 05 2012 dimstar@opensuse.org
  - Update to version 3.3.5:
    + Fix introspection data for SearchItems()
    + Fix regression when an invalid password used to unlock keyring
    + Updated translations.
* Mon Jan 16 2012 vuntz@opensuse.org
  - Update to version 3.3.4:
    + Build fixes
    + Updated translations.
* Wed Dec 21 2011 vuntz@opensuse.org
  - Update to version 3.3.3.1:
    + No message in gnome-keyring-pkcs11.so module, when no daemon
      running
    + Build fixes
    + Updated translations.
  - Drop gnome-keyring-fix-build.patch: fixed upstream.
* Mon Dec 19 2011 vuntz@opensuse.org
  - Update to version 3.3.3:
    + Distribute correct desktop autostart files
    + Use GcrPrompt and GcrSystemPrompt for prompting
    + Do not crash when reading a truncated keyring file
    + Add test tool for dumping the keyring format
    + Update for GckBuilder changes in libgck
    + Fix for deprecations in glib 2.31.x
    + Fix ReadAlias() returning null when 'login' keyring exists
    + Build fixes, bug fixes
  - Add xz BuildRequires because we can't build a package for a
    xz-compressed tarball without explicitly specifying that... See
    bnc#697467 for more details.
  - Add gnome-keyring-fix-build.patch: add some libraries during
    linkage, to fix build; taken from git.
  - Change libgck Requires in libgck-modules-gnome-keyring to gck:
    this is a new Provides in libgck to help us for this Requires, so
    we don't have a Requires on a shared library package, whose name
    can change. Note that we don't version the Requires: there's no
    reason for this.
* Mon Nov 28 2011 dimstar@opensuse.org
  - Fix libgck Requires in libgck-modules-gnome-keyring: as libgck
    got split out, we can't assume any longer that the version will
    always be the same as the one of the main package. For now at
    least we assume that we can maintain the library name.
* Mon Nov 21 2011 dimstar@opensuse.org
  - Update to version 3.3.2:
    + Do not make label selectionnable in prompt dialog
    + Fix deadlock in the 'unsafe storage' prompt
    + Better locking for the old gnome2-store
    + Build fixes
    + Updated translations.
  - Drop gnome-keyring-remove-xfce-lxde-autostart.patch: fixed
    upstream.
* Tue Nov 08 2011 dimstar@opensuse.org
  - Update to version 3.3.1.1:
    + Build correctly against glib 2.31
  - Changes from version 3.3.1:
    + Return most recent secret first when searching
    + Split the Gcr and Gck libraries out of gnome-keyring
    + Build fixes
    + Updated translations.
  - Rebase gnome-keyring-remove-xfce-lxde-autostart.patch.
  - Remove BuildRequires that have moved to the new gcr source
    package: shared-mime-info, pkgconfig(p11-kit-1).
  - Add pkgconfig(gck-1) and pkgconfig(gcr-3) BuildRequires: newly
    depend on the split out library,
  - Drop libgcr-3-1, libgcr-devel, libgck-1-0 and libgck-devel
    subpackages: upstream split the libraries out.
  - Rename libgck-modules to libgck-modules-gnome-keyring: since
    libgck is split away from gnome-keyring, we cannot use a generic
    package name like this anymore. Add appropriate Obsoletes, but
    no Provides as there could be another libgck-modules package
    appearing in the future.
  - Stop calling %mime_database_post(un) in %post/%postun and stop
    passing --disable-update-mime to configure: the mime definition
    moved to the gcr source package.
  - Add missing calls to %desktop_database_post(un) in %post/%postun.
  - Use grep -F instead of deprecated fgrep in %post of pam
    subpackage.
* Tue Nov 08 2011 vuntz@opensuse.org
  - Add pam-config calls in %post/%postun for gnome-keyring-pam in
    baselibs.conf: when pam-32bit is installed, pam-config checks if
    the 32bit version of the module is installed before enabling it,
    and if we install from scratch, this is not necessarily true when
    gnome-keyring-pam is installed. Fix bnc#728586.
* Sun Oct 23 2011 gber@opensuse.org
  - Fixed gnome-keyring-remove-xfce-lxde-autostart.patch which was
    ineffective since it modified the .in rather than the .in.in
    files
* Mon Oct 17 2011 vuntz@opensuse.org
  - Update to version 3.2.1:
    + Fix debugging output, and erroneous warnings
    + Updated translations.
* Mon Oct 03 2011 vuntz@opensuse.org
  - Add explicit shared-mime-info BuildRequires since we use the
    %mime_database_* macros.
* Mon Sep 26 2011 vuntz@opensuse.org
  - Update to version 3.2.0:
    + Don't install setuid when filesystem capabilities not available
    + Updated translations.
  - Update summary to not talk about password manager: this is really
    the keyring, which is more than just a password manager.
* Tue Sep 20 2011 gber@opensuse.org
  - Do not start the gnome-keyring daemon for LXDE or Xfce via XDG
    autostart, that only works with gnome-session
* Sun Sep 18 2011 vuntz@opensuse.org
  - Update to version 3.1.92:
    + Add back the file format "documentation".
    + Make .desktop file match prompt process so icon and title are
      shown.
    + Fix packaging issues installing the pkcs11 module.
    + Return correct error code in gpg-agent for unimplemented stuff.
    + Fixes for parsing/viewing various (sometimes slightly invalid)
      PKCS#12 files.
    + Allow daemon to access secrets of internal PKCS#11 modules, so
      that we can do things like hash NTLM and Kerberos secrets in
      the future.
    + Build and documentation fixes.
    + Updated translations.
* Fri Sep 09 2011 vuntz@opensuse.org
  - Update pam module and pam module configuration for the new gdm
    (>= 3.1.90), which uses both gdm and gdm-password pam services:
    + Update gnome-keyring-check-session.patch: check if the service
      is called gdm-password too.
    + Change pam-config call in %post to add gdm-password in
    - -gnome_keyring-only_if option.
  - gnome-keyring-check-session.patch: also remove support for the
    smeegol session, since Smeegol is dead.
* Mon Sep 05 2011 vuntz@opensuse.org
  - Update to version 3.1.91:
    + gcr-viewer will now display errors when failing to load a file.
    + gcr-viewer can now prompt for passwords to unlock files.
    + Add support for getting the current data block being parsed in
      GcrParser.
    + Add debug output to various points in the GCR and GCK
      libraries.
    + When replacing another gnome-keyring-daemon, wait a moment
      before initializing.
    + Fix GCR library initialization bugs loading PKCS#11 modules.
    + Fine tuning of GcrParser when parsing PKCS#12 files.
    + Build and packaging fixes.
    + Updated translations.
* Thu Sep 01 2011 vuntz@opensuse.org
  - Update to version 3.1.90:
    + Install better xdg-mime files for identifying crypto related
      file types
    + New gcr-viewer for viewing certificates and keys, hooked up to
      file types
    + Display tweaks for the certificate and key widgets
    + Don't initialize PKCS#11 modules automatically in gcr library
      unless needed.
    + Cleanup the libgck API since we're bumping the major version.
    + ABI fixes for the GCR library for changes in the 3.1.x release
      cycle
    + New automatic checks for symbols that have changed in the ABI
    + Add async PKCS#11 initialization functions to libgck
    + Display Certificate otherName subject-alt-name for xmppAddr and
      DNS SRV
    + Documentation, testing, translation and build fixes.
  - Pass --disable-update-mime to configure and add
    %mime_database_post/%mime_database_postun to %post/%postun
    scriptlets for the new gcr-crypto-types.xml MIME file.
  - Rename libgcr-3-0 to libgcr-3-1 after library version change.
  - Remove gtk-doc BuildRequires and call to libtoolize and
    autoreconf: there is no patch needing that.
* Tue Jul 26 2011 gber@opensuse.org
  - Add LightDM support for the pam module:
    + Update gnome-keyring-check-session.patch: add support for
      LightDM.
    + Change pam-config call in %post to add lightdm in
    - -gnome_keyring-only_if option.
* Mon Jul 25 2011 vuntz@opensuse.org
  - Update to version 3.1.4:
    + New GcrListSelector class for selecting multiple keys.
    + Add icons for key and key pair.
    + Gcr now has support for loading of GnuPG keys from gpg,
      including photos.
    + New gcr dependency on p11-kit for loading PKCS#11 modules.
    + Remove support for GTK+ 2.x.
    + Implement calculation of fingerprints in gcr for keys.
    + Fix problems in daemon if IPC lock or FS capabilities are not
      available.
    + Bug fixes and build fixes.
    + Code cleanup and refactoring.
  - Drop gnome-keyring-keep-only-ipc_lock.patch and
    gnome-keyring-accept-no-ipc_lock.patch: fixed upstream.
  - Add pkgconfig(p11-kit-1) BuildRequires, for new dependency.
  - Add libselinux-devel BuildRequires, to build SELinux support.
  - Remove --with-gtk=3.0 from configure, as GTK+ 2.x support was
    removed.
  - Rename libgck0 to libgck-1-0, following soname change.
  - Rename libgcr-3-1 back to libgcr-3-0, following soversion revert.
  - Call %icon_theme_cache_post/%icon_theme_cache_postun in
    libgcr-3-0 scriptlets, since the package now comes with icons.
* Thu May 26 2011 vuntz@opensuse.org
  - Update baselibs.conf with package names after 3.0 update.
* Tue May 17 2011 dimstar@opensuse.org
  - Update to version 3.1.1:
    + Add 'Export Certificate' option to right click of certificate
      widget.
    + Use file system linux capabilities for memory locking.
    + Set correct daemon SELinux context when started from PAM module
    + Fix assertions in parser.
    + Add GcrCollection interface to represent collections of objects
    + Add GcrGnupgCollection to libgcr.
    + Implement functionality in renderers to populate GtkTreeModel
    + Add a GcrSelector widget.
    + Cleanup unregistering from session.
    + Build fixes.
    + Updated translations.
  - Drop gnome-keyring-fix-parallel-build.patch and
    gnome-keyring-file-capabilities.patch: fixed upstream.
  - Rename libgcr-3-0 subpackage to libgcr-3-1 following soversion
    change.
* Thu May 05 2011 vuntz@opensuse.org
  - Handle specific permissions for %{_bindir}/gnome-keyring-daemon:
    + Add permissions PreReq.
    + Add %set_permissions %{_bindir}/gnome-keyring-daemon to %post.
    + Add a %verifyscript scriptlet calling %verify_permissions.
  - Do not package %{_bindir}/gnome-keyring-daemon with filesystem
    capabilities: the security team will add what is needed via
    %set_permissions after a review of the code.
  - Drop rpmlintrc file as we don't need it anymore, since we have no
    setuid binary nor capabilities.
  - Add gnome-keyring-keep-only-ipc_lock.patch: when filesystem
    capabilities are used, make sure that we do have ipc_lock and
    keep only this one.
  - Add gnome-keyring-accept-no-ipc_lock.patch: accept to run without
    ipc_lock capability, just print a warning instead of aborting.
  - This is part of bnc#682244.
* Mon May 02 2011 fcrozat@novell.com
  - Add gnome-keyring-file-capabilities.patch: Use libcap-ng for file
    capabilities (from git, see rh#668831).
  - Use libcap-ng-devel BuildRequires instead of libcap-devel
  - Add gtk-doc BuildRequires, only needed because of the new patch.
  - gnome-keyring-daemon is now using cap_ipc_lock=ep instead of
    setuid.
* Wed Apr 27 2011 fcrozat@novell.com
  - Update to version 3.0.1:
    + Fix clicking buttons in 'unsafe storage' dialog on GTK+3.
    + Build with GTK+3 by default.
    + More tests and test fine tuning: --enable-tests=yes/no/full.
    + Expand path in gnome-keyring-prompt.desktop properly.
    + Implement debug tracing in parts of gcr library.
    + Complete documentation in gcr and gck libraries.
    + Fix assertions in gcr library during parsing of a stream.
    + Build fixes.
  - Add gnome-keyring-fix-parallel-build.patch to fix parallel build
    (from git).
  - Remove libmock-test-module.so in %install, as this is only useful
    for tests.
* Mon Apr 25 2011 vuntz@opensuse.org
  - Add the rpmlintrc that was added as workaround until bnc#682244
    is fixed (security review) as a source.
* Mon Apr 04 2011 fcrozat@novell.com
  - Update to version 3.0.0:
    + Updated translations.
* Tue Mar 22 2011 fcrozat@novell.com
  - Update to version 2.91.93:
    + Use full interface.Property form for CreateCollection and
      CreateItem in the DBus API.
    + Add deprecated functions for libgcr symbols lost since 2.32.x
    + Don't crash when the GPG agent is asked for a passhprase
      without a key id.
  - Changes from version 2.91.92:
    + Don't leak login name from PAM when logging error.
    + Also start daemon in XFCE
    + Fix inability to save password for other keyrings.
    + Build and test fixes.
    + Support removal of aliases via the secret service API
    + Fix race condition when multiple applications create the
      default keyring at the same time.
    + Add a desktop file for gnome-keyring-prompt, so the icon shows
      up properly in gnome-shell.
    + Implement HKDF for transport encryption security.
  - Changes from version 2.91.91:
    + Fix the certificate details expander when used with GTK+3
    + Calculate the minimum/natural size of the certificate widget
      better.
    + Fix gnome-keyring-prompt for GTK+3 release.
    + Fix problems with the URIs used for trust lookup and storage.
    + Pass around a content-type for secrets in the DBus Secret
      Service API.
    + If DBus couldn't be initialized when starting up the daemon,
      try again at a later point.
    + Build and testing fixes.
    + Remove support for the pkcs11-options file, and wait for a
      proper configuration file setup being worked on in p11-kit.
    + Add support for --version argument to gnome-keyring-daemon and
      gnome-keyring.
    + Create necessary directory when storing trust assertion
      objects.
  - Changes from version 2.91.4:
    + gck library loads PKCS#11 modules from /usr/lib/pkcs11
    + PKCS#11 config file in /etc/xdg/pkcs11.conf[.defaults]
    + Many ASN.1 encoding fixes.
    + Refactor how tests work.
    + Install standalone PKCS#11 modules to a consistent location.
    + Memory leaks and other bug fixes.
    + Allow enumeration of objects in specific PKCS#11 slots as well
      as modules.
    + Add GcrCertificateChain for building certificate chains.
    + Implementation of the initial PKCS#11 Trust Assertions spec.
    + Add GcrPkcs11Certificate for looking up certificates in PKCS#11
      modules by issuer.
    + Expose gcr functionality for setting which PKCS#11 modules to
      use.
    + Find the root certificates by default.
    + Move to a single header model for libgcr.
    + Don't load *.la files when looking for PKCS#11 modules.
    + Fixes for GTK+3.0
    + New xdg-store PKCS#11 module with support for storing trust
      assertions.
    + Rename old user-store to gnome2-store since it stores its data
      in old formats in the old .gnome2 location.
  - Replace gnome-keyring-autostart-in-xfce.patch with
    desktop-file-install calls. Add desktop-file-utils BuildRequires
    for this.
  - Add support for source service checkout, with %BUILD_FROM_VCS:
    + Add gnome-common and gtk-doc BuildRequires.
    + Add call to ./autogen.sh.
    + Enforce gtk-doc html generation by passing --enable-gtk-doc to
      configure.
* Wed Dec 29 2010 gber@opensuse.org
  - Update gnome-keyring-check-session.patch to add support for Xfce
    sessions.
  - Add gnome-keyring-autostart-in-xfce.patch to autostart
    gnome-keyring in XFCE sessions.
* Fri Dec 17 2010 vuntz@opensuse.org
  - Update to version 2.91.3:
    + Shutdown module timer when holding proper mutex.
    + Linux capabilities to overcome limits on locked memory.
    + Update HACKING with coding style
    + Build fixes.
  - Changes from version 2.91.2:
    + Add timeout if PAM startup doesn't complete shortly.
    + Fix login keyring password when it doesn't match unix login.
    + Replace gp11-0 with gck in pkgconfig file
    + Fix broken dispose of GcrCertificateWidget
    + Remove gp11 library.
  - Changes from version 2.91.1:
    + Fix build problem in gpg-agent.
    + Properly distribute pkgconfig file for gck library.
    + Better certificate widget in gcr library.
    + Add extra debug guard around printing of prompt io.
    + Rework how the gcr parser and importer work together.
    + More GTK+ 3.0 fixes.
  - Changes from version 2.91.0:
    + String and punctuation fixes.
    + Add libgck library to soon replace libgp11
    + Migrate everything in gnome-keyring to libgp11
    + Fix invalid memory access in PKCS#11 rpc-layer
    + Fix race condition in tests
  - Move to pkgconfig()-style BuildRequires:
    + Old ones: dbus-1-devel, gtk2-devel, libtasn1-devel.
    + New ones: dbus-1, glib-2.0, gtk+-3.0, libtasn1.
  - Add libcap-devel BuildRequires.
  - Rename libgcr0 to libgcr-3_0 after library name change.
  - Remove explicit glib2-devel, gtk2-devel, libgp11-devel,
    libtasn1-devel Requires in libgcr-devel package: they will be
    automatically added the pkgconfig() way.
  - Add libgck0, libgck-devel and libgck-modules subpackages, and
    remove libgp11-0, libgp11-devel, libgp11-modules. Packaging-wise,
    it's mostly like a renaming. Note that we have libgck-modules
    with a Obsoletes tag for libgp11-modules since they share the
    same files.
  - Pass --with-gtk=3.0 instead of --with-gtk=2.0 to configure.
  - Stop passing --libexecdir=%{_libexecdir}/gnome-keyring-1 to
    configure: this is really not needed.
* Wed Dec 15 2010 vuntz@opensuse.org
  - Own /usr/share/GConf and /usr/share/GConf/gsettings to fix build.
* Tue Nov 23 2010 aj@suse.de
  - Change lang package Requires to Recommends since it is not
    mandatory at runtime.
* Thu Oct 28 2010 vuntz@opensuse.org
  - Update to version 2.32.1:
    + Don't offer to save password for symmetric encryption in
      gpg-agent.
    + Don't try to cache password when symmetric encryption in
      gpg-agent.
    + Check that daemon is initialized before changing password from
      pam.
    + Fix login keyring password doesn't match login.
    + Link correctly to gio.
    + Add extra debug guard around printing of prompt io.
    + Fix invalid memory access in rpc-layer.
* Wed Oct 20 2010 vuntz@opensuse.org
  - Update gnome-keyring-check-session.patch to also use the
    gnome-keyring PAM module for the gnome3 and smeegol sessions: we
    want the keyring to be unlocked on login there.
* Mon Sep 27 2010 vuntz@opensuse.org
  - Update to version 2.32.0:
    + Make builds silent by default.
* Sun Sep 12 2010 vuntz@opensuse.org
  - Update to version 2.31.92:
    + Require glib 2.25 or later.
    + Require automake 1.7 or later.
    + Fix assertion in secure memory code.
    + Don't go into endless loop when GPG Agent client disconnects.
    + Fix double free in gp11 library.
    + Fix crash during keyring unlock operation.
    + Expand prompt details when a non-default unlock option is
      chosen.
    + Migrate to gsettings.
    + Use gsettings for GPG agent unlock options.
    + Fix library header installation directory for libgcr.
    + Fix some errors parsing certificates.
    + Rework how unlock options are loaded and handled.
    + Fix saving of auto-unlock passwords.
    + Support building with GTK+ 3.0
    + No warning message when SSH unlock prompt is cancelled.
    + Build fix finding PAM headers.
    + Build fix of PAM module for Hurd.
  - Drop gnome-keyring-fix-pam-module-build.patch: fixed upstream.
  - Pass --with-gtk=2.0 to configure to make sure we build against
    GTK+ 2.
  - Handle GSettings schemas, by using the %glib2_gsettings_schema_*
    macros.
* Mon Aug 30 2010 vuntz@opensuse.org
  - Update to version 2.31.91:
    + Fix problem with keyring names that contain foreign charaters.
    + Build fixes and warning fixes.
    + Better GPG Agent prompt strings.
    + More internal documentation.
    + Remove gconf as part of migration to gsettings.
    + Add --replace option to daemon.
    + Fix race condition in tests.
    + Use new DER decoding and encoding routines.
    + Only try to authenticate once if PKCS#11 slot has protected
      auth path.
    + Better handling of when PKCS#11 token is write protected.
  - Add gnome-keyring-fix-pam-module-build.patch to fix build of PAM
    module.
  - Pass --enable-pam to configure to make the build fail early if we
    lose the pam module.
  - Pass --with-root-certs=%{_sysconfdir}/ssl/certs to configure.
  - Remove all of the gconf packaging:
    + Remove gconf2-devel BuildRequires.
    + Remove use of %gconf macros and corresponding
      %pre/%preun/%posttrans.
    + Do not pass --disable-schemas-install to configure.
* Thu Jul 22 2010 vuntz@opensuse.org
  - Remove gnome-common BuildRequires and call to gnome-autogen.sh.
  - Call %suse_update_desktop_file on gnome-keyring-gpg.desktop.
* Thu Jul 08 2010 dimstar@opensuse.org
  - Update to version 2.31.4:
    + New GPG Agent built into gnome-keyring-daemon
    + Start building (but not using) new DER parser and writer.
    + Fix building of desktop and service files.
    + Fix problems displaying prompts with certain characters in
      strings.
    + Fix deadlock on secure memory usage.
    + Refactor the way prompting works for PKCS#11 components.
    + Refactor the way testing works and files are named.
    + Implement coverage testing.
    + Cleanup whitespace issues and rename certain modules.
    + Tests can now involve prompts and responses.
    + Fix possible threading race condition in gp11.
    + Fix broken startup when used with gdm and password-less login.
    + Fix checking of uninitialized value in prompting code.
  - Drop gnome-keyring-fixes-from-git.patch: fixed upstream.
* Thu Jun 03 2010 vuntz@opensuse.org
  - Add gnome-keyring-fixes-from-git.patch to fix various issues
    related to gnome-keyring not working fine (with autologin, for
    example).
  - Add gnome-common BuildRequires and call to gnome-autogen.sh
    needed for the patch.
* Thu Apr 29 2010 dimstar@opensuse.org
  - Update to version 2.30.1:
    + Build fixes for errors and distribution problems.
    + Fixes for building on recent GTK versions.
    + Remove accidental storage of user's login password in login
      keyring.
    + Fix assertion when exiting.
    + Updated translations.
* Tue Mar 30 2010 vuntz@opensuse.org
  - Update to version 2.30.0:
    + More robust error display and handling.
    + Don't assert on va_list.
    + Don't save session keyring to disk.
    + Allow unlocking even when always unlock is not available.
    + Hide the automatically unlock check when login not usable.
    + Fix various issues storing and using auto unlock passwords.
    + Updated translations.
* Wed Mar 10 2010 dimstar@opensuse.org
  - Update to version 2.29.92:
    + Fix various problems with not storing secret value properly.
    + Return no results when a search includes a bad collection
      identifier.
    + Don't raise error if ssh client disconnects early.
    + Allow running in a test environment.
    + Fix error when setting default keyring to NULL.
    + Autostart gnome-keyring-daemon in LXDE as well.
    + Rework the startup again, to use a singleton crontrolled via
      dbus, to help when no process was started by pam.
    + Display password and confirm prompts when creating keyring.
    + Allow specifying CKA_ID when creating collection.
    + Give translatable label to created login keyring.
    + When no default keyring set, use login keyring.
    + Fix problem initializing socket path in rpc module.
    + Fix endless loop in reading data.
    + Potential fix or sporadic crash.
    + Solaris build fixes.
    + Updated translations.
    Drop upstream included gnome-keyring-LXDE-autostart.patch.
* Thu Feb 11 2010 vuntz@opensuse.org
  - Update to version 2.29.90:
    + Quit daemon when the dbus session is disconnected.
    + Don't print out warnings on SSH v1 keys.
    + Remove erroneous egg-dbus dependency.
    + Allow saving password for encryption keys.
    + Fix problems storing secrets in keyrings.
    + Expose idle and timeout lock options for keyrings in the prompt
      dialog. Fix remaining issues to get this to work.
    + Display a different message when unlocking the login keyring.
    + Fix problem with phantom 'xxx_1' keyrings appearing.
    + Load and use the default keyring properly.
    + Support accessing template style pkcs11 attributes.
    + Fix endless loop when looking for encryption key password in
      login keyring.
    + GNU Hurd build fixes.
    + Solaris build fixes.
    + Translation fixes.
  - Drop eggdbus-devel BuildRequires.
  - Tweak gnome-keyring-check-session.patch to not start the keyring
    if we're in a supported display manager, but DESKTOP_SESSION is
    not set.
* Sun Feb 07 2010 andrea@opensuse.org
  - Add gnome-keyring-LXDE-autostart.patch to allow to autostart
    keyring on LXDE session.
* Wed Jan 27 2010 andrea@opensuse.org
  - Update gnome-keyring-check-session.patch to also support LXDE
    (and lxdm).
* Mon Jan 11 2010 captain.magnus@opensuse.org
  - Update to version 2.29.5:
    + Implement lookup collection passwords in login keyring.
    + Various prompting fixes.
    + Store PKCS#11 objects after any attribute change.
    + Add 'Type' property to Secret Service API DBus item interface
    + Various warning, and uninitialized memory fixes.
* Tue Dec 22 2009 vuntz@opensuse.org
  - Update to version 2.29.4:
    + Refactor how the daemon starts up.
    + Allow init with already present environment variables, using
    - -start.
    + Install autostart files for each component of the daemon.
    + New DBus Secret Service API for accessing passwords and
      secrets.
    + Old protocol for accessing secrets is no longer present.
    + libgnome-keyring is now its own module, and no longer bundled
      with gnome-keyring.
    + Use normal GtkEntry when prompting for passwords.
    + Requires GTK+ 2.18
    + Implement new more flexible control protocol for pam and
      startup.
    + Complete more of the gp11 PKCS#11 wrapper library.
    + Implement AES key wrapping and unwrapping in PKCS#11
      components.
    + Implement DH key generation and derivation in PKCS#11
      components.
    + Integrate testing of PKCS#11 components via p11-tests.
    + Implement PKCS#11 component for storing 'keyring' style
      secrets.
    + Don't complain if we can't set session environment variables.
    + When running a debug build, warnings are fatal.
    + Refactor testing.
    + Encrypted channel for password with prompting dialog.
  - Pass --disable-schemas-install to configure.
  - Add eggdbus-devel BuildRequires.
  - Remove libgnome-keyring0 and gnome-keyring-devel subpackages
    (moved to libgnome-keyring source package).
  - Split the remaining of gnome-keyring-devel in libgcr-devel and
    libgp11-devel.
  - Update baselibs.conf to reflect the packages shipping libraries
    (libgcr0 and libgp11-0).
* Thu Dec 17 2009 jengelh@medozas.de
  - Add baselibs.conf as a source
* Thu Dec 17 2009 vuntz@opensuse.org
  - Fix build on openSUSE <= 11.2.
* Tue Dec 15 2009 vuntz@opensuse.org
  - Update to version 2.28.2:
    + Add license to reference documentation.
    + Sent output of g_printerr to syslog.
    + No error when can't unlock login keyring.
    + Fix assertion when comparing attributes.
    + Fix freeing of unallocated memory in test.
    + Don't barf on certificates with unsupported algorithm.
    + Fix some memory leaks.
* Fri Dec 04 2009 vuntz@opensuse.org
  - Split the libraries in their own packages, to avoid useless
    dependencies for packages depending on libgnome-keyring0 but that
    don't want the whole gnome-keyring (which pulls gtk2). This means
    we now have libgnome-keyring0, libgcr0, libgp11-0 and
    libgp11-modules subpackages. (Thanks to Debian: summaries and
    descriptions are inspired by the Debian ones.)
  - Remove .la files.
  - Do not self-obsolete for gnome-keyring-doc and pam_keyring.
  - Move the pam-confire PreReq to the pam subpackage.
* Fri Nov 13 2009 vuntz@opensuse.org
  - Update to version 2.28.1:
    + Fix support for SSH RSA1 keys.
    + Fix a delay when the daemon quits.
    + Use default D-Bus timeout when finding daemon.
    + Make custom pkcs11 constants unsigned longs.
    + Use unsigned long for module handle counter.
    + Fix assertion when releasing secure memory block.
  - Drop gnome-keyring-no-logout-delay.patch: fixed upstream.
  - Drop gnome-keyring-fix-ssh1-agent.patch: fixed upstream.
  - Update gnome-keyring-check-session.patch to apply without fuzz.
* Thu Oct 08 2009 vuntz@opensuse.org
  - Add gnome-keyring-fix-ssh1-agent.patch to make the ssh agent
    support rsa1 keys again. Fix bnc#540515.
* Tue Oct 06 2009 vuntz@opensuse.org
  - Update gnome-keyring-pam-auth-prompt-password.patch to not prompt
    for password if use_authtok option is used.
* Fri Oct 02 2009 vuntz@opensuse.org
  - Add gnome-keyring-no-logout-delay.patch to fix delay during
    logout.
* Tue Sep 22 2009 dimstar@opensuse.org
  - Update to version 2.28.0:
    + Fix build problems with -as-needed.
  - Remove export SUSE_ASNEEDED.
* Mon Sep 14 2009 vuntz@opensuse.org
  - Update to version 2.27.92:
    + Some uses of glib memory routines to explicitly allocate
      memory.
    + Fix erroneous assertion hit by gtk-doc and tests.
    + Revert change which bumped libtasn1 required to 1.0.
    + Fix logic for only_if option in PAM module.
    + Handle unix signals on one thread.
    + Better daemon startup and forking logic.
    + Optional use of automake silent rules when available.
    + No warning when a disk doesn't have a UDI identifier.
  - Drop gnome-keyring-pam-fix-only_if.patch: fixed upstream.
  - Add SUSE_ASNEEDED=0 to fix build.
* Sun Aug 30 2009 vuntz@novell.com
  - Add gnome-keyring-pam-fix-only_if.patch to fix logic in pam
    module when using only_if.
* Mon Aug 10 2009 vuntz@novell.com
  - Update to version 2.27.90:
    + Build fixes on Solaris and FreeBSD.
    + Take length of ASN.1 elements into account, when parsing.
* Wed Jul 29 2009 vuntz@novell.com
  - Drop gnome-keyring-auto-start-if-compatibility.patch now that
    pam-config has been updated to support only_if in the pam config.
  - Change pam-config call in post to use "--gnome_keyring-auto_start
    - -gnome_keyring-only_if=gdm" instead of
    "--gnome_keyring-auto_start_if=gdm""
  - PreReq pam-config at least 0.72 for those changes.
* Tue Jul 28 2009 lmedinas@gmail.com
  - Update to version 2.27.5:
    + Add support for lifetime constrained SSH identities.
    + Use GtkBuilder files where glade files were used.
    + Write private key files with tighter file permissions.
    + Use gio instead of libhal for monitoring volumes.
    + Updated translations.
  - Remove hal-devel from BuildRequires not needed anymore.
* Sun Jul 19 2009 vuntz@novell.com
  - Update to version 2.27.4:
    + Insurance in parsing keyring format for future changes.
    + Add 'use_authtok' option to pam module.
    + Test utility fix.
    + Add 'only_if=' option to pam module.
    + Make 'Password:' prompt translatable in pam module.
    + Use libgcrypt to generate iv/salt where needed.
    + Remove old cu-test style unit tests.
    + Code refactoring and cleanup, removed 'common' component.
    + Auto generated ChangeLog.
    + Cleanup unit tests, and make them run with 'make check'
  - Changes from version 2.26.3:
    + Build fixes.
    + Fix problem with RSA key sizes that are not a multiple of 8.
      This affected use of SSH keys in particular.
    + Fix crash related to secure memory.
  - Drop gnome-keyring-pam-auto-start-if.patch: fixed upstream.
  - Drop gnome-keyring-pam-translate.patch: fixed upstream.
  - Remove AutoReqProv: it's default now.
  - Add gnome-keyring-auto-start-if-compatibility.patch since
    pam-config does not know yet about only_if. It will be removed
    once pam-config will be updated.
* Sun Apr 12 2009 mboman@suse.de
  - Update to version 2.26.1:
    + Fix many problems with the new secure memory allocator
    + DBus now automatically starts the gnome-keyring service
      properly
    + When auto activating the gnome-keyring DBus service, check for an
      already running daemon
    + Don't print critical warnings when registering with DBus fails
    + Bump glib dependency
    + Add DBus method for getting the gnome-keyring environment
      variables
    + Fix crash when prompting to unlock the keyring
    + Initialize daemon with LOGNAME and USERNAME environment
      variables
    + Build fixes
  - Merge -doc into -devel as it only contains gtk-doc
  - Move gtk-doc from main to -devel
* Sat Mar 21 2009 mboman@suse.de
  - Modify baselibs.conf so that if pam-32bit is installed on x86_64,
    gnome-keyring-pam-32bit and gnome-keyring-32bit is installed as
    well.
* Thu Mar 19 2009 mboman@suse.de
  - Fix an issue where Requires on libtasn1-devel and gtk2-devel was
    added to -pam instead of -devel
* Sat Mar 14 2009 mboman@suse.de
  - Update to version 2.26.0:
    + Implement support for running gnome-keyring-daemon under
      valgrind
    + Checks for asn1Parser tool when configuring
    + Only automatically expose PKCS#11 public key objects for
      private keys
    + Have the SSH agent only log into the token when we have a
      private key that we want to access
    + Disable input method in password
  - Add libtasn1-devel and gtk2-devel to Requires for devel package
* Fri Mar 06 2009 vuntz@novell.com
  - Update to version 2.25.92:
    + Fix problems when multiple processes tried to initialize the
      gnome-keyring-daemon at the same time, often resulting in a
      user session that hung on login.
    + Add compatibility support for loading SSH unlock passwords from
      previous versions of gnome-keyring.
    + Fix compiler warnings on 32-bit systems.
    + Fix uninitialized variable usage. These resulted in crashes.
    + Initialize PKCS#11 tokens before importing certificates or keys
      to them. Remove previous auto-initialize idea.
    + Add basic support for PKCS#11 SO logins.
    + Fix focus issues in the import certificate/key dialog.
    + When looking for PKCS#11 objects, skip tokens that have not
      been initialized.
    + Exit properly when an error occurs on importing a certificate
      or key.
    + Hash objects when storing them in PKCS#11 user-store and
      validate the hashes when loading them.
    + Build fix on Solaris
    + If login keyring doesn't exist when changing a PAM password,
      don't create it automatically.
    + Close stdin/stdout when not running the daemon in foreground.
      This fixes a regression in scripts starting
      gnome-keyring-daemon.
  - Remove -fno-strict-aliasing from CFLAGS.
  - Use makeinstall (install-pam is no longer useful)
  - Make sure fdupes is called last (since we might changes some
    files before).

Files

/lib64/security/pam_gnome_keyring.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jul 10 17:22:44 2014