Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

xorg-x11-devel-7.6-37.1.1 RPM for noarch

From OpenSuSE 12.2 for noarch

Name: xorg-x11-devel Distribution: openSUSE 12.2
Version: 7.6 Vendor: openSUSE
Release: 37.1.1 Build date: Fri Jun 22 22:47:38 2012
Group: Development/Libraries/X11 Build host: build06
Size: 182 Source RPM: xorg-x11-libs-7.6-37.1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://xorg.freedesktop.org/
Summary: Compatibility metapackage for X.Org development libraries
This package is a compatibility metapackage. It used to contain the
X.Org development libraries.

Provides

Requires

License

GPL-2.0+ ; MIT

Changelog

* Thu Apr 19 2012 vuntz@opensuse.org
  - Remove all tarballs and patches, since they're not used anymore
    with the split packages.
  - Stop making xorg-x11-devel have a Requires on xorg-x11-libs: both
    are metapackages, so it's useless.
  - Add a README.meta file to explain the goal of the compatibility
    metapackages, and update their summaries and descriptions as
    well.
* Fri Feb 24 2012 sndirsch@suse.com
  - devel package: fixed devel requires for libpciaccess, added the
    remaining requires: liblbxutil-devel, xbitmaps-devel,
    xorg-x11-fonts-devel
* Fri Feb 24 2012 coolo@suse.com
  - there is no value in manually adding the pkgconfig provides of
    package names we already know (bnc#748486)
    The pkgconfig provides of random X libraries can change at any
    time and it would be necessary to touch this meta package without
    any additional gain.
* Mon Feb 20 2012 sndirsch@suse.com
  - fixed xcb-util Requires for openSUSE <= 12.1
* Sat Feb 18 2012 coolo@suse.com
  - readd all the devel libs lost during the split as pkgconfig requires
* Tue Feb 14 2012 sndirsch@suse.com
  - turned -devel package into a meta package, which now requires
    all the previously required packages by adding the appropriate
    pkgconfig(...) Requires
* Fri Feb 10 2012 sndirsch@suse.com
  - back to real libs package, but no longer preferred in project
* Thu Feb 09 2012 sndirsch@suse.com
  - please rebuild !!!
* Thu Feb 09 2012 sndirsch@suse.com
  - no longer package anything, since libs are now packaged
    seperately ==> dummy package
* Tue Feb 07 2012 sndirsch@suse.com
  - instead of using LD_PRELOAD link the fake libs against the
    freshly introduced libxcb-util; hope this works out ...
    Still this does not help on openSuSE 11.4 (bnc#742297)
* Fri Feb 03 2012 sndirsch@suse.com
  - still we need a LD_PRELOAD for the freshly introduced libxcb-util;
    added this to /etc/profile.d/xorg-x11-libs.{csh,sh}; seems to
    help on openSUSE 12.1, but apparently not on openSUSE 11.4
    (bnc #742297)
* Mon Jan 23 2012 sndirsch@suse.com
  - fixed typo in generating fake xcb libs; fake xcb libs don't need
    to be provided explicitely via spec file, since this Provides is
    already picked up from the generated xcb libs themselves
* Thu Jan 19 2012 sndirsch@suse.com
  - create the full set of fake libxcb-* libs being replaced now
    by libxcb-util (reported by email)
* Mon Jan 16 2012 sndirsch@suse.de
  - provide fake libxcb-atom.so.1 (bnc #741465) for older openSUSE
    releases since it apparently vanished with xcb-util 0.3.8 :-(
* Sat Jan 07 2012 chris@computersalat.de
  - xcb-util 0.3.8
    * Split up atom, aux event into their own repository.
    * Create a single shared library and header file.
    * Remove namespaceless pre-defined atoms.
    * Remove synchronous xcb_atom_get().
    * Remove useless xcb_atom_get_fast*() and xcb_atom_get_name().
    * Delete redundant core-protocol error codes.
    * Delete callback-based APIs for events, properties, and replies.
    * Link with -no-undefined.
    * Add AM_MAINTAINER_MODE for vendors.
  - remove AUTHORS from description
  - switch {?jobs:-j%jobs} to {?_smp_mflags}
* Sun Nov 20 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency
* Fri Sep 02 2011 sndirsch@suse.com
  - U_libXfont_LZW-decompress-fix-for-CVE-2011-2895.patch
    * LZW decompress: fix for CVE-2011-2895 (bnc #709851)
* Tue Aug 30 2011 sndirsch@suse.com
  - split off libpciaccess to avoid build cycles; latest intel driver
    now buildrequires libpciaccess
* Mon Jun 20 2011 mhopf@novell.com
  - Don't delete .la files for SLE11-SP1
* Tue May 31 2011 eich@suse.de
  - removed libXTrap-pcfix.diff:
    * This patch is rather irrelevant to us. We are not even
      going to submit it to upstream.
* Tue Dec 21 2010 sndirsch@novell.com
  - bumped version number to 7.6
* Thu Dec 09 2010 sndirsch@novell.com
  - xbitmaps 1.1.1
    * This minor maintenance release mostly provides the usual
      collection of janitorial cleanups and build configuration
      improvements.
      It also changes the installation path for the pkg-config
      xbitmaps.pc from $(libdir) to $(datadir), as no libraries
      or compiled code are found via this pkg-config file, only
      platform-independent image files (which double as C source
      code headers that programs may #include at compile time).
* Wed Dec 01 2010 sndirsch@novell.com
  - revert 'export only public API symbols'
    it breaks at least build of Xnest (xorg-x11-server package)
* Tue Nov 30 2010 cristian.rodriguez@opensuse.org
  - export only public API symbols
  - disable silent rules, defeat the purpose of post build checks
* Sun Nov 21 2010 sndirsch@novell.com
  - libXxf86misc 1.0.3
    * This minor maintenance release provides the usual recent set
      of misc. cleanups and build configuration improvements.
* Mon Nov 01 2010 sndirsch@novell.com
  - libXevie-1.0.3
    * This release provides the cleanups and build configuration
      improvements that have been made since the last libXevie
      release in 2006.
* Sat Oct 30 2010 sndirsch@novell.com
  - libXft 2.2.0
    * This release removes the deprecated xft-config script now that
      pkg-config is well-established as it's replacement.   It also
      updates the xft pkg-config file to reduce unnecessary linking
      in users of libXft, but may cause issues if used with versions
      of pkg-config older than the pkg-config 0.22 release from 2007.
      It also includes the usual recent set of build configuration
      improvements and janitorial cleanups.
  - libXtst 1.2.0
    * This release adds the specification documents for the API's for
      both extensions, converted from the original troff format to
      DocBook/XML. It also includes the usual recent rounds of build
      configuration improvements and janitorial cleanups.
  - libXxf86dga 1.1.2
    * This minor maintenance release provides the usual recent
      collection of build configuration improvements and janitorial
      cleanups.
  - libXxf86vm 1.1.1
    * This minor maintenance release provides the usual recent
      collection of build configuration improvements and janitorial
      cleanups.
  - libXScrnSaver 1.2.1
    * This minor maintenance release provides the usual recent
      collection of build configuration improvements and janitorial
      cleanups, with no additional snarkiness beyond that provided
      in this announcement.
* Fri Oct 29 2010 sndirsch@novell.com
  - libXfont 1.4.3
    * This bug fix release mostly fixes build issues on various
      platforms involving the hackery required for libXfont to
      depend on symbols defined in the X server itself. Trying to
      explain or understand this hackery may be damaging to your
      sanity - it has already robbed several generations of X
      developers of ours.
  - libdmx 1.1.1
    * This minor maintenance release provides the latest set of
      the usual build configuration improvements and janitorial
      cleanups.
  - libXrandr 1.3.1
    * This release includes several fixes to the error handling
      paths in the library, as well as the usual set of recent
      build configuration improvements and janitorial cleanups.
  - libXres 1.0.5
    * This minor maintenance release provides the latest set of
      the usual build configuration improvements and janitorial
      cleanups.
* Thu Oct 28 2010 sndirsch@novell.com
  - readded lbx headers, since these have been removed from libXext
    1.2.0
* Thu Oct 28 2010 sndirsch@novell.com
  - libXcomposite 0.4.3
    * This minor maintenance release provides build improvements and
      reduces both buildtime & runtime dependencies of the library.
  - libXcursor 1.1.11
    * This minor maintenance release provides the usual recent set
      of build configuration improvements and janitorial cleanups.
  - libXinerama 1.1.1
    * This minor maintenance release of the Xlib-based library for
      the Xinerama extension protocol provides the usual set of
      recent build configuration improvements and janitorial
      cleanups.
* Wed Oct 27 2010 sndirsch@novell.com
  - fixed build on openSUSE 11.2/SLE11-SP1
* Wed Oct 27 2010 sndirsch@novell.com
  - libFS 1.0.3
    * This minor maintenance release simply collects the latest set
      of build configuration improvements and janitorial cleanups.
* Mon Oct 25 2010 sndirsch@novell.com
  - libXaw 1.0.8
    * This minor maintenance release fixes some bugs, improves build
      configuration, includes various janitorial cleanups, and
      delivers for the first time the DocBook/XML conversion of the
      API docs that were previously in troff format.
* Sun Sep 05 2010 sndirsch@novell.com
  - libXcomposite 0.4.2
  - libXdamage 1.1.3
  - libXfontcache 1.0.5
  - libXvMC 1.0.6
  - libXxf86misc 1.0.2
  - libpciaccess 0.12.0
* Mon Aug 23 2010 sndirsch@suse.de
  - libXfont 1.4.2
    * This minor release contains a new and single hook function to
      be used by the server to register all fpe functions
      (register_fpe_functions()). Also, lot of clean-ups for
      configuration happened.
  - required by xorg-server 1.9
* Thu May 06 2010 sndirsch@suse.de
  - build libpciaccess with corrrect path to pci.ids (bnc #603071)
* Sun Apr 11 2010 sndirsch@suse.de
  - libxtrap-pcfix.patch --> libXTrap-pcfix.diff
  - specfile cleanup
* Mon Apr 05 2010 sndirsch@suse.de
  - libXaw 1.0.7
  - provide libXaw8.so.8, libXaw7.so.7, libXaw6.so.6
  - create compatibility symlinks libXaw8.so.8, libXaw.so.8
* Sun Apr 04 2010 sndirsch@suse.de
  - libWindowsWM 1.0.1
  - libXScrnSaver 1.2.0
  - libXcomposite 0.4.1
  - libXcursor 1.1.10
  - libXdamage 1.1.2
  - libXfont 1.4.1
  - libXinerama 1.1
  - libXres 1.0.4
  - libXvMC 1.0.5
  - libpciaccess 0.10.9
  - xbitmaps 1.1.0
  - libXft 2.1.14
  - obsoletes p_xft_cjk.diff, Header-cleanup-bug-4703.patch
  - adjusted libXft-2.1.7-lcd-filter-2.patch
  - bumped version number to 7.5
* Thu Feb 18 2010 sndirsch@suse.de
  - exclude /usr/include/X11/extensions/lbximage.h from
    xorg-x11-devel (already in xorg-x11-libXext-devel)
  - exclude /usr/lib/libpciaccess.so from xorg-x11-devel (already in
    libpciaccess0-devel)
* Sat Jan 16 2010 sndirsch@suse.de
  - updated libraries
    * libXtst-1.1.0
    * libXxf86dga-1.1.1
    * libXxf86vm-1.1.0
    * libdmx-1.1.0
    * liblbxutil-1.1.0
  - removed lbxbuf.h/lbxbufstr.h (same version already in libXext)
  - removed libAppleWM
  - removed libXi (seperate libXi6 package now)
  - added libXi6-devel to Requires
* Mon Dec 14 2009 jengelh@medozas.de
  - add baselibs.conf as a source
* Thu Nov 19 2009 sndirsch@suse.de
  - moved pkgconfig file for libpciaccess to seperate libpciaccess
    package
* Mon Aug 24 2009 sndirsch@suse.de
  - xcb-util 0.3.6
    * various issues fixed
* Wed Jul 08 2009 sndirsch@novell.com
  - libFS 1.0.2: various fixes
* Mon Jun 08 2009 sndirsch@suse.de
  - drop libXft1, since it's no longer required by current versions
    of Intel's Debugger (bnc #198432)
* Sun Jun 07 2009 sndirsch@suse.de
  - force removal of .la files on openSUSE > 11.1 (fixes build on
    IA64)
* Fri Jun 05 2009 eich@suse.de
  - Add patches from Moblin:
    * libXft:
      . clean up header file.
    * libXTrap:
      . remove trapproto as Requires from pkgconfig file.
* Fri May 29 2009 sndirsch@suse.de
  - xcb-util 0.3.5
    * various issues fixed
    Thu Apr 30 22:40:53 CEST 2009
  - fix a version typo that prevented the .la files to be found for
    11.0 <= version <= 11.1
    Thu Apr 30 21:53:45 CEST 2009
  - pack .la files in devel package
* Thu Apr 30 2009 eich@suse.de
  - move static libraries to devel package
* Thu Apr 30 2009 sndirsch@suse.de
  - build static libraries for versions <= 11.1
* Sat Apr 25 2009 sndirsch@suse.de
  - libpciaccess 0.10.6
* Tue Apr 21 2009 crrodriguez@suse.de
  - remove static libraries and "la" files
* Wed Apr 15 2009 sndirsch@suse.de
  - xcb-util 0.3.4
* Tue Mar 10 2009 sndirsch@suse.de
  - libXrandr 1.3.0
  - obsoletes libXrandr-70d641c.diff
* Wed Mar 04 2009 sndirsch@suse.de
  - libXrandr-70d641c.diff
    * fixes fatal protocol error in libXrandr, which broke RANDR
      support completely (bnc #481863)

Files

/usr/share/doc/packages/xorg-x11-devel
/usr/share/doc/packages/xorg-x11-devel/README.meta


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Sep 15 22:31:57 2014