Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

xml2po-devel-0.20.10-2.1.2 RPM for noarch

From OpenSuSE 12.2 for noarch

Name: xml2po-devel Distribution: openSUSE 12.2
Version: 0.20.10 Vendor: openSUSE
Release: 2.1.2 Build date: Mon Jul 16 14:28:09 2012
Group: System/GUI/GNOME Build host: build23
Size: 195 Source RPM: gnome-doc-utils-0.20.10-2.1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.gnome.org
Summary: Tool to extract translatable content from XML documents
xml2po is a simple Python program which extracts translatable
content from free-form XML documents and outputs gettext compatible
POT files.

Provides

Requires

License

GPL-2.0+

Changelog

* Mon Mar 26 2012 vuntz@opensuse.org
  - Update to version 0.20.10:
    + Fixed problem with dist and install with too many files
    + Updated translations.
* Wed Mar 21 2012 vuntz@opensuse.org
  - Update to version 0.20.9:
    + Temporarily adding RNG files back for compatibility.
* Mon Mar 19 2012 zaitor@opensuse.org
  - Update to version 0.20.8:
    + Don't call RNG files, removed in 0.20.7
* Fri Mar 02 2012 dimstar@opensuse.org
  - Update to version 0.20.7:
    + Use gawk --traditional option instead of -W compat
    + Added support for silent rules to gnome-doc-utils.make
    + Fixed xml2po.pc to not Require libxml.pc
    + Added --disable-documentation build option
    + Dropped Mallard definitions from gnome-doc-utils
    + Updated translations.
  - Remove libxml2-devel Requires from xml2po-devel package: the .pc
    file no longer references libxml.
  - Remove obsoleted conditions for openSUSE <= 11.1.
* Sat Feb 25 2012 coolo@suse.com
  - Add libxml2-tools BuildRequires for xmllint, now that libxml2 got
    split.
  - Remove python BuildRequires and %py_requires: we only need a
    minimal python, which libxml2-python will bring in both cases.
* Thu Dec 22 2011 vuntz@opensuse.org
  - Own %{_datadir}/aclocal to fix build without automake/autoconf.
* Fri May 27 2011 vuntz@opensuse.org
  - Add docbook_4 Requires to devel subpackage: packages building
    with gnome-doc-utils support will use xsltproc to validate files,
    and we want ot use a local DTD instead of fetching one from the
    internet.
* Tue Apr 26 2011 fcrozat@novell.com
  - Update to version 0.20.6:
    + Updated Mallard schema.
    + Fixed 'make pot' rule for Mallard.
    + Updated translations.
* Tue Mar 22 2011 fcrozat@novell.com
  - Update to version 0.20.5:
    + Updated Mallard RNG files
    + Updated translations.
* Thu Mar 03 2011 fcrozat@novell.com
  - Update to version 0.20.4:
    + Use /bin/bash in gnome-doc-tool
    + Add xml:lang attribute to translated Mallard pages
    + Handle title and desc elements in Mallard tables
    + Updated translations.
* Sun Feb 13 2011 vuntz@opensuse.org
  - Pass %{?no_lang_C} to %find_lang so that english documentation
    can be packaged with the program, and not in the lang subpackage.
  - Change Requires of lang subpackage to Recommends, since the
    english documentation is not there anymore.
* Tue Dec 21 2010 vuntz@opensuse.org
  - Update to version 0.20.3:
    + Fixed nested command substitution in gnome-doc-utils.make.
    + Updated translations.
* Thu Oct 14 2010 vuntz@opensuse.org
  - Use Recommends instead of Requires for the lang package.
* Tue Sep 28 2010 vuntz@opensuse.org
  - Update to version 0.20.2:
    + Updated translations.
* Thu Apr 29 2010 dimstar@opensuse.org
  - Update to version 0.20.1:
    + Improved support for SVG imagedata
    + Updated translations.
* Mon Mar 29 2010 vuntz@opensuse.org
  - Update to version 0.20.0:
    + Updated translations.
* Sun Feb 21 2010 vuntz@opensuse.org
  - Update to version 0.19.5:
    + Updated the Mallard RNG schema.
    + Updated translations:
* Wed Feb 10 2010 vuntz@opensuse.org
  - Update to version 0.19.4:
    + Bold userinput inside programlisting
    + Updated translations.
* Tue Jan 26 2010 vuntz@opensuse.org
  - Update to version 0.19.3:
    + Fixed shading with rowspans, bgo#606986
    + Implemented text titles
    + Updated translations.
* Tue Jan 12 2010 vuntz@opensuse.org
  - Update to version 0.19.2:
    + Added 'css' command for Mallard documents
    + Fixed theme.color.text default, was white-on-white
    + Implemented previous and next links for Mallard documents
    + Updated translations.
* Wed Jan 06 2010 vuntz@opensuse.org
  - Update to version 0.19.1:
    + Importing Mallard XSLT changes from yelp-xsl
    - Added support for audio and video in Mallard HTML output
    - Moved most automatic link logic into common XSLT
    - Implemented sorting of link trails
    - Implemented link groups on Mallard guide pages
    - Added support for Mallard span element
    - Added condensed list style for Mallard lists
    - Made various parts of the Mallard XSLT more extensible
    - Changed Mallard Cache files to use new namespace
    + Added Mallard HTML output to gnome-doc-tool
    + Added --custom-xslt option to gnome-doc-tool
    + Compile mo files before running xml2po
    + Properly clean mo files in build utilities
    + Updated translations.
  - Drop gnome-doc-utils-make-parallel.patch: fixed upstream.
  - Make the build noarch.
  - Remove en@shaw locale on 11.2 and earlier.
  - Split xml2po tool in xml2po and xml2po-devel subpackages.
  - Make gnome-doc-utils-devel Requires xml2po-devel, to make sure no
    build is broken because of the split.
* Wed Dec 02 2009 vuntz@opensuse.org
  - Update to version 0.18.1:
    + Fixed Makefile.am to byte-compile Python files, bug #596702
    + Updated translations.
  - Complete gnome-doc-utils-make-parallel.patch with commit
    ce05d9fd, and reenable parallel build.
* Thu Nov 26 2009 dimstar@opensuse.org
  - Parallel build still has chances to fail. Disabling for now.
* Wed Nov 25 2009 dimstar@opensuse.org
  - Add gnome-doc-utils-make-parallel.patch to solve parallel build
    failures (patch taken from upstream git).
* Mon Sep 28 2009 vuntz@opensuse.org
  - Update to version 0.18.0:
    + Replaced Mallard copyright element with credit
    + Fixed model for external-namespace elements in info context
    + Fixed gnome-doc-utils.make parallel build failure, bgo#595197
    + Updated translations.
* Wed Sep 09 2009 vuntz@opensuse.org
  - Update to version 0.17.5:
    + mal2html: Handle link roles on automatic and inline links
    + Updated translations.
* Tue Aug 25 2009 vuntz@novell.com
  - Update to version 0.17.4:
    + Don't let "twocolumn" tables collapse in Mallard documents
    + Use AC_MSG_* when checking for gnome-doc-utils, bgo#571300
    + Work around buggy OpenSolaris awk
    + Substantial changes to xml2po
    + Work on xml2po Mallard mode
    + Fix misspelling of 'description'
    + Updated translations.
* Wed Aug 12 2009 dominique-obs@leuenberger.net
  - Define new python macros on openSUSE <= 11.1.
* Sun Aug 09 2009 coolo@novell.com
  - use new python macros
* Wed Jul 29 2009 vuntz@novell.com
  - Update to version 0.17.3:
    + Added initial work on a Mallard xml2po mode
    + Internationalization work on Mallard stylesheets
    + Fixed example in Mallard document
    + Preserve exiting PYTHONPATH in bootstrap
    + Addressed RTL issues in Mallard stylesheets
    + Updated translations.
* Mon Jul 20 2009 vuntz@novell.com
  - Update to version 0.17.2:
    + Added build magic for Mallard documents
    + Fixed various validity errors in the Mallard spec
    + Created a (not yet complete) DocBook->Mallard reference
    + Fixed various problems with the Mallard RNG schema
    + Various additions to (still incomplete) Mallard spec
    + Fixed DocBook menuchoice seperator in RTL, bgo#579278
    + Install xml2po modes in /usr/lib/python2.x/ to respect FHS,
      bgo#528099
    + Remove ending dot in translator-credits comment [xml2po],
      bgo#398541
    + Make all xml2po modes inherit from basic mode
    + Fixed typos in xml2po man page, bgo#586089
    + Updated translations.
  - Add libxml2-python BuildRequires since xml2po is called during
    the build now.
  - Package is not noarch anymore since we use py_sitedir.
  - Add py_requires.
* Mon Jun 15 2009 vuntz@novell.com
  - Update to version 0.17.1:
    + Integrated Mallard support
    + Fix file-not-found warnings from config.status
  - Add libxml2-devel Requires to devel package.
* Wed Apr 15 2009 vuntz@novell.com
  - Update to version 0.16.1:
    + Use new hashlib module instead of md5, bgo#576161
    + Updated transations.
* Mon Mar 16 2009 vuntz@novell.com
  - Update to version 0.16.0:
    + Updated translations.
* Mon Mar 16 2009 sbrabec@suse.cz
  - Added support for translation-update-upstream (FATE#301344).
* Mon Mar 09 2009 vuntz@novell.com
  - Split off a lang package.
  - Put back scrollkeeper in Requires (of the devel package this
    time). It's really needed.
  - Move some files to the devel package, where they belong.
* Mon Mar 02 2009 mboman@suse.de
  - Update to version 0.15.2:
    + More RTL fixes for bgo#563559
    + Translation updates
  - Completly remove gnome-doc-utils-permissive.patch
  - Remove scrollkeeper from BuildRequires/Requires
  - Remove AutoReqProv since it's default
  - Add libxslt to Requires

Files

/usr/share/pkgconfig/xml2po.pc


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jul 10 17:26:57 2014