Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libxklavier-doc-5.2.1-2.1.2 RPM for i586

From OpenSuSE 12.2 for i586

Name: libxklavier-doc Distribution: openSUSE 12.2
Version: 5.2.1 Vendor: openSUSE
Release: 2.1.2 Build date: Mon Jul 16 02:11:33 2012
Group: Development/Libraries/X11 Build host: build32
Size: 66921 Source RPM: libxklavier-5.2.1-2.1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.freedesktop.org/Software/LibXklavier
Summary: Additional Package Documentation for libxklavier
This library allows you to simplify XKB-related development.

Provides

Requires

License

LGPL-2.0+

Changelog

* Thu Feb 16 2012 dimstar@opensuse.org
  - Update to version 5.2.1:
    + Fixed GIR params for introspection (broken build)
  - Remove xz BuildRequires now that it comes for free in the build
    system.
  - Drop libxklavier-fix-gir-build.patch: fixed upstream.
  - Change glib2-devel and libxml2-devel BuildRequires to their
    pkgconfig() equivalents: glib-2.0 and libxml-2.0.
  - Clean spec file using spec-cleaner.
* Thu Jan 26 2012 vuntz@opensuse.org
  - license update: LGPL-2.0+
    No indication of GPL-2.0+ tools or utilities (apart from
    configure, etc.)
* Wed Jan 18 2012 vuntz@opensuse.org
  - Update to version 5.2:
    + Optional introspection introduced
    + Some minor fixes (runtime and build-time)
  - Add xz BuildRequires because we can't build a package for a
    xz-compressed tarball without explicitly specifying that... See
    bnc#697467 for more details.
  - Add gobject-introspection-devel BuildRequires to build
    introspection support.
  - Add libxklavier-fix-gir-build.patch to fix build of introspection
    support.
  - Create typelib-1_0-Xkl-1_0 subpackage for typelib file.
  - Add typelib-1_0-Xkl-1_0 Requires to devel subpackage.
  - Remove glib2-devel and libxml2-devel Requires from devel
    subpackage: they will automatically be added the pkgconfig() way.
  - Remove Requires for the XFree86-devel provider from devel
    subpackage: it's not needed according to the pkgconfig file.
  - Change group of libxklavier16 from Development/Libraries/X11 to
    System/Libraries.
* Thu Oct 06 2011 vuntz@opensuse.org
  - Add iso-codes Requires to libxklavier16 since the iso-codes data
    is used at runtime.
* Tue Apr 19 2011 ro@suse.de
  - Update baselibs.conf (libxklavier16 instead of libxklavier12)
* Mon Feb 14 2011 fcrozat@novell.com
  - Update to version 5.1:
    + Expanding APIs for GNOME 3 needs:
    - converting ISO codes to translatable names (it was private,
      now public)
    - search by pattern
    + Using X11 API through pkg-config
    + One race condition eliminated
    + XInput2 version checking: looking for support of DevicePresence
* Wed Jan 13 2010 captain.magnus@opensuse.org
  - Update to version 5.0:
    + Introducing counters for start/stop listen operations: in one
      process (actually g-s-d) start and stop can be called several
      times, with different masks. The API is incompatibly changed!
    + Using transient property for smart handling of the popup
      windows (for the per-window layout scenario)
    + Save xinput error code and event type
    + Introduced engine-specific error handling (for ignoring xinput
      errors)
    + Sometimes focus_in arrives when the previously focused window
      is already destroyed. That causes BadMatch and all kinds of
      trouble. The code should handle that case correctly
    + Fixed a bug with XIE check (bgo#583709)
    + Small fix for flag enum fdo#21578
  - Rename libxklavier15 subpackage to libxklavier16, following
    soname change.
* Tue Jan 05 2010 jengelh@medozas.de
  - Package baselibs.conf
* Sun Aug 02 2009 coolo@novell.com
  - remove the obsolete to the old library, shared libraries are supposed
    to be installable in parallel
* Mon Jul 20 2009 vuntz@novell.com
  - Update to version 4.0:
    + Support for "extras" in xkeyboard-config, small bugfixes and
      build fixes.
  - Rename libxklavier12 to libxklavier15 and make it Obsolete
    libxklavier12.
* Thu Mar 19 2009 vuntz@novell.com
  - Update to version 3.9:
    + Several small bugs fixed, including memleak and crash under NX
  - Remove AutoReqProv: it's default now.
  - Use makeinstall.
  - Remove libxklavier package (contained only doc) and have
    libxklavier12 provide it.
  - Remove work-around for old versions of openSUSE and autoreconf
    call.

Files

/usr/share/gtk-doc/html/libxklavier
/usr/share/gtk-doc/html/libxklavier/XklConfigItem.html
/usr/share/gtk-doc/html/libxklavier/XklConfigRec.html
/usr/share/gtk-doc/html/libxklavier/XklConfigRegistry.html
/usr/share/gtk-doc/html/libxklavier/ch01.html
/usr/share/gtk-doc/html/libxklavier/ch02.html
/usr/share/gtk-doc/html/libxklavier/home.png
/usr/share/gtk-doc/html/libxklavier/index.html
/usr/share/gtk-doc/html/libxklavier/index.sgml
/usr/share/gtk-doc/html/libxklavier/left.png
/usr/share/gtk-doc/html/libxklavier/libxklavier-xkl-engine.html
/usr/share/gtk-doc/html/libxklavier/libxklavier-xklavier.html
/usr/share/gtk-doc/html/libxklavier/libxklavier.devhelp2
/usr/share/gtk-doc/html/libxklavier/right.png
/usr/share/gtk-doc/html/libxklavier/style.css
/usr/share/gtk-doc/html/libxklavier/up.png


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 10 12:27:23 2014