Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gnome-pilot-2.91.93-2.1.2 RPM for x86_64

From OpenSuSE 12.1 for x86_64

Name: gnome-pilot Distribution: openSUSE 12.1
Version: 2.91.93 Vendor: openSUSE
Release: 2.1.2 Build date: Sun Oct 30 07:35:07 2011
Group: System/GUI/GNOME Build host: build27
Size: 1147406 Source RPM: gnome-pilot-2.91.93-2.1.2.src.rpm
Summary: PalmOS Device Management for GNOME
This package provides application to integrate PalmOS devices in GNOME.






* Sun Sep 11 2011
  - Update to version 2.91.93:
    + Bugs fixed: bgo#647479, bgo#657658, bgo#657365.
  - Drop gnome-pilot-fix-cast.patch: fixed upstream.
  - Drop gnome-pilot-fix-pkgconfig.patch: fixed upstream.
* Thu Jul 07 2011
  - Add gnome-pilot-fix-pkgconfig.patch: this fixes the pkg-config
    file to reference the right library names (which are versioned
    with 3.0, now).
* Wed Apr 06 2011
  - Update to version 2.91.92:
    + bgo#590215: complete port to gtk3/gnome3
    + update all libraries to major version 3, including conduits.
      Should allow parallel installs with gnome-2 if desired.
    + migrated applet to use libpanel4 (dbus instead of bonobo)
      bgo#592604, bgo#630725
    + fix crash in configuration applet when configuring multiple
      Evolution conduits bgo#644319.
    + fix crash in configuration applet caused by non-ASCII
      characters in owner name, introduced in migration to dbus in
    + fix gob rules to support parallel builds, and todo conduit
      map-file patch bgo#634874, bgo#634869.
    + Fix map-file path for todo conduit. bgo#634869
    + fix include problem when using a separate build directory.
    + Use dbus directly for device detection, instead of HAL.
    + Use gnome-doc-utils
  - Add gnome-pilot-fix-cast.patch: fix invalid cast, breaking build
    (from git).
  - Drop gnome-pilot-add-gtk-2.0-to-pkgconfig.patch: no longer needed
  - Change pkgconfig() BuildRequires for GNOME 3 port:
    + Old ones: gtk+-2.0, libedataserverui-1.2, libpanelapplet-2.0.
    + New ones: gtk+-3.0, libedataserverui-3.0, libpanelapplet-4.0.
  - Drop scrollkeeper, pkgconfig(hal) BuildRequires.
  - Add gnome-common, gnome-doc-utils-devel, pkgconfig(gudev-1.0)
  - Drop --with-pisock-lib configure flag, removed upstream.
* Thu Feb 17 2011
  - Add gnome-pilot-add-gtk-2.0-to-pkgconfig.patch: the headers
    installed by gnome-pilot reference GTK+, so gtk+-2.0 should be in
    the Requires field of the pkg-config file.
* Sun Feb 13 2011
  - Call relevant macros in %post/%postun:
    + %desktop_database_post/postun because the package ships at
      least one desktop file.
    + %icon_theme_cache_post/postun because the package ships themed
    + %mime_database_post/postun because the package ships a mime
      type definition.
  - Pass %{?no_lang_C} to %find_lang so that english documentation
    can be packaged with the program, and not in the lang subpackage.
  - Change Requires of lang subpackage to Recommends, since the
    english documentation is not there anymore.
* Tue Sep 28 2010
  - Add missing libpisync-devel Requires to devel package. This will
    fix build in gnome-pilot-conduits.
* Sun Sep 26 2010
  - Update to version 2.32.0:
    + Significant code cleanups.
    + Migrate Evolution conduits from evolution code base to
    + Bug Fixes:
    - bgo#594214: Remove deprecated GTK/glib symbols
    - bgo#590215: Remove libgnome/libgnomeui dependency
    - bgo#589501: convert applet to GtkBuilder
    - bgo#597328: remove obsolete gpilotd-conduit-mgmt.h
    - bgo#619315: Move evolution conduits from evo to gnome-pilot
    - bgo#592604: Migrate from bonobo to dbus
    - bgo#610782: support more versions of autoconf
    - bgo#607142: Clean up of build system
    - bgo#590225: remove gnome_help and gnome-open calls
    - bgo#584894: pilot applet is not visible on the panel on
    - bgo#569481: Use stock gnome pda icon
    - bgo#569193: remove obsolete SUSE-specific GNOMEPATH
    - bgo#570724: avoid using deprecated gnome-i18n in favour or
    - bgo#568404: only gpilotd binary needs to be linked with
  - Drop gnome-pilot-no-susepath.patch and
    gnome-pilot-pkgconfig.patch: fixed upstream.
  - Rebase gnome-pilot-pisock64bit.patch.
  - Change old-style BuildRequires to pkgconfig() style
    + old-style: gnome-panel-devel.
    + new-style: dbus-glib-1, gconf-2.0, gtk+-2.0,
      libpanelapplet-2.0, libxml-2.0.
  - Remove unneeded BuildRequires: fam, libglade2-devel, libidl.
  - Add BuildRequires: pkgconfig(hal),
  - Update summary and description.
  - Do not add -fno-strict-aliasing to CFLAGS.
  - Pass --disable-static to configure and remove .la files with a
  - Create a gnome-pilot icon based on the pda icon from
    gnome-icon-theme for the desktop file:
    + add gnome-icon-theme BuildRequires
    + copy the pda icons from gnome-icon-theme to hicolor as
      gnome-pilot icons
    + update the desktop file accordingly
* Mon Apr 26 2010
  - Add gnome-pilot-pkgconfig.patch: do not provide extra information
    in the pkgconfig version field. It breaks any case of version
    based checks.
* Tue Aug 04 2009
  - Do not package omf files twice.
* Mon Feb 16 2009
  - Added support for translation-update-upstream (FATE#301344).



Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 10 04:45:39 2015