Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gtk-vnc-devel-0.4.3-6.1.2 RPM for i586

From OpenSuSE 12.1 for i586

Name: gtk-vnc-devel Distribution: openSUSE 12.1
Version: 0.4.3 Vendor: openSUSE
Release: 6.1.2 Build date: Sun Oct 30 02:53:13 2011
Group: Development/Libraries/X11 Build host: build31
Size: 142253 Source RPM: gtk-vnc-0.4.3-6.1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://gtk-vnc.sf.net/
Summary: A GTK widget for VNC clients -- Development Files
gtk-vnc is a VNC viewer widget for GTK+. It is built using coroutines
allowing it to be completely asynchronous while remaining single
threaded.

Provides

Requires

License

LGPLv2.1+

Changelog

* Sat Oct 15 2011 coolo@suse.com
  - add libtool as buildrequire to make the spec file more reliable
* Wed Aug 24 2011 crrodriguez@opensuse.org
  - Add libgcrypt-devel BuildRequires. This used to be pulled in by
    gnutls-devel, but this is no longer the case.
* Thu Mar 24 2011 fcrozat@novell.com
  - Update to version 0.4.3:
    + Bug fixes:
    - Fix crash in pointer motion event handler
    - Fix crash in vnc_display_get_pixbuf
    - Fix crash in TLS cleanup code
    - Fix framebuffer boundary checks
    - Improve drawing performance with server side pixmap
    - Fix performance degradation due to leaked GSource
    - Fix setting of 'shared' connection flag
    - Make pointer warp boundary detection more robust
    - Adapt keymap code to build with GDK3 multiple displays
    - Remove use of gdk_drawable calls to fix GTK3
    + Code cleanup:
    - Remove need for Text::CSV perl module at build time
  - Add pre_checkin.sh to build gtk2 and gtk3 version of the package
    and add some macros to handle dual gtk2 / gtk3 packages.
  - Differences between gtk2 / gtk3 packages:
    + gtk3 package doesn't come with python bindings as introspection
      support is used instead.
    + Pass --with-gtk=2.0/--with-gtk=3.0 to configure as appropriate.
    + libgvnc-1_0-0 and tools subpackages are only kept for gtk3
      build.
  - Drop gtk-vnc-unref-gsource.patch: fixed upstream.
  - Use Recommends instead of Requires for the -lang package.
  - Remove explicit gtk2-devel Requires from the -devel package: the
    right Requires will automatically be added the pkgconfig() way.
  - Drop perl-Text-CSV BuildRequires.
* Tue Feb 15 2011 sbrabec@suse.cz
  - Added support for translation-update-upstream.
* Tue Feb 15 2011 rhafer@suse.de
  - Add gtk-vnc-unref-gsource.patch to fix cpu usage and speed
    problems in virt-manager (bnc#672071, rh#657847)
* Mon Nov 15 2010 dimstar@opensuse.org
  - Update to version 0.4.2:
    + New features:
    - OSX VNC Authentication scheme
    - Add API to query library version
    + Bug fixes
    + Switched over to GIO for socket connections.
    + Removed all use of GNULIB. GIO now handles all portability
      issues with sockets.
    + Mandate use of cairo for all drawing, removing any use of
      GdkPixmap, GdkImage and GdkBitmap.
    + Updated translations.
  - Drop gtk-vnc-0.4.1-close-buffer.patch: fixed upstream.
  - Add perl-Text-CSV BuildRequires for keymap-gen.pl to work.
* Mon Sep 27 2010 seife@opensuse.org
  - Add gtk-vnc-0.4.1-close-buffer.patch to fix virt-manager crashes
    (bnc#641981, rh#620843).
* Mon Aug 09 2010 vuntz@opensuse.org
  - Build introspection support: add gobject-introspection-devel
    BuildRequires.
  - Remove gtkglext-devel BuildRequires and replace gnome-common
    BuildRequires with intltool.
  - Split the libgvnc library in its own libgvnc-1_0-0 subpackage.
  - Move %py_requires to python-gtk-vnc subpackage.
  - Pass --with-examples to configure to build the gvncviewer tool.
  - Package examples/gvncviewer.py in python-gtk-vnc as
    documentation.
* Mon Jul 26 2010 dimstar@opensuse.org
  - Update to version 0.4.1:
    + Fix test suite execution
    + Ensure builds against GTK3 get a separate library soname,
      pkg-config file and include directory to allow parallel
      install with GTK2 builds
  - Changes from version 0.4.0:
    + Refactored gvnc module to provide a full GObject for
      interacting with the RFB protcol.
    + Create a libgvnc.so for non-GTK related APIs for dealing with
      RFB protcol
    + Add gvnccapture command line tool for screenshot capture
    + Fix protocol greeting so wireshark detects stream
    + Fix build with GSEAL
    + Try next DNS address after any connect failure
    + Plugin build with newer mozilla
    + Fix linkage to libgpg-error
    + Fix linker flags on solaris
    + Fix gcrypt threading callbacks
    + Fix multiple memory leaks
    + Remove use of PATH_MAX to fix Hurd
  - Drop gtk-vnc-0.3.3-pkgconfig.patch, upstream fixed.
* Fri Nov 13 2009 vuntz@opensuse.org
  - Update to version 0.3.10:
    + Bug fixes:
    - Fix check for SASL on Solaris
    - Improvements on autoconf stuff such as drop some warnings,
      use silent Makefile rules, etc.
    - Improvements on the example program
    - Request a full screen update when receives a desktop-resize
      encoding
    + New features:
    - Add internationalization (i18n) support
    - Add ability to set the depth color
    - Add ability to request a full screen update
    + Updated translations.
  - Create a lang package.
* Tue Aug 11 2009 vuntz@novell.com
  - Update to version 0.3.9:
    + Bug fixes:
    - Fix Shift+Tab keyval translation (again)
    - Remove use of deprecated GTK+ symbols
    - Fix inverted logic for release pointer grab
    - Fix enter/leave event handling in relative mouse mode
    - Don't send keys/clipboard data in readonly mode
    - Fix relative mouse motion mode edge tracing
    - Fix linking to libgcrypt for mingw32 platform
    + New features:
    - Add API to get command line GOptionEntry objects
    - Support SASL authentication extension
    - Support MS Logon authentication extension
  - Add cyrus-sasl-devel BuildRequires.
* Thu Mar 19 2009 vuntz@novell.com
  - Do not create a gtk-vnc package with only documentation, and
    instead ship the documentation in the libgtk-vnc-1_0-0 package
    (add Obsoletes/Provides for this)
  - Remove AutoReqProv: it's default now.
  - Remove check for old version of openSUSE.
  - Remove unneeded BuildRequires: perl-XML-Parser.

Files

/usr/include/gtk-vnc-2.0
/usr/include/gtk-vnc-2.0/vncdisplay.h
/usr/include/gtk-vnc-2.0/vncdisplayenums.h
/usr/include/gtk-vnc-2.0/vncgrabsequence.h
/usr/include/gtk-vnc-2.0/vncimageframebuffer.h
/usr/include/gvnc-1.0
/usr/include/gvnc-1.0/vncbaseframebuffer.h
/usr/include/gvnc-1.0/vnccolormap.h
/usr/include/gvnc-1.0/vncconnection.h
/usr/include/gvnc-1.0/vncconnectionenums.h
/usr/include/gvnc-1.0/vnccursor.h
/usr/include/gvnc-1.0/vncframebuffer.h
/usr/include/gvnc-1.0/vncpixelformat.h
/usr/include/gvnc-1.0/vncutil.h
/usr/lib/libgtk-vnc-2.0.so
/usr/lib/libgvnc-1.0.so
/usr/lib/pkgconfig/gtk-vnc-2.0.pc
/usr/lib/pkgconfig/gvnc-1.0.pc
/usr/share/gir-1.0/GVnc-1.0.gir
/usr/share/gir-1.0/GtkVnc-2.0.gir


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 10 12:40:22 2014