Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libpanel-applet-2-0-2.32.1-7.10.5 RPM for i586

From OpenSuSE 11.4 for i586

Name: libpanel-applet-2-0 Distribution: openSUSE 11.4
Version: 2.32.1 Vendor: openSUSE
Release: 7.10.5 Build date: Tue Feb 22 23:07:56 2011
Group: System/GUI/GNOME Build host: build21
Size: 59832 Source RPM: gnome-panel-2.32.1-7.10.5.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.gnome.org
Summary: GNOME Panel Applet Library -- Bonobo-based library
This package contains the GNOME Desktop Panel. The panel is an
easy-to-use and functional interface to manage your desktop, start
programs, and organize access to your data.

This package contains the library used by GNOME panel applets,
based on bonobo.

Provides

Requires

License

LGPLv2.1+

Changelog

* Thu Feb 17 2011 vuntz@opensuse.org
  - Add gnome-panel-fix-applet-xinerama.patch: on a xinerama setup,
    applets on the second/third/etc. screens won't even start. This
    patch from git fixes this.
  - Add gnome-panel-no-bonobo-in-process.patch: remove the
    possibility to have in-process bonobo applets. Having in-process
    bonobo applets will simply break the whole gnome-panel process,
    which is extremely bad. So we remove this option directly from
    the library. Note that it breaks API, but it actually affects no
    package in openSUSE, as far as I know -- if it happens to do so,
    though, then we can just rebuild the broken package as
    out-of-process applet. Taken from git.
* Sun Feb 13 2011 vuntz@opensuse.org
  - Call relevant macros in %post/%postun:
    + %desktop_database_post/postun because the package ships at
      least one desktop file.
    + %icon_theme_cache_post/postun because the package ships themed
      icons.
  - Pass %{?no_lang_C} to %find_lang so that english documentation
    can be packaged with the program, and not in the lang subpackage.
  - Change Requires of lang subpackage to Recommends, since the
    english documentation is not there anymore.
* Wed Dec 15 2010 vuntz@opensuse.org
  - Make libpanel-applet-3-0 own /usr/share/gnome-panel and
    /usr/share/gnome-panel/applets as applets using this library must
    install a file there.
* Wed Nov 17 2010 dimstar@opensuse.org
  - Update to version 2.32.1:
    + Panel: Support relocating the .gnome2 directory with an
      environment variable, like libgnome does
    + libpanel-applet: Fix build breakage caused by wrong include
    + Link gnome-desktop-item-edit against X libs too
    + Updated translations.
* Wed Oct 13 2010 vuntz@opensuse.org
  - Remove libidl-devel BuildRequires: gnome-panel doesn't need it
    (it's actually needed as a dependency for ORBit, though, but we
    don't need it explicitly).
* Mon Oct 11 2010 vuntz@opensuse.org
  - Add libpanel-applet-3-0 to baselibs.conf.
* Mon Sep 27 2010 vuntz@opensuse.org
  - Update to version 2.32.0.2:
    + Build panel with -export-dynamic. Else, it just fails badly at
      runtime
  - Changes from version 2.32.0.1:
    + Fix build with --as-needed
  - Changes from version 2.32.0:
    + Associate .gir with pkg-config file.
    + Updated translations.
* Tue Sep 14 2010 vuntz@opensuse.org
  - Update to version 2.31.92:
    + Panel
    - Fix various issues where panels stay hidden on load or on
      addition
    - Do not queue load of an applet if it's already being loaded
    - Fix loading of bonobo applets that are already configured
    - Understand bonobo IID in applet_iid keys
    - Add back optional support for bonobo applets to
      gnome-panel-add
    - Stop using deprecated gdk_display/GDK_DISPLAY()
    - Prevent modules from being unloadable, which fixes a crash on
      logout
    + libpanel-applet
    - Fix build with gobject-introspection 0.9.5
    + libpanel-applet
    - Stop using deprecated gdk_display
    + Misc
    - Small build fixes
    - Update information in README and other files
    - Rewrite gnome-panel man page
    - Explicitly link to xrandr
    + Updated translations.
  - Drop gnome-panel-fix-hidden-panel-and-applets.patch: fixed
    upstream.
* Tue Sep 07 2010 vuntz@opensuse.org
  - Add gobject-introspection-devel BuildRequires to build
    introspection support for libpanel-applet-3.
  - Change old-style BuildRequires to pkgconfig() style
    BuildRequires:
    + old-style: NetworkManager-devel, dbus-1-devel,
      evolution-data-server-devel, gnome-desktop-devel,
      gnome-menus-devel, libbonoboui-devel, libcanberra-devel,
      libgweather-devel, librsvg-devel, libwnck-devel
    + new-style: NetworkManager, ORBit-2.0, cairo, dbus-glib-1,
      gconf-2.0, gdk-pixbuf-2.0, glib-2.0, gnome-desktop-2.0,
      gtk+-2.0, gweather, ice, libbonoboui-2.0, libcanberra-gtk,
      libedataserver-1.2, libedataserverui-1.2, libgnome-menu,
      librsvg-2.0, libwnck-1.0, pango, sm, x11, xau.
  - This will make it easier to switch to GNOME 3 libraries.
* Mon Sep 06 2010 vuntz@opensuse.org
  - Add gnome-panel-fix-hidden-panel-and-applets.patch to fix several
    issues, with fixes I just pushed to git:
    + panel is hidden on first boot (bnc#637180)
    + newly created panels are hidden
    + main menu not on default panel (bnc#637130, bnc#637229)
  - Remove 2.x references in summaries and descriptions: the panel
    will still be an option in GNOME 3.
* Thu Sep 02 2010 vuntz@opensuse.org
  - Update to version 2.31.91:
    + Fix build with missing dbus-glib-1 dependency.
    + Notification Area Applet:
    - Fix bugs related to GSEALing effort.
    + Updated translations.
  - Remove hack to fix the build by setting CFLAGS.
* Wed Sep 01 2010 vuntz@opensuse.org
  - Fix workaround that fixes the build by adding the dbus-glib-1
    flags: we also need the path to headers.
* Wed Aug 18 2010 dimstar@opensuse.org
  - Update to version 2.31.90:
    + Use the polkit helper from g-s-d to set time/timezone
    + Updated translations.
  - Remove polkit-devel BuildRequires.
  - Require gnome-settings-daemon-polkit-datetime.
* Sun Aug 08 2010 vuntz@opensuse.org
  - Cleanup update to 2.31.4.
  - Update to version 2.31.6:
    + Panel
    - Allow Windows key as valid mouse modifier
    - Update to latest gdbus API change
    + libpanel-applet
    - GSeal fixes
    + Workspace Switcher Applet
    * Fix crash in multiscreen setups
    + Updated translations.
  - Remove gnome-themes Requires: it's just wrong.
  - Remove gnome-control-center Recommends: there's no reason for it.
  - Update summaries and descriptions.
  - Fix license tags: the non-library code is GPLv2+, not LGPLv2.1+.
  - Create a bonobo-support subpackage: the support for bonobo
    applets is optional, and this makes it easy to remove it when
    possible.
  - Update packaging for /usr/share/gconf renaming to
    /usr/share/GConf.
  - Reintroduce gnome-panel-bnc363981-intlclock-compatibility.patch,
    but update it for the new way panel applets work.
  - Move panel-test-applets* utilities to devel subpackage, since
    it's really only useful for developers.
  - Move old fish-related images to the extras subpackage.
* Thu Jul 08 2010 dimstar@opensuse.org
  - Update to version 2.31.4:
    + More GSeal fixes
    + Stop using deprecated GTK+ API
    + libpanel-applet
    - Update to GDBus API change
    - Add gobject-introspection support
    + Clock Applet
    - Add -lm when linking the clock applet
    + Notification Area Applet
    - Fix issues with old-style multiscreen setups
    + Misc
    - Make automatic detection of bonobo work in configure
  - Changes from version 2.31.2:
    + All
    - Provide a dbus-based applet library
    - Keep an optional bonobo-based applet library
    + Panel
    - Make sure that newly-created panels become unhidden
    + Misc
    - Require glib 2.25.7
    - Make orbit and bonobo dependencies optional
    + Updated translations.
  - Drop gnome-panel-bnc363981-intlclock-compatibility.patch, as the
    change away from bonobo obsoletes this.
* Fri Jun 04 2010 coolo@novell.com
  - fix baselibs.conf for the previous change
* Sun May 23 2010 guido+opensuse.org@berhoerster.name
  - Split off libpanel-applet-2-0 subpackage
* Sat Apr 24 2010 coolo@novell.com
  - buildrequire pkg-config to fix provides
* Tue Mar 30 2010 vuntz@opensuse.org
  - Update to version 2.30.0:
    + Updated translations.
* Fri Mar 12 2010 dimstar@opensuse.org
  - Update to version 2.29.92.1:
    + Panel: Fix crash when using the main menu
    + Misc: Add configure summary
    + Updated translations.
* Tue Mar 09 2010 dimstar@opensuse.org
  - Update to version 2.29.92:
    + Panel:
    - Display GenericName in tooltip if there's no Comment
    - Fix applet right-sticking on screen resolution change
    - Make email addresses hyperlinks in about dialog
    - Use special XDG directory icon names
    + All Applets:
    - Build with latest GSeal'ed GTK+
    + Clock Applet:
    - Fix wrong string in documentation
    - Use icon fallbacks if the theme does not include phases of
      moon
    - Validate input in add location dialog
    + Notification Area Applet:
    - Make location of standard status icons predictable
    + Updated translations.
* Mon Feb 22 2010 vuntz@opensuse.org
  - Update to version 2.29.91:
    + Panel
    - Add X-GNOME-AutoRestart to desktop file
    + Clock Applet
    - Make sunrise/sunset and other times follow the 12/24h
      preference
    + Updated translations.
* Wed Jan 27 2010 vuntz@opensuse.org
  - Update to version 2.29.6:
    + Panel
    - Load applets in a high-priority idle loop on startup
    - Build fix
    + Clock Applet
    - Updated documentation
    + Updated translations.
* Fri Jan 15 2010 vuntz@opensuse.org
  - Do not package en@shaw locale on openSUSE 11.2 and earlier.
* Fri Jan 15 2010 vuntz@opensuse.org
  - Remove libgnomeui-devel BuildRequires.
  - Fix self-obsoletion of intlclock.
* Fri Jan 15 2010 captain.magnus@opensuse.org
  - Update to version 2.29.5.1:
    + Panel
    - Update latest EggSMClient code, which requires no
      panel-specific patch
    - Fix potential crash when creating a launcher with drag and
      drop
    - Make sure to initialize bonobo
    + Clock Applet
    - Avoid unnecessary wakeups when monitoring non-existing
      timezone files
    + Misc
    - Require gnome-desktop >= 2.24.0
    + Translation updates
* Thu Jan 14 2010 captain.magnus@opensuse.org
  - Update to version 2.29.5:
    + Panel
    - Use a native window for PanelWidget to fix uglyness on unhide
    - Fix crashes in various conditions with the new randr code
    - Fix important regression in very important code
    - Fix crash with malicious .gtk-bookmarks
    - Impose a limit on the size of the bookmarks file
    - Port code away from libgnome and libgnomeui
    - Do not add (deprecated) Encoding key when creating desktop
      files
    + Clock Applet
    - Remove hack for gravity that was needed with earlier pango
    - Check errors returned by PolicyKit
    - Deprecate gmt_time gconf key
    + Misc
    - Build fixes
    - Remove dependency on libgnome and libgnomeui
    - Add configure check for libcanberra-gtk
    - Add configure check for ice and sm (X libraries)
    + Translation updates
  - Add libcanberra-devel to BuildRequires.
  - Remove gnome-panel-fix-ugly-unhide.patch. Fixed upstream
  - Remove gnome-panel-randr-crashes.patch. Fixed upstream
  - Update the following patches to apply with fuzz=0:
    gnome-panel-2-11-bring-back-my-run-item.patch,
    gnome-panel-alt-f1-slab.patch, gnome-panel-beagle-search.patch,
    gnome-panel-bnc356242-recently-used-apps-hidden.patch,
    gnome-panel-bnc363981-intlclock-compatibility.patch,
    gnome-panel-main-menu-name.patch,
    gnome-panel-recent-check-exists.patch,
    gnome-panel-recently-used-apps.patch
* Tue Jan 05 2010 jengelh@medozas.de
  - Package baselibs.conf
* Wed Dec 02 2009 vuntz@opensuse.org
  - Update the way we remove the ha, la, ig locales for old versions
    of openSUSE.
* Tue Oct 06 2009 vuntz@opensuse.org
  - Add gnome-panel-randr-crashes.patch to fix some crashes on
    startup because of the randr code. Fix bnc#543876.
  - Add gnome-panel-fix-ugly-unhide.patch to fix some uglyness on
    unhiding a auto-hidden panel. Patch from upstream.
* Tue Sep 22 2009 dimstar@opensuse.org
  - Update to version 2.28.0:
    + Updated translations.
* Wed Sep 09 2009 vuntz@opensuse.org
  - Update to version 2.27.92:
    + Panel
    - Add shebang to gnome-panel-add script
    - Use display name instead of name for menu items This implies
      we now support the X-GNOME-FullName key.
    - Make the desktop item editor not emit signals on startup
    - Support X-GNOME-FullName in the desktop item editor
    - Always show icons for categories in the applications menu
    + Clock Applet
    - Update the time when the user clicks to open calendar
    + Wnck Applets
    - Fix spin buttons not working in workspace switcher
      preferences
    + Misc
    - Require gnome-menus 2.27.92
    - Ship the desktop.in files in tarball, not pre-build .desktop
  - Respin gnome-panel-2-11-bring-back-my-run-item.patch.
  - Add gconf2-devel Requires to devel package.
* Wed Aug 26 2009 vuntz@novell.com
  - Update to version 2.27.91:
    + Panel
    - Drop dead code
    - Don't show icons icons for actions and categories
    - Remove use of GnomeEntry in run dialog
    - Port to GtkBuilder
    - Make the run button icon respect the desktop-wide setting
    - Add gnome-panel-add script to allow easy addition of applets
    - Use g_timeout_add_seconds to reduce wakeups
    - Ignore overlapping monitors and just use the largest one
    - Put LVDS as first monitor
    - Correctly set struts when two panels are right-oriented
    - Use /desktop/gnome/lockdown/disable_lock_screen
    - Use a different define for the size of the Applications menu
      icon
    - Clarify warning message at forced quit
    - Make sure to preload /apps/panel/general early enough
    - Remove empty labels from translation
    - Do not use non-existing monitors for toplevels
    - Do not save monitor changes that are caused by constraints
    - Use randr 1.3 features to detect the first monitor when
      possible
    - Use XRRGetScreenResourcesCurrent() when possible
    - Improve check for LVDS-named output
    - Remove deprecated Encoding key from desktop file
    + libpanel-applet
    - Port to GtkBuilder
    + All Applets
    - Port to GtkBuilder
    + Clock Applet
    - Change "Clock Options" label to "Clock Format"
    - Launch the configured calendar/tasks application instead of
      evolution
    - Port to PolicyKit 1
    - Make default PolicyKit configuration stricter
    - Do not crash when setting time/timezone without PolicyKit
    - Do not use obsolete and unneeded daylight variable
    - Fix confusion between GTime and time_t
    - Add missing mnemonics and window title
    - Use g_timeout_add_seconds to reduce wakeups
    - Do not place on the map locations with lat = 0 and lon = 0
    - Make it possible to change the name of a location
    - Add/improve translator comments
    - Code cleanups
    + Notification Area Applet
    - Allow more flexibility for NaTrayChild compositing
    - Use g_timeout_add_seconds to reduce wakeups
    + Misc
    - Add ACLOCAL_AMFLAGS
    - Use silent-rules instead of shave for quiet build
    - Remove workaround for scrollkeeper
    - Remove libglade dependency
    - Require libgweather 2.27.90
    + Updated translations.
  - Remove PolicyKit-devel, PolicyKit-gnome-devel BuildRequires.
  - Add polkit-devel BuildRequires.
  - Respin gnome-panel-beagle-search.patch and
    gnome-panel-recently-used-apps.patch.
* Mon Jul 20 2009 vuntz@novell.com
  - Update to version 2.27.4:
    + Panel
    - Make the kill message of the action protocol work
    - Add missing animation_speed keys to default panel config
    - Make auto-hiding more reactive by tweaking default settings
    - Fix Command mnemonic in launcher editor
    - Fix crash when clicking launcher on second screen
    - Always show icons in panel menus
    + libpanel-applet
    - Fix critical warning when an applet is created
    + Clock Applet
    - Fix some small UI issues in the clock applet
    - Remove dead code
    + Notification Area Applet
    - Remove focus padding from status area
    + Misc
    - Remove now useless --with-clock-time-utility configure option
    + Docs
    - Remove deprecated help files
    - Update metadata for some help files
    + Updated translations.
  - Use libexecdir for normal applets.
* Wed May 20 2009 vuntz@novell.com
  - Update to version 2.26.2:
    + libpanel-applet
    - Only associate gconf keys with schemas when needed
    - Work-around new gconf bug that make the applets not see the
      default values in gconf
    + Clock Applet
    - Remove <requires-version> from glade file
    + Misc build system changes.
    + Updated translations.
  - Remove --with-clock-time-utility configure flag: it's useless now
    (it's using some PolicyKit stuff).
  - Remove scrollkeeper hack: it's not needed anymore.
  - Do not package omf files twice.
* Wed Apr 29 2009 vuntz@novell.com
  - Move gconf entries file from /etc/gconf/macros to
    /usr/share/gconf/macros. This is part of fate#305318.
* Wed Apr 15 2009 vuntz@novell.com
  - Update to version 2.26.1:
    + Panel
    - Display the right icons for locations in the menu
    + Updated translations.
* Tue Mar 17 2009 vuntz@novell.com
  - Update to version 2.26.0:
    + Panel
    - Ignore shadow mounts in the panel menus
    - Mark desktop files as trusted when it makes sense
    + Clock Applet
    - Fix bad memory usage for a string returned by libical
    + Misc
    - Remove scrollkeeper check, since it belongs to
      gnome-doc-utils
    + Updated translations
  - Remove scrollkeeper BuildRequires.
  - Remove -fno-strict-aliasing from CFLAGS.
* Fri Mar 06 2009 vuntz@novell.com
  - Update to version 2.25.92:
    + Panel
    - Fix some randr-interaction by connecting to the
      monitors-changed signal.
    - Use close button instead of ok button in error dialogs
    + All Applets
    - Use close button instead of ok button in error dialogs
    + Updated translations.

Files

/usr/lib/libpanel-applet-2.so.0
/usr/lib/libpanel-applet-2.so.0.2.73


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Dec 10 10:41:11 2014