Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgd-devel-2.2.2-1.1.mga5 RPM for i586

From Mageia 5 for i586 / media / core / updates

Name: libgd-devel Distribution: Mageia
Version: 2.2.2 Vendor: Mageia.Org
Release: 1.1.mga5 Build date: Thu Jun 30 16:47:14 2016
Group: Development/C Build host: rabbit.mageia.org
Size: 133126 Source RPM: libgd-2.2.2-1.1.mga5.src.rpm
Packager: luigiwalser <luigiwalser>
Url: http://www.libgd.org/
Summary: The development libraries and header files for gd
gd is a graphics library. It allows your code to quickly draw images complete
with lines, arcs, text, multiple colors, cut and paste from other images, and
flood fills, and write out the result as a PNG or JPEG file. This is
particularly useful in World Wide Webapplications, where PNG and JPEG are two
of the formats accepted for in-line images by most browsers.

gd is not a paint program. If you are looking for a paint program, you are
looking in the wrong place. If you are not a programmer, you are looking in the
wrong place.

gd does not provide for every possible desirable graphics operation. It is not
necessary or desirable for gd to become a kitchen-sink graphics package, but
version 1.7.3 incorporates most of the commonly requested features for an 8-bit
2D package.

These are the development libraries and header files for gd, the .png and .jpeg
graphics library. If you're installing the gd graphics library, you'll probably
want to install gd-devel.

Provides

Requires

License

BSD-like

Changelog

* Thu Jun 30 2016 luigiwalser <luigiwalser> 2.2.2-1.1.mga5
  + Revision: 1038202
  - add upstream patch to fix CVE-2016-5766
  - add binary test case for CVE-2016-5766 as Source1
  - add upstream patch to fix CVE-2016-6128
  - 2.2.2
  - BR libwebp, not vpx, for webp support
  - re-enable webp support (BR libvpx)
  - 2.2.1
  - add upstream patch to fix CVE-2015-8877
  - add upstream patch to fix CVE-2015-8874
  - add upstream patch to fix CVE-2016-3074
* Mon Feb 02 2015 oden <oden> 2.1.1-1.mga5
  + Revision: 813085
  - 2.1.1
* Fri Jan 23 2015 luigiwalser <luigiwalser> 2.1.0-8.mga5
  + Revision: 812017
  - add upstream changes to fix possible buffer read overflow (php#68601)
* Wed Oct 15 2014 umeabot <umeabot> 2.1.0-7.mga5
  + Revision: 742130
  - Second Mageia 5 Mass Rebuild
* Tue Sep 16 2014 umeabot <umeabot> 2.1.0-6.mga5
  + Revision: 681475
  - Mageia 5 Mass Rebuild
* Thu Aug 21 2014 luigiwalser <luigiwalser> 2.1.0-5.mga5
  + Revision: 666100
  - use libgd upstream CVE-2014-2497 patch
* Thu Jun 12 2014 luigiwalser <luigiwalser> 2.1.0-4.mga5
  + Revision: 635830
  - add patch from PHP bug 66901 to fix CVE-2014-2497 (thx to opensuse for the ref)
* Sat Oct 19 2013 umeabot <umeabot> 2.1.0-3.mga4
  + Revision: 530325
  - Mageia 4 Mass Rebuild
* Mon Jul 22 2013 oden <oden> 2.1.0-2.mga4
  + Revision: 457139
  - sync with php-5.5.1
* Thu Jul 11 2013 oden <oden> 2.1.0-1.mga4
  + Revision: 452893
  - 2.1.0

Files

/usr/bin/gdlib-config
/usr/bin/multiarch-i386-linux/gdlib-config
/usr/include/entities.h
/usr/include/gd.h
/usr/include/gd_color_map.h
/usr/include/gd_errors.h
/usr/include/gd_io.h
/usr/include/gdcache.h
/usr/include/gdfontg.h
/usr/include/gdfontl.h
/usr/include/gdfontmb.h
/usr/include/gdfonts.h
/usr/include/gdfontt.h
/usr/include/gdfx.h
/usr/include/gdhelpers.h
/usr/include/gdpp.h
/usr/include/multiarch-i386-linux/gd.h
/usr/include/multiarch-i386-linux/gd_io.h
/usr/include/multiarch-i386-linux/gdfx.h
/usr/lib/libgd.so
/usr/lib/pkgconfig/gdlib.pc
/usr/share/doc/libgd-devel
/usr/share/doc/libgd-devel/NEWS


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 10 09:38:51 2018