Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

php-zlib-5.5.29-1.mga4 RPM for i586

From Mageia 4 for i586 / media / core / updates

Name: php-zlib Distribution: Mageia
Version: 5.5.29 Vendor: Mageia.Org
Release: 1.mga4 Build date: Fri Sep 4 19:33:48 2015
Group: Development/PHP Build host: sucuk.mageia.org
Size: 35772 Source RPM: php-5.5.29-1.mga4.src.rpm
Packager: luigiwalser <luigiwalser>
Url: http://www.php.net/zlib
Summary: Zlib extension module for PHP
This is a dynamic shared object (DSO) for PHP that will add zlib compression
support to PHP.

Provides

Requires

License

PHP License

Changelog

* Fri Sep 04 2015 luigiwalser <luigiwalser> 3:5.5.29-1.mga4
  + Revision: 872775
  - 5.5.29
  - 5.5.28
  - 5.5.27
  - 5.5.26
  - 5.5.25
  - 5.5.24
  - remove upstreamed CVE-2015-135[12] patches
  - 5.5.23
  - remove upstream patch for php#68942
  - remove CVE-2015-2305 patch (fixed upstream)
  - add patch from dragonflybsd via debian to fix CVE-2015-2305
  - add upstream patch to fix secondary issue in php#68942
  - 5.5.22
  - rediff patch 25
  - rediff upstream patches to fix CVE-2015-1351 and CVE-2015-1352
  - 5.5.21
  - 5.5.20
  - rediff patches 3 and 20
  - 5.5.19
  - remove CVE-2014-3710 patch (fixed upstream in 5.5.19)
  - add upstream patch to fix CVE-2014-3710
  - 5.5.16
  - remove upstreamed CVE-2014-3538 patch
  - 5.5.14
  - 5.5.13
  - 5.5.11
  
    + oden <oden>
      - jsonc-1.3.7 (http://pecl.php.net/package-changelog.php?package=jsonc&release=1.3.7)
      - fix #13820 (PHP zip makes httpd crash when adding file to an archive.)
      - 5.5.18 (fixes CVE-2014-3669, CVE-2014-3670, CVE-2014-3668)
      - P230: security fix for CVE-2014-3538 (upstream)
      - 5.5.15
      - jsonc-1.3.6
      - 5.5.12
      - jsonc-1.3.5
      - P23: rediff
      - also sync spec file changes with cauldron
      - sync patches with cauldron
      - 5.5.10
      - jsonc-1.3.4
* Tue Jan 14 2014 luigiwalser <luigiwalser> 3:5.5.8-2.mga4
  + Revision: 566586
  - do not reload httpd when it is not running in filetriggers
* Tue Jan 14 2014 oden <oden> 3:5.5.8-1.mga4
  + Revision: 566544
  - 5.5.8
  - rediff the external libzip patch
  - jsonc-1.3.3
* Fri Dec 13 2013 luigiwalser <luigiwalser> 3:5.5.7-1.mga4
  + Revision: 556537
  - 5.5.7
* Fri Nov 22 2013 oden <oden> 3:5.5.6-1.mga4
  + Revision: 552282
  - rediff some patches
  - 5.5.6
* Tue Oct 22 2013 oden <oden> 3:5.5.5-1.mga4
  + Revision: 545808
  - 5.5.5 (http://www.php.net/ChangeLog-5.php#5.5.5)
* Mon Oct 21 2013 umeabot <umeabot> 3:5.5.4-3.mga4
  + Revision: 537673
  - Mageia 4 Mass Rebuild
* Fri Sep 27 2013 fwang <fwang> 3:5.5.4-2.mga4
  + Revision: 487500
  - rebuild for icu 52
* Fri Sep 20 2013 fwang <fwang> 3:5.5.4-1.mga4
  + Revision: 481811
  - 5.5.4 final
* Tue Sep 10 2013 fwang <fwang> 3:5.5.4-0.0.RC1.3.mga4
  + Revision: 477030
  - rebuild for new postgresql
* Mon Sep 09 2013 oden <oden> 3:5.5.4-0.0.RC1.2.mga4
  + Revision: 476668
  - jsonc-1.3.2
* Fri Sep 06 2013 oden <oden> 3:5.5.4-0.0.RC1.1.mga4
  + Revision: 475425
  - 5.5.4RC1
  - rediffed some patches
* Tue Aug 27 2013 luigiwalser <luigiwalser> 3:5.5.3-2.mga4
  + Revision: 472083
  - rebuild for cyrus-sasl
  
    + fwang <fwang>
      - add descriptive url
* Fri Aug 23 2013 fwang <fwang> 3:5.5.3-1.mga4
  + Revision: 470029
  - new version 5.5.3
  
    + oden <oden>
      - fix #8538 (There is an undocumented hard-coded limit of 24 minutes on PHP session lifetime)
      - fix #10331 (php-sqlite3 does not obsolete php-sqlite)
      - 5.5.2
      - rediff some patches
* Mon Jul 22 2013 oden <oden> 3:5.5.1-1.mga4
  + Revision: 457143
  - 5.5.1
  - P50: rediff
  - fix the php-test.ini file according to needed loading sequence
  - fix the loading of opcache
  - keep all the sources in php-devel for easier post-testing
* Fri Jun 28 2013 oden <oden> 3:5.5.0-5.mga4
  + Revision: 447732
  - add back the deprecated php-mysql package (fixes #10628)
* Mon Jun 24 2013 blino <blino> 3:5.5.0-4.mga4
  + Revision: 446070
  - buildrequire mysql-devel for mysql_config
* Sun Jun 23 2013 blino <blino> 3:5.5.0-3.mga4
  + Revision: 446060
  - mysqlnd: detect mysql unix socket path with mysql_config (this fixes mysqli and pdo_mysql)
* Sun Jun 23 2013 blino <blino> 3:5.5.0-2.mga4
  + Revision: 445794
  - specify back mysql socket path at configure (to fix mysqli)
* Fri Jun 21 2013 oden <oden> 3:5.5.0-1.mga4
  + Revision: 445354
  - 5.5.0
  - P11 & P25: newer rediffed patches from fedora
  - P30: rediff
  - the mysql extension is deprecated, so might as well remove it now...
* Thu Jun 13 2013 oden <oden> 3:5.5.0-0.0.RC3.4.mga4
  + Revision: 442540
  - bump release
  - fix the php-fpm.service file (Remi Collet)
  - add some conflicts for the php-opcache sub package
* Thu Jun 13 2013 oden <oden> 3:5.5.0-0.0.RC3.3.mga4
  + Revision: 442476
  - use /run/php-fpm
  - add systemd to php-fpm (Remi Collet)
* Thu Jun 13 2013 oden <oden> 3:5.5.0-0.0.RC3.2.mga4
  + Revision: 442375
  - S10: use json from pecl due to licensing issues
  
    + fwang <fwang>
      - deprecate mysql extension
* Sun Jun 09 2013 oden <oden> 3:5.5.0-0.0.RC3.1.mga4
  + Revision: 441224
  - 5.5.0RC3
  - bye, bye logos and the eastern egg crap (drop P302+P303)
  - P2: patch and use the php.ini-production file because the shipped php.ini file is several years old...
  - P20: rediff
  - say hello to opcache
* Sun Jun 09 2013 oden <oden> 3:5.4.16-1.mga4
  + Revision: 441117
  - 5.4.16 (fixes CVE-2013-2110)
  - rediffed P25
* Mon Jun 03 2013 fwang <fwang> 3:5.4.15-3.mga4
  + Revision: 435546
  - rebuild for new libpng
* Tue May 28 2013 oden <oden> 3:5.4.15-2.mga4
  + Revision: 429242
  - use ext/gd from php-5.5.0RC2 for now
* Sun May 26 2013 oden <oden> 3:5.4.15-1.mga4
  + Revision: 428167
  - 5.4.15
  - rediffed P25
  - use the new libgd 2.1.x that should render the php-gd-bundled package obsolete
* Sun May 26 2013 fwang <fwang> 3:5.4.13-4.mga4
  + Revision: 427995
  - rebuild for new icu
* Fri Apr 26 2013 fwang <fwang> 3:5.4.13-3.mga3
  + Revision: 411308
  - fix systemd unit file so that it can start correctly (bug#9844)
* Sun Mar 24 2013 colin <colin> 3:5.4.13-2.mga3
  + Revision: 404859
  - Add systemd requires and general post/pre fixes (mga#9302)
* Fri Mar 15 2013 oden <oden> 3:5.4.13-1.mga3
  + Revision: 403244
  - 5.4.13 (fixes CVE-2013-1635, CVE-2013-1643)
* Tue Mar 05 2013 oden <oden> 3:5.4.12-2.mga3
  + Revision: 401489
  - P303: added a new mageia logo by R?\195?\169mi Verschelde
* Fri Feb 22 2013 oden <oden> 3:5.4.12-1.mga3
  + Revision: 399881
  - 5.4.12
* Thu Jan 31 2013 luigiwalser <luigiwalser> 3:5.4.11-2.mga3
  + Revision: 393831
  - rebuild for icu
* Mon Jan 21 2013 oden <oden> 3:5.4.11-1.mga3
  + Revision: 390585
  - 5.4.11 (http://php.net/ChangeLog-5.php#5.4.11)
* Thu Jan 17 2013 colin <colin> 3:5.4.10-5.mga3
  + Revision: 388944
  - Use tmpfiles for php-fpm runtime dir creation
* Wed Jan 09 2013 spuhler <spuhler> 3:5.4.10-4.mga3
  + Revision: 343541
  - reversed threadsafe build
* Sat Jan 05 2013 spuhler <spuhler> 3:5.4.10-3.mga3
  + Revision: 339336
  - built threadsafe
* Wed Dec 26 2012 oden <oden> 3:5.4.10-2.mga3
  + Revision: 335433
  - make it backportable
* Fri Dec 21 2012 fwang <fwang> 3:5.4.10-1.mga3
  + Revision: 333629
  - new version 5.4.10
* Sat Dec 01 2012 fwang <fwang> 3:5.4.9-3.mga3
  + Revision: 323654
  - rebuild for new pcre
* Sat Nov 24 2012 oden <oden> 3:5.4.9-2.mga3
  + Revision: 321559
  - maybe better configure line now...
  - rebuild
  - remove pok crap
  - merge firebird (interbase) into this package
* Sat Nov 24 2012 fwang <fwang> 3:5.4.9-1.mga3
  + Revision: 321476
  - new version 5.4.9
  
    + oden <oden>
      - whoops. didn't realize php-5.4 only has sqlite3 support.
      - fix #8164 (php-sqlite3 obsoletes php-sqlite)
* Fri Nov 09 2012 fwang <fwang> 3:5.4.8-9.mga3
  + Revision: 316669
  - rebuild for updated icu
* Tue Nov 06 2012 fwang <fwang> 3:5.4.8-8.mga3
  + Revision: 314746
  - rebuild for new icu
* Thu Oct 25 2012 fwang <fwang> 3:5.4.8-7.mga3
  + Revision: 309900
  - recognize more recent jpeg version
  - update description
  
    + luigiwalser <luigiwalser>
      - use macros for php-fpm service
      - php-fpm requires webserver-base for apache user
      - php-cli provides /usr/bin/php (mga#6534)
* Tue Oct 23 2012 fwang <fwang> 3:5.4.8-6.mga3
  + Revision: 309398
  - prepare to build pdo_mysql-bundled
  - note for mysqlnd
* Fri Oct 19 2012 fwang <fwang> 3:5.4.8-5.mga3
  + Revision: 308312
  - force load mysqlnd before mysql exts
* Fri Oct 19 2012 fwang <fwang> 3:5.4.8-4.mga3
  + Revision: 308152
  - specify ldflags
  - enable vpx support
* Fri Oct 19 2012 fwang <fwang> 3:5.4.8-3.mga3
  + Revision: 308147
  - all mysql exts are now using mysqlnd now
* Fri Oct 19 2012 fwang <fwang> 3:5.4.8-2.mga3
  + Revision: 308140
  - build with mysqlnd per default upstream
* Fri Oct 19 2012 fwang <fwang> 3:5.4.8-1.mga3
  + Revision: 308062
  - new version 5.4.8
* Wed Oct 17 2012 obgr_seneca <obgr_seneca> 3:5.4.7-2.mga3
  + Revision: 307677
  - Add requires for webserver-base in php-session
* Mon Sep 17 2012 fwang <fwang> 3:5.4.7-1.mga3
  + Revision: 294677
  - new version 5.4.7
* Wed Sep 12 2012 oden <oden> 3:5.4.6-1.mga3
  + Revision: 292568
  - remove libphp5.so from file lists as well
  - 5.4.6
  - make mod_php the more correct way
  
    + spuhler <spuhler>
      - upgrade to 5.4.6

Files

/etc/php.d/21_zlib.ini
/usr/lib/php/extensions/zlib.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri May 11 08:43:33 2018